Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Debug IP icmp....

Hi,

Need  help for resolving this issue

Infrastructure..

We have one RouterA ----Fa2/0.202------------connected to Switch(Gi0/2)-----------------RouterB(Gi1/7)

IF i try to ping from Router A to Router B, getting request timed out...I have done the debug also...but still unable to resolve that.

Need your help.....

Debug--ip icmp

Oct  6 02:13:53 IST:     ICMP type=8, code=0

Oct  6 02:13:53 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, encapsulation failed

Oct  6 02:13:53 IST:     ICMP type=8, code=0

Oct  6 02:13:55 IST: IP: tableid=0, s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), routed via RIB

Oct  6 02:13:55 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, sending

Oct  6 02:13:55 IST:     ICMP type=8, code=0

Oct  6 02:13:55 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, encapsulation failed

Oct  6 02:13:55 IST:     ICMP type=8, code=0

Oct  6 02:13:57 IST: IP: tableid=0, s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), routed via RIB

Oct  6 02:13:57 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, sending

Oct  6 02:13:57 IST:     ICMP type=8, code=0

Oct  6 02:13:57 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, encapsulation failed

Oct  6 02:13:57 IST:     ICMP type=8, code=0

Oct  6 02:13:59 IST: IP: tableid=0, s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), routed via RIB

Oct  6 02:13:59 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, sending

Oct  6 02:13:59 IST:     ICMP type=8, code=0

Oct  6 02:13:59 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, encapsulation failed

Oct  6 02:13:59 IST:     ICMP type=8, code=0

Oct  6 02:14:01 IST: IP: tableid=0, s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), routed via RIB

Oct  6 02:14:01 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, sending

Oct  6 02:14:01 IST:     ICMP type=8, code=0

Oct  6 02:14:01 IST: IP: s=200.200.200.18 (local), d=200.200.200.21 (FastEthernet2/0.202), len 100, encapsulation failed

1 ACCEPTED SOLUTION

Accepted Solutions

Debug IP icmp....

Hello Arindam,

First of all remember to rate all of the helpful posts.

now going to your scenario, Encapsulation failed messages in this scenarios let us know that the packet knows where to send the packet but it does now know how to do it.

We are handeling an Ethernet network so we are having some troubles with ARP.

We basically do not know what's the MAC addres of the IP address we are trying to ping so we are unable to build the L2 information for the packet hence "encapsulation failed"

That being said make sure the L2 network is properly designed (Check Trunk links, Port-status, VLAN databases, etc) afterwards you should be good my friend.

For more information about Core and Security Networking follow my website at http://laguiadelnetworking.com

Any question contact me at jcarvaja@laguiadelnetworking.com

Cheers,

Julio Carvajal Segura

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
4 REPLIES
Green

Debug IP icmp....

Arindam,

Can you post the configs of

Router A int fas 2/0.202

Both switch port configs

Router B int gi1/7

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Community Member

Debug IP icmp....

Thankz Alex....

Now I am facing another issue, I have resolved the issue by doing shut/unshut  Subinterfaces and also reconfigured encapsulation dot1q tag... Now i am able to ping from Router A to Router B,

But now im not able to ping Router-B to Router A(reverse)

Debug ouput in reverse direction....

Oct  6 05:38:58: FIBipv4-packet-proc: route packet from (local) src 200.200.200.21 dst 200.200.200.18

Oct  6 05:38:58: FIBfwd-proc: Default:200.200.200.0/24 proces level forwarding

Oct  6 05:38:58: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Oct  6 05:38:58: FIBfwd-proc: try path 0 (of 1) v4-con-Vlan201 first short ext 0(-1)

Oct  6 05:38:58: FIBfwd-proc: v4-con-Vlan201 valid

Oct  6 05:38:58: FIBfwd-proc: Vlan201 no nh type 2  - deag

Oct  6 05:38:58: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none deag 1 chg_if 0 via fib 0 path type connected prefix

Oct  6 05:38:58: FIBfwd-proc: packet routed to Vlan201 p2p(0)

Oct  6 05:38:58: FIBipv4-packet-proc: packet routing succeeded

Oct  6 05:38:58: IP: tableid=0, s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), routed via FIB

Oct  6 05:38:58: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 ttlexp 0

Oct  6 05:38:58: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0

Oct  6 05:38:58: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, sending

Oct  6 05:38:58:     ICMP type=8, code=0

Oct  6 05:38:58: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, output feature

Oct  6 05:38:58:     ICMP type=8, code=0, HW Shortcut Installation(66), rtype 1, forus FALSE, sendself FALSE, mtu 0

Oct  6 05:38:58: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, encapsulation failed

Oct  6 05:38:58:     ICMP type=8, code=0.

Oct  6 05:39:00: FIBipv4-packet-proc: route packet from (local) src 200.200.200.21 dst 200.200.200.18

Oct  6 05:39:00: FIBfwd-proc: Default:200.200.200.0/24 proces level forwarding

Oct  6 05:39:00: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Oct  6 05:39:00: FIBfwd-proc: try path 0 (of 1) v4-con-Vlan201 first short ext 0(-1)

Oct  6 05:39:00: FIBfwd-proc: v4-con-Vlan201 valid

Oct  6 05:39:00: FIBfwd-proc: Vlan201 no nh type 2  - deag

Oct  6 05:39:00: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none deag 1 chg_if 0 via fib 0 path type connected prefix

Oct  6 05:39:00: FIBfwd-proc: packet routed to Vlan201 p2p(0)

Oct  6 05:39:00: FIBipv4-packet-proc: packet routing succeeded

Oct  6 05:39:00: IP: tableid=0, s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), routed via FIB

Oct  6 05:39:00: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 ttlexp 0

Oct  6 05:39:00: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0

Oct  6 05:39:00: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, sending

Oct  6 05:39:00:     ICMP type=8, code=0

Oct  6 05:39:00: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, output feature

Oct  6 05:39:00:     ICMP type=8, code=0, HW Shortcut Installation(66), rtype 1, forus FALSE, sendself FALSE, mtu 0

Oct  6 05:39:00: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, encapsulation failed

Oct  6 05:39:00:     ICMP type=8, code=0.

Oct  6 05:39:02: FIBipv4-packet-proc: route packet from (local) src 200.200.200.21 dst 200.200.200.18

Oct  6 05:39:02: FIBfwd-proc: Default:200.200.200.0/24 proces level forwarding

Oct  6 05:39:02: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Oct  6 05:39:02: FIBfwd-proc: try path 0 (of 1) v4-con-Vlan201 first short ext 0(-1)

Oct  6 05:39:02: FIBfwd-proc: v4-con-Vlan201 valid

Oct  6 05:39:02: FIBfwd-proc: Vlan201 no nh type 2  - deag

Oct  6 05:39:02: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none deag 1 chg_if 0 via fib 0 path type connected prefix

Oct  6 05:39:02: FIBfwd-proc: packet routed to Vlan201 p2p(0)

Oct  6 05:39:02: FIBipv4-packet-proc: packet routing succeeded

Oct  6 05:39:02: IP: tableid=0, s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), routed via FIB

Oct  6 05:39:02: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 ttlexp 0

Oct  6 05:39:02: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0

Oct  6 05:39:02: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, sending

Oct  6 05:39:02:     ICMP type=8, code=0

Oct  6 05:39:02: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, output feature

Oct  6 05:39:02:     ICMP type=8, code=0, HW Shortcut Installation(66), rtype 1, forus FALSE, sendself FALSE, mtu 0

Oct  6 05:39:02: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, encapsulation failed

Oct  6 05:39:02:     ICMP type=8, code=0.

Oct  6 05:39:04: FIBipv4-packet-proc: route packet from (local) src 200.200.200.21 dst 200.200.200.18

Oct  6 05:39:04: FIBfwd-proc: Default:200.200.200.0/24 proces level forwarding

Oct  6 05:39:04: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Oct  6 05:39:04: FIBfwd-proc: try path 0 (of 1) v4-con-Vlan201 first short ext 0(-1)

Oct  6 05:39:04: FIBfwd-proc: v4-con-Vlan201 valid

Oct  6 05:39:04: FIBfwd-proc: Vlan201 no nh type 2  - deag

Oct  6 05:39:04: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none deag 1 chg_if 0 via fib 0 path type connected prefix

Oct  6 05:39:04: FIBfwd-proc: packet routed to Vlan201 p2p(0)

Oct  6 05:39:04: FIBipv4-packet-proc: packet routing succeeded

Oct  6 05:39:04: IP: tableid=0, s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), routed via FIB

Oct  6 05:39:04: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 ttlexp 0

Oct  6 05:39:04: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0

Oct  6 05:39:04: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, sending

Oct  6 05:39:04:     ICMP type=8, code=0

Oct  6 05:39:04: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, output feature

Oct  6 05:39:04:     ICMP type=8, code=0, HW Shortcut Installation(66), rtype 1, forus FALSE, sendself FALSE, mtu 0

Oct  6 05:39:04: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, encapsulation failed

Oct  6 05:39:04:     ICMP type=8, code=0.

Oct  6 05:39:06: FIBipv4-packet-proc: route packet from (local) src 200.200.200.21 dst 200.200.200.18

Oct  6 05:39:06: FIBfwd-proc: Default:200.200.200.0/24 proces level forwarding

Oct  6 05:39:06: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Oct  6 05:39:06: FIBfwd-proc: try path 0 (of 1) v4-con-Vlan201 first short ext 0(-1)

Oct  6 05:39:06: FIBfwd-proc: v4-con-Vlan201 valid

Oct  6 05:39:06: FIBfwd-proc: Vlan201 no nh type 2  - deag

Oct  6 05:39:06: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none deag 1 chg_if 0 via fib 0 path type connected prefix

Oct  6 05:39:06: FIBfwd-proc: packet routed to Vlan201 p2p(0)

Oct  6 05:39:06: FIBipv4-packet-proc: packet routing succeeded

Oct  6 05:39:06: IP: tableid=0, s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), routed via FIB

Oct  6 05:39:06: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 ttlexp 0

Oct  6 05:39:06: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Vlan201 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0

Oct  6 05:39:06: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, sending

Oct  6 05:39:06:     ICMP type=8, code=0

Oct  6 05:39:06: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, output feature

Oct  6 05:39:06:     ICMP type=8, code=0, HW Shortcut Installation(66), rtype 1, forus FALSE, sendself FALSE, mtu 0

Oct  6 05:39:06: IP: s=200.200.200.21 (local), d=200.200.200.18 (Vlan201), len 100, encapsulation failed

Oct  6 05:39:06:     ICMP type=8, code=0.

Success rate is 0 percent (0/5)

CRTR103#unde all

All possible debugging has been turned off

CRTR103#

Debug IP icmp....

Hello Arindam,

First of all remember to rate all of the helpful posts.

now going to your scenario, Encapsulation failed messages in this scenarios let us know that the packet knows where to send the packet but it does now know how to do it.

We are handeling an Ethernet network so we are having some troubles with ARP.

We basically do not know what's the MAC addres of the IP address we are trying to ping so we are unable to build the L2 information for the packet hence "encapsulation failed"

That being said make sure the L2 network is properly designed (Check Trunk links, Port-status, VLAN databases, etc) afterwards you should be good my friend.

For more information about Core and Security Networking follow my website at http://laguiadelnetworking.com

Any question contact me at jcarvaja@laguiadelnetworking.com

Cheers,

Julio Carvajal Segura

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Community Member

Debug IP icmp....

Router A- Switch-Router B

Configuration of all three devices.

Problem : Am able to ping Router A to Router B, but unable to do from Router B to Router A

L2-Switch Configuration

interface GigabitEthernet0/1

description Back-to-Back MPLS Switches

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

description **** CONNECTED TO VPN RTR - FA2/0  ****

switchport access vlan 202

switchport mode access

interface GigabitEthernet0/24

description **** CONNECTED TO CRTR1  1/7 ****

switchport access vlan 202

switchport mode access

Router-A

interface FastEthernet2/0

no ip address

no ip redirects

n) ip unreachables

no ip proxy-arp

duplex auto

speed auto

!

interface FastEthernet2/0.202

encapsulation dot1Q 202

no cdp enable

standby 202 ip 200.200.200.20

standby 202 priority 120

standby 202 preempt

standby 202 name MPLS

!

Router-B(7609)


interface GigabitEthernet1/7

description **** CONNECTED TO MPLS SWITCH GI 0/24 ****

switchport

switchport access vlan 202

switchport mode access

speed 1000

L3 Vlan

interface Vlan201

ip address 200.200.200.21 255.255.255.0

standby 202 ip 200.200.200.23

standby 202 priority 120

standby 202 preempt

L2 Vlan

Vlan 202



516
Views
0
Helpful
4
Replies
CreatePlease to create content