Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Design Question: Voice and data vlans

Hi. I have kind of a design question on voice and data vlan routing. Equipment involved:

Router: Cisco 2811 for CME, two Fastethernet ports and NME module

Switch1: Cisco Catalyst 3750G-12S-S SMI 12 port Fiber with with sfp modules

Switch2: Cisco Catalyst 2960G-24TC with 2 gigabit sfp modules

Switch3: Cisco Catalyst 2960-24PC-L with one Gigabit SFP module

Other switches: 11 WS-C2960-8TC-L each with one gigabit sfp module

Connecting both Fastethernet ports on CME router to Switch2 Fastethenet ports

Connecting core switches together via

Switch SFP ports

11 Remote switches connecting via fiber to 12 port fiber switch

The functionality I need for voice and data vlans on all switches is to be able to plug in a PC or Cisco Phone into any ethernet port on any switch and receive either dhcp address for data or ip address and phone load for voice. The pc's will not be haging off a phone.

The voice router will not be connecting to the Internet. The Internet link will be an ASA 5505 on the data vlan.

I need a little help setting up the vlans for this functionality. I know I can do something like this on the switches:

interface Vlan10

ip address 192.168.10.23 255.255.255.0

ip helper-address 192.168.10.5

no ip route-cache

!

interface Vlan20

ip address 192.168.1.23 255.255.255.0

ip helper-address 192.168.1.15

no ip route-cache

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode access

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip trust

spanning-tree portfast

(fiber port):

interface GigabitEthernet0/21

switchport access vlan 20

switchport trunk native vlan 20

switchport trunk allowed vlan 10,20

switchport mode access

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

spanning-tree portfast

with router Addressing as follows:

interface FastEthernet0/0

ip address 192.168.10.5 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface Integrated-Service-Engine1/0

description Panoche Unity Express

ip unnumbered FastEthernet0/0

service-module ip address 192.168.10.1 255.255.255.0

service-module ip default-gateway 192.168.10.5

no keepalive

ip route 192.168.10.1 255.255.255.255 Integrated-Service-Engine1/0

!

But it is not working as I thought and the PC's cant ping all switches and some switches cant ping both router ip addresses, but all switches can ping the vlan ip addresses on switches.

I'm probably missing something simple, and could use some insight. I can post more detailed configs later, but this is the gist of it.

Any advice would be appreciated, I don't get to do this type of config often and am pretty rusty. Thanks in advance

1 REPLY
Hall of Fame Super Silver

Re: Design Question: Voice and data vlans

Hello James,

have you configured the two FE ports on switch2 one in vlan10 and one in vlan20 ?

also if you enable routing on the switches you need to set a default route the ip address of router in vlan 10 can bbe the next hop:

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.10.5

if you haven't enabled ip routing you need to configure a default gateway

no ip routing

ip default-gateway 192.168.10.5

this should fix the connectivity problem on switches.

Hope to help

Giuseppe

249
Views
0
Helpful
1
Replies
CreatePlease to create content