Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP across Trunk

I am plugging a device into FastEthernet 1/0/22.  I cannot get DHCP across the trunk.  Config is at link.  Any ideas? 

https://www.dropbox.com/s/gsyai3e94s170hv/FRS.rtf

Everyone's tags (3)
17 REPLIES
Community Member

DHCP across Trunk

More details: device is a lightweight AP that is configured for HREAP local routing.  Vlan support is enabled.  Natve vlan is 80.  No other vlan is specified.  I did have this setup prior with multiple vlans at play but tried to simplify it to troubleshoot. The interface on the AP has been configured entirely by the controller; however, I did ssh into it and verify that it was setup correctly with the proper encapsulation. 

The gateway and dhcp pool are on the same switch as the trunk.  This is what is throwing me. 

Also, when SSHed into the AP the switch shows up as a CDP neighbor but the AP does not show up as a neighbor to the switch. 

Switch - Show Version

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 26    WS-C3750-24P       12.2(55)SE6           C3750-IPSERVICESK9-M  

AP -

Product/Model Number                 : AIR-LAP1242AG-A-K9

DHCP across Trunk

Hello Josh.

I couldn't open the link for some reason... I got error web site not available for some reason...

Anyways.. I wonder if:

- Is the device connected to FA1/0/22 the AP?

- Is the int FA1/0/22 configured as a trunk?

- What if you connect a PC into FA1/0/22? is it getting an dinamyc IP address in vlan 80? if so the wired network is working fine and you have isolated the problem to be with the wireless connection, if the PC wired connected to int FA1/0/22 is still not able to get an IP address then the problem most be in the 3750 or behind it..

Try doing those steps to isolate the problem either with the wired or wireless connection to continue with the troubleshooting.

Regards.

Wilson B.

Community Member

DHCP across Trunk

I tried that.  No luck with the connected computer. I did that to troubleshoot at first and landed on the switch being the issue.  The config is at the other side of the link.

https://www.dropbox.com/s/gsyai3e94s170hv/FRS.rtf

Exerpts:

ip dhcp excluded-address 10.55.80.0 10.55.80.15

ip dhcp excluded-address 10.55.80.250 10.55.80.255

ip dhcp pool VLAN80

   network 10.55.80.0 255.255.255.0

   default-router 10.55.80.1

   dns-server 10.51.40.58 10.51.40.57

   domain-name gatewaystaff.com

   lease 0 8

vlan 80

interface FastEthernet1/0/22

description WAP FRI-03

switchport trunk encapsulation dot1q

switchport trunk native vlan 80

switchport trunk allowed vlan 80

switchport mode trunk

interface Vlan80

ip address 10.55.80.1 255.255.255.0

I also tried switchport nonegotiate

Hall of Fame Super Gold

Re: DHCP across Trunk

IF the AP is in FlexConnect/H-REAP is the AP connected to a Trunk port?

Post the output to the command "sh cdp n F1/0/22 det".

Community Member

DHCP across Trunk

It is in H-REAP mode and it works when the port is in access mode; however, not when trunked.  Because of this I can only use a single VLAN; however, I have a guest SSID/VLAN to broadcast. 

Community Member

Re: DHCP across Trunk

Hey

What happens if you remove;

switchport trunk allowed vlan 80

Maybe the switchport is dropping the data because it has no VLAN80 tag when entering the interface ?


Sent from Cisco Technical Support iPhone App

Community Member

DHCP across Trunk

Same thing with no switchport trunk allowed vlan80. 

FRS-B01-CMDF-SW1#sh cdp nei fastethernet 1/0/22 detail

Load for five secs: 5%/0%; one minute: 8%; five minutes: 7%

Time source is NTP, 18:13:45.406 CST Tue Oct 8 2013

Hall of Fame Super Gold

Re: DHCP across Trunk

Load for five secs: 5%/0%; one minute: 8%; five minutes: 7%

Time source is NTP, 18:13:45.406 CST Tue Oct 8 2011

What the heck is that?   This is the output to two different commands which I is not what I am requesting.

Community Member

DHCP across Trunk

 

FRS-B01-CMDF-SW1#sh cdp nei fastethernet 1/0/22 detail

Load for five secs: 5%/0%; one minute: 8%; five minutes: 7%

Time source is NTP, 18:13:45.406 CST Tue Oct 8 2013

FRS-B01-CMDF-SW1#sh cdp n F1/0/22 det

Load for five secs: 4%/0%; one minute: 6%; five minutes: 6%

Time source is NTP, 18:19:39.659 CST Tue Oct 8 2013

FRS-B01-CMDF-SW1#

This is what the output is.  I am not sure what to tell you.  It does not see the AP as a CDP neighbor.  It is odd.  That is why I am posting on this site.

Hall of Fame Super Gold

DHCP across Trunk

This is what the output is.  I am not sure what to tell you.  It does not see the AP as a CDP neighbor.  It is odd.  That is why I am posting on this site.

Try this:

conf t

cdp run

end

Wait for 30 seconds and run the "sh cdp neig f1/0/22 det" again.

And also add the output to the command "sh power inline".

Community Member

DHCP across Trunk

No luck.

FRS-B01-CMDF-SW1(config)#cdp run

FRS-B01-CMDF-SW1(config)#end

FRS-B01-CMDF-SW1#sh cdp neig f1/0/22 det

Load for five secs: 34%/0%; one minute: 10%; five minutes: 7%

Time source is NTP, 18:37:24.976 CST Tue Oct 8 2013

FRS-B01-CMDF-SW1#show power inline

FRS-B01-CMDF-SW1#show power inline fas

FRS-B01-CMDF-SW1#show power inline fastEthernet 1/0/22

Load for five secs: 5%/0%; one minute: 10%; five minutes: 7%

Time source is NTP, 18:37:36.670 CST Tue Oct 8 2013

Interface Admin  Oper       Power   Device              Class Max

                            (Watts)                           

--------- ------ ---------- ------- ------------------- ----- ----

Fa1/0/22  auto   on         15.4    Ieee PD             3     15.4

Interface  AdminPowerMax   AdminConsumption   

             (Watts)           (Watts)          

---------- --------------- -------------------- 

Fa1/0/22              15.4                 15.4

FRS-B01-CMDF-SW1#

Hall of Fame Super Gold

Re: DHCP across Trunk

FRS-B01-CMDF-SW1#show power inline fastEthernet 1/0/22

Load for five secs: 5%/0%; one minute: 10%; five minutes: 7%

Time source is NTP, 18:37:36.670 CST Tue Oct 8 2013

I know WTF this is.  Someone's put an EEM script.  Everytime you hit the "Enter" key, the system will take a snapshot of the first line of the "sh proc cpu" and the first line of the "sh ntp status".

Fa1/0/22  auto   on         15.4    Ieee PD             3     15.4

The IEEE bit only means one of three things:

1.  The AP is not properly negotiating PoE standard.  The switch, which can only push 15.4w PoE, is pushing the default value.

2.  Someone's turned off CDP all over the switch.

3.  You've got a cable problem.

Can you tell me what is the AP's LED like?  Is it blinking? 

In regards to #3, there's nothing I can help you because your switch is a non-GigabitEthernet 3750.  TDR is supported only when you have 3750G/E/X.  Let's investigate cable issues LAST.

Do this:

default interface Fast 1/0/22

interface FastEthernet1/0/22

shutdown

description WAP FRI-03

switchport trunk encapsulation dot1q

switchport trunk native vlan 80

switchport trunk allowed vlan 80

switchport mode trunk

no power inline never

cdp enable

no shutdown

Community Member

DHCP across Trunk

Got ya.  So the out come of sh cdp neigh f1/0/22 det is:

Blank.  Either way.  Anyone have any ideas about the issues regarding DHCP accross the trunk?  Works in access mode but no in trunk mode for both this AP that may or may not be junk.  But also for my computer. 

Re: DHCP across Trunk

Josh.

You said:

" Works in access mode but no in trunk mode for both this AP that may or may not be junk.  But also for my computer. "

If it works fine when it's an access port but not when it's a trunk, then must be a encapsulation issue between the switchport and the access point, that may also be the reason why you can't see the neighbour through cdp command.

Please connect the AP to the switch and post the output of the command show interfaces trunk, I wonder if it looks something like this below encapsulaton.

Cat3550#show interfaces trunk

Port         Mode         Encapsulation  Status        Native vlan

Fa0/17     trunk            non-802.1q     other           1

=========================================================================================

By the way my 3560 also displays the same output as yours when running sh cdp

F340.24.19-3500-3#show inter trunk

Load for five secs: 6%/0%; one minute: 6%; five minutes: 6%

No time source, *08:16:42.072 UTC Mon Mar 1 1993

... and I don't have any EEM ... I guess it's expected...

=========================================================================================

Regards.

Wilson B

Community Member

Re: DHCP across Trunk

FRS-B01-CMDF-SW1#show interfaces trunk

Load for five secs: 33%/0%; one minute: 8%; five minutes: 7%

Time source is NTP, 19:18:16.182 CST Tue Oct 8 2013

Port        Mode             Encapsulation  Status        Native vlan

Fa1/0/22    on               802.1q         trunking      80

Re: DHCP across Trunk

Josh,

Are you able to configure a SPAN session in the port Fa1/0/22. if configuration wise everything looks good then we will need to dig a little bit deeper.

So my suggestion is

config# monitor session 1 source interface fast 1/0/22

config# monitor session 1 destinatin interface fast x/y/z <== as you know a computer with wireshark.

Once the span session is running, go ahead and request for an ip address from a wireless devices, we will be able to see the dhcp negotiation across the link.

In wireshark use the filter "bootp" we are only interested in seeing the DHCP traffic gonig back and forth the trunk interface.

Regards

Wilson B

Hall of Fame Super Gold

DHCP across Trunk

Josh,

Post the complete running config.  I'm suspicious about that EEM script.  it could be running something else.

715
Views
14
Helpful
17
Replies
CreatePlease to create content