Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP Binding

Every morning  some of my IP Phones are stuck on Configuring IP.  I run the command Clear IP DHCP Binding * and the phones come back up.  I have also created a new voice VLAN just because we were short on IPs.  But now that I have created a new voice vlan I am still having to run Clear IP DHCP Binding * on the router.

Current IOS: Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(20)T1, RELEASE SOFTWARE (fc3)

DHCP Config:

no ip dhcp use vrf connected
ip dhcp excluded-address 10.200.1.254
ip dhcp excluded-address 10.200.1.1 10.200.1.30
!
ip dhcp pool Voice-VLAN
   network 10.200.1.0 255.255.255.0
   default-router 10.200.1.254
   option 150 ip 10.200.1.5
   lease 3


My other voice vlan DHCP is configured on a Windows Server.  Its on network 10.201.1.0 255.255.255.0

Any ideas of what to do to resolve issue?

Thanks,

Jaime

3 REPLIES

Re: DHCP Binding

How many phones do you have in the vlan?  Make sure no PC's are connected to the voice vlan.

New Member

Re: DHCP Binding

Hi Andrew,

We have currently 180 phones in voice vlan 200 and 40 in (new) voice vlan 201.

Switch ports are configured as follows.  We are using the 10/100 ports on the IP Phones for PC connectivity.  Do you think that is causing an issue?  From what I can tell PCs are grabbing ip addresses for data vlan 20 (Windows DHCP Server).

switchport access vlan 20
switchport voice vlan 200
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
no mdix auto
spanning-tree portfast

and

switchport access vlan 20
  switchport voice vlan 201
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
mls qos trust device cisco-phone
  mls qos trust cos
auto qos voip cisco-phone
  no mdix auto
spanning-tree portfast

Thanks,

Jaime

Re: DHCP Binding

Do you have a layer 3 interface in vlan 201? Does the mac address table in the switch and the arp table in the router for vlan 201 match? Are there any mac/arp entries that exist in both vlan 20/201 ?

1446
Views
0
Helpful
3
Replies
CreatePlease to create content