Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP client cannot get an valid IP address

I have a problem with DHCP ip assigning.  I configured dhcp server on the router 2921 with 192.168.1.1/24 but the laptop is get invalid ip address of 169.254.x.x. The brand new laptop is running Windows 7 64bit. Here is a list what I tried:

- ipconfig /all got us a 169.254.x.x ip address and no default gateway

- ipconfig /release gave us the same number

- ipconfig /renew failed

- configure static IP address of 192.168.1.2 and it works

- pulled power cord out of router for 10 secs and pluged in agin.

- shut computer down, pulled network cable and restarted.

- ensured firewall was off

- went to start-run-services.msc and made sure DHCP service is started and automatic

- changed another computer and the problem was same.

- typed "show arp" command on the router, it couldn't see the laptop unless static ip (192.168.1.2) is set.

- typed "debug dhcp" command, configure the laptop to be dhcp, pulled out the network cable and pluged in, but no debug information was shown.

I looked up through the internet, and saw many people asking similar questions but didn't get a clear answer. This issue is discribed as APIPA - Automatic Private IP Addressing, which means the client cannot find any dhcp server any assigns itself a private IP. Combined with the debug information I drew conclution that the computer was not sending any dhcp request to the server, but I don't know why, nor how to fix it.

The config on the router and the topology is not complicated like I attached below. Anybody please help me cause I am really bothered by this issude. Many thanks in advance.

FULL config:

Building configuration...

Current configuration : 3147 bytes
!
version 15.0
service nagle
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service dhcp
!
!
boot-start-marker
boot system flash0 c2900-universalk9-mz.SPA.150-1.M.bin
boot-end-marker
!
logging buffered 64000
logging console notifications
enable password 7 070C29454008540B191B595C547D
!
aaa new-model
!
!
aaa authentication login default line
!
!
!
!
!
aaa session-id common
clock timezone MET 1
clock summer-time MST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp pool Customer_LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8
!
!
no ip bootp server
no ip domain lookup
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ160670C2
!
!
!        
!        
!
class-map match-any BESTEFFORT
match ip precedence 0
class-map match-any PREMIUM-MARKING
match access-group name PREMIUM-CLASSIFY
class-map match-any VOICE-MARKING
match access-group name VOICE-CLASSIFY
class-map match-any VOICE
match ip precedence 7
class-map match-any MULTIMEDIA-MARKING
match access-group name MULTIMEDIA-CLASSIFY
!
!
policy-map LAN-INCOMING-QOS-POLICY
class VOICE-MARKING
  set ip precedence 7
class class-default
  set ip precedence 0
policy-map WAN-OUTGOING-QOS-POLICY
class VOICE
    priority 896
class class-default
    bandwidth 1088
     random-detect
!
!
!
!
!
interface GigabitEthernet0/0
dampening
bandwidth 1984
ip address 192.168.6.2 255.255.255.252
carrier-delay msec 0
duplex full
speed 100
no cdp enable
max-reserved-bandwidth 100
service-policy output WAN-OUTGOING-QOS-POLICY
!
interface GigabitEthernet0/1
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
description CustomerLAN
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
no cdp enable
service-policy input LAN-INCOMING-QOS-POLICY
!
ip forward-protocol nd
!        
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 192.168.2.0 255.255.254.0 192.168.6.1
!
ip access-list extended MULTIMEDIA-CLASSIFY
remark Use this ACL for QoS Multimedia Classification
ip access-list extended PREMIUM-CLASSIFY
remark Use this ACL for QoS Premium Classification
ip access-list extended PREMIUM_2-CLASSIFY
remark Use this ACL for QoS Premium_2 Classification
ip access-list extended VOICE-CLASSIFY
remark Use this ACL for QoS Voice Classification
permit ip any any precedence network
!
!
!
!
control-plane
!
banner motd ^C
CPE  client
^C
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
session-timeout 60
exec-timeout 720 0
!
scheduler allocate 20000 1000
end

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions

DHCP client cannot get an valid IP address

Hi.

The service dhcp must be enabled with the global configuration command:

service dhcp

Hope this helps.

Best regards.

Massimiliano.

Purple

Re: DHCP client cannot get an valid IP address

  If you are plugging the devices into a cisco switch make sure all access ports have the "switchport host"  command applied to them and then retry . Also fix this " no service dhcp " . 

10 REPLIES

DHCP client cannot get an valid IP address

Hi.

The service dhcp must be enabled with the global configuration command:

service dhcp

Hope this helps.

Best regards.

Massimiliano.

Hall of Fame Super Silver

DHCP client cannot get an valid IP address

Would you assign a static IP to the PC, verify that it works, and then post the output of show arp?

HTH

Rick

New Member

DHCP client cannot get an valid IP address

Thanks for the suggestion, I would try once the customer is back to work after weekend.

New Member

DHCP client cannot get an valid IP address

Yes, I have proved it will work after assigning a static IP to the PC. There will be 192.168.1.2 and a mac address on the output of show arp. If no static IP is set, this mac address won't be there.

New Member

DHCP client cannot get an valid IP address

It's a non cisco 8 port switch without any configuration. I don't know the model because I am remote controlling the router helping the customer with trouble shooting. I guess there should be no problem with the setting of switch.

Re: DHCP client cannot get an valid IP address

What is the complete config and model of the switch?

Sent from Cisco Technical Support iPad App

New Member

DHCP client cannot get an valid IP address

It's a non cisco 8 port switch without any configuration. I don't know the model because I am remote controlling the router helping the customer with trouble shooting. I guess there should be no problem with the setting of switch.

Purple

Re: DHCP client cannot get an valid IP address

  If you are plugging the devices into a cisco switch make sure all access ports have the "switchport host"  command applied to them and then retry . Also fix this " no service dhcp " . 

New Member

DHCP client cannot get an valid IP address

The switch is non cisco 8 ports with default setting, I guess the problem is probably this " no service dhcp ". I will try and let you know. Thanks.

New Member

Re: DHCP client cannot get an valid IP address

Hi

Did you check the cable ?

Sent from my iPhone

9313
Views
0
Helpful
10
Replies
CreatePlease to create content