Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP deliver time taking long

Hi,

I was wondering whether someone could help  me.

In my network setup I use, at least, two VLAN's in a Virtualized model. That is... I have each workstation with a Virtual Machine inside it. The host machine, is in  VLAN Id 76 and the VM uses default VLAN.

Each VLAN has a separate DHCP server. The interface definition for the tagged VLAN is as follows

interface GigabitEthernet1/0/11

switchport access vlan 76

switchport trunk encapsulation dot1q

switchport mode access

priority-queue out

spanning-tree portfast

!

The NIC on the server has no definition for setting a VLAN, mostly because the server hasn't the latest Intel driver. Anyways I'm not sure that it is because of that... What happens? Everytime I turn on the computer, it takes more than a minute to assign an IP to the workstations. The same doesn't happen on the Virtual Machines... the VM's use the default VLAN...

The workstations have the following setup:

interface GigabitEthernet1/0/40

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,4,76

switchport mode trunk

switchport voice vlan 4

priority-queue out

mls qos trust device cisco-phone

mls qos vlan-based

spanning-tree portfast

Might there be any config in my 3750 that can help improve the time that the DHCP takes to deliver an IP to the workstations?

Thanks in advance.

Nuno Silva

2 REPLIES
Cisco Employee

DHCP deliver time taking long

Hi Nuno,

Try using the spanning-tree portfast trunk on the trunk ports towards the workstation. You currently have them configured with PortFast, however, such a configuration applies only to access ports. If you want a trunk port to be PortFast enabled, you have to use the spanning-tree portfast trunk command including the trunk optional keyword.

Note also that on your Gi1/0/11 port, the spanning-tree trunk encapsulation dot1q is superfluous - as the port is currently set to access mode, all spanning-tree trunk ... commands are ignored. You may remove that command, it will make your configuration easier to read and understand.

Best regards,

Peter

New Member

DHCP deliver time taking long

Hi Peter,

That was it! Did the change, and it is now working much faster.

Best regards,

Nuno Silva

1183
Views
5
Helpful
2
Replies