Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP doesnt assign IP on Cisco 881c (but yes on 881w)

Hello everybody!

 

I've on my hands 2 greats wireless routers cisco, the 881c (left) and the 881w (right).

 

This routers are a embedded solution, this mean:

 

A CISCO 881 series contain:

  • Router
  • AP
  • VPN
  • Firewall
  • Switching (VLANs on this case)

 

I started to configure the Router and the AP for both CISCOs, so the point to following is this way...

 

 

Well, I'm stuck with a special configuration of one of this both routers (the 881c). Both are very similar, both has the same technical specifications, so finally proceeded to configure the 881w with the following configs:

 

  1. The F/4 port will be the WAN side, where I conect my ISP internet
  2. 3 DHCP pools for each VLAN
  3. 3 VLANs replicated to the FastEthernet ports (VLAN 10 for F/0, VLAN 20 for F/1 and VLAN 30 for F/2-F/3)
  4. The same 3 VLAN need to be present on the AP side, were there is 3 SSID's (wifiduoc, duoc and Gerencia)
  5. Each SSID are asigned to each VLAN 10, 20 and 30
  6. And finally, each DHCP pool should asign the same IPs of the VLANs range dynamically through DHCP.

 

The result: The Cisco 881w works perfectly! All computers conected to the router 881w obtain the corresponding IP on the VLAN via cable, heach PC connected the corresponding port, or via wifi on the corresponding SSID.

 
However, I can't configure the Cisco 881c in the same way. I copied/pasted the same/exactly config from the 881w to the 881c, and all seems to be fine on the 881c, but the DHCP doesn't work.

 

The 881c do correctly the following:

  • The WAN port detect correctly the ISP IP
  • The 3 SSIDs are irradiated and are detected by the laptops and computers equiped with wireless NIC
  • The FE ports are asigned correctly to the VLANs

 

The 881c can't do correctly the following:

  • The DHCP ip assignment via cable can't be asigned on the computers
  • The DHCP ip assignment via SSID (wifi) can't be asigned on the computers or laptops too
  • If I configure the computers with a static IP, the 881c work well and it traffic to internet well

I've searched and I've investigated, so I've put the following command to verify if the DHCP brings me the ip bindings:

 

router-881c#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address          Hardware address              Lease expiration        Type

192.168.10.23       01e0.cb4e.42f1.9d       Jan 01 1900 02:24 AM    Automatic

 

My computer has been correctly identified with the MAC by the router 881c, BUT:

 

If you look, the IPv4 not are assigned on my PC from the 881c router, this IP correspond to APIPA protocol of Windows.

 

 

For other hand, the SSID's are irradiated correctly from the Dot11Radio 0 antena... but with the same problem, the DHCP ip assignment doesn't work.

 

 

router-881c#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address          Hardware address              Lease expiration        Type

182.168.30.11       0100.1b11.b1c5.53       Jan 01 1900 02:51 AM    Automatic

192.168.10.28       01e0.cb4e.42f1.9d       Jan 01 1900 02:51 AM    Automatic

 

 

If I try the same configuration on the 881w all work very fine. Take a look:

 

router-881w#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address          Hardware address              Lease expiration        Type

182.168.30.11       0100.1b11.b1c5.53       Nov 03 2013 09:40 PM    Automatic

192.168.10.11       01e0.cb4e.42f1.9d       Nov 03 2013 09:35 PM    Automatic

 

 

For now, I can't found a solution for this weird issue, I think that the router 881c has a bug, so I've probed two different OS's, take a look:

 

router-881c#dir

Directory of flash:/

    1  -rw-    31291784  Feb 29 1984 00:01:00 +00:00  c800-universalk9-mz.SPA.151-4.M4.bin
    2  -rw-        3472   Feb 6 2036 06:35:36 +00:00  cpconfig-8xxW.cfg
    3  -rw-     3000320   Feb 6 2036 06:36:00 +00:00  cpexpress.tar
    4  -rw-        1038   Feb 6 2036 06:36:14 +00:00  home.shtml
    5  -rw-      122880   Feb 6 2036 06:36:26 +00:00  home.tar
    6  -rw-     1697952   Feb 6 2036 06:38:14 +00:00  securedesktop-ios-3.1.1.45-k9.pkg
    7  -rw-      415956   Feb 6 2036 06:38:30 +00:00  sslclient-win-1.1.4.176.pkg
    8  -rw-        3472   Feb 6 2036 06:30:02 +00:00  startup.backup.20360206-063002-UTC
    9  -rw-         780   Feb 6 2036 07:31:32 +00:00  vlan.dat
   10  -rw-    52841320   Feb 6 2036 11:30:28 +00:00  c800-universalk9-mz.SPA.153-1.T.bin

 

The 151-4.M4 are the original OS.

 

With both OS's occur the same problem, The DHCP does not assign the IP'S.

 

There is other weird symptom: If I assign a static IP to my computer, the traffic to the LAN and Internet work great on the 881c (via wifi and via cable).

 

So the only problem is about the DHCP IP assignment from the 881c.

 

If anybody can helpme will be great!

 

I've tried everything, but nothing work, :'-(

 

PS: I've attached the [show configs] and [show versions] from the 881w and the 881c

 

Chers,

Alfred.

3 REPLIES
New Member

Well, I've done a run

Well, I've done a run following debug on the router:

 

logging buffered debug

logging buffered 100000

logging enable

do debug ip dhcp server packet

 

Then when I host has an IP : do sh log  and I paste output here

 

Also I post config of the router.

 

The loggin from 881c:

router-881c#show logging

Syslog logging: enabled (0 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.

    Console logging: level debugging, 109 messages logged, xml disabled,

                     filtering disabled

    Monitor logging: level debugging, 0 messages logged, xml disabled,

                     filtering disabled

    Buffer logging:  level debugging, 66 messages logged, xml disabled,

                    filtering disabled

    Exception Logging: size (8192 bytes)

    Count and timestamp logging messages: disabled

    Persistent logging: disabled

No active filter modules.

    Trap logging: level informational, 48 message lines logged

        Logging Source-Interface:       VRF Name:

Log Buffer (100000 bytes):

Feb  6 06:51:01.662: %SYS-5-CONFIG_I: Configured from console by console

Feb  6 06:51:27.342: DHCPD: client's VPN is .

Feb  6 06:51:27.342: DHCPD: No option 125

Feb  6 06:51:27.342: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10

Feb  6 06:51:27.346: DHCPD: Allocate an address without class information (192.168.10.0)

Feb  6 06:51:27.346: DHCPD: Saving workspace (ID=0x47000003)

Feb  6 06:51:29.346: DHCPD: Reprocessing saved workspace (ID=0x47000003)

Feb  6 06:51:29.346: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10

Feb  6 06:51:29.346: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:51:29.346: DHCPD: no option 125

Feb  6 06:51:29.346: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

Feb  6 06:51:29.346: DHCPD: client's VPN is .

Feb  6 06:51:29.346: DHCPD: No option 125

Feb  6 06:51:29.346: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:51:29.346: DHCPD: No default domain to append - abort update

Feb  6 06:51:29.346: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:51:33.346: DHCPD: client's VPN is .

Feb  6 06:51:33.346: DHCPD: No option 125

Feb  6 06:51:33.346: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:51:33.346: DHCPD: No default domain to append - abort update

Feb  6 06:51:33.346: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:51:40.793: DHCPD: client's VPN is .

Feb  6 06:51:40.793: DHCPD: No option 125

Feb  6 06:51:40.793: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:51:40.793: DHCPD: No default domain to append - abort update

Feb  6 06:51:40.793: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:51:57.793: DHCPD: client's VPN is .

Feb  6 06:51:57.793: DHCPD: No option 125

Feb  6 06:51:57.793: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:51:57.793: DHCPD: No default domain to append - abort update

Feb  6 06:51:57.793: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:52:06.813: DHCPD: removing ARP entry (192.168.10.13 vrf default).

Feb  6 06:52:29.801: DHCPD: client's VPN is .

Feb  6 06:52:29.801: DHCPD: No option 125

Feb  6 06:52:29.801: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10

Feb  6 06:52:29.801: DHCPD: Allocate an address without class information (192.168.10.0)

Feb  6 06:52:29.801: DHCPD: Saving workspace (ID=0xE6000004)

Feb  6 06:52:31.801: DHCPD: Reprocessing saved workspace (ID=0xE6000004)

Feb  6 06:52:31.801: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10

Feb  6 06:52:31.801: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:52:31.801: DHCPD: no option 125

Feb  6 06:52:31.801: DHCPD: creating ARP entry (192.168.10.14, e0cb.4e42.f19d, vrf default).

Feb  6 06:52:31.801: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.10.14).

Feb  6 06:52:31.801: DHCPD: client's VPN is .

Feb  6 06:52:31.801: DHCPD: No option 125

Feb  6 06:52:31.801: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:52:31.801: DHCPD: No default domain to append - abort update

Feb  6 06:52:31.801: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:52:35.801: DHCPD: client's VPN is .

Feb  6 06:52:35.801: DHCPD: No option 125

Feb  6 06:52:35.801: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:52:35.801: DHCPD: No default domain to append - abort update

Feb  6 06:52:35.801: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:52:44.805: DHCPD: client's VPN is .

Feb  6 06:52:44.805: DHCPD: No option 125

Feb  6 06:52:44.805: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:52:44.805: DHCPD: No default domain to append - abort update

Feb  6 06:52:44.805: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:53:01.805: DHCPD: client's VPN is .

Feb  6 06:53:01.805: DHCPD: No option 125

Feb  6 06:53:01.805: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:53:01.805: DHCPD: No default domain to append - abort update

Feb  6 06:53:01.805: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:54:06.812: DHCPD: removing ARP entry (192.168.10.14 vrf default).

router-881c#

 

The startup-config from 881c:

router-881c#sh startup-config

Using 2613 out of 262136 bytes

! Last configuration change at 07:48:36 UTC Wed Feb 6 2036

! NVRAM config last updated at 07:56:25 UTC Wed Feb 6 2036

! NVRAM config last updated at 07:56:25 UTC Wed Feb 6 2036

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname router-881c

boot-start-marker

boot-end-marker

no aaa new-model

crypto pki token default removal timeout 0

ip source-route

ip cef


ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.20.1 192.168.20.10

ip dhcp excluded-address 182.168.30.1 182.168.30.10

ip dhcp pool VLAN10

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 190.160.0.13

ip dhcp pool VLAN20

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

dns-server 190.160.0.13

ip dhcp pool VLAN30

network 182.168.30.0 255.255.255.0

dns-server 10.20.4.11

default-router 182.168.30.1

no ip dhcp-client broadcast-flag

no ipv6 cef

license udi pid C881W-A-K9 sn xxxxxxxxx

interface FastEthernet0

switchport access vlan 10

no ip address

interface FastEthernet1

switchport access vlan 10

no ip address

interface FastEthernet2

switchport access vlan 20

no ip address

interface FastEthernet3

switchport access vlan 30

no ip address

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

no ip address

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

ip address 172.168.0.1 255.255.0.0

interface Vlan1

ip address 192.168.1.1 255.255.255.0

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

interface Vlan20

ip address 192.168.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

interface Vlan30

ip address 182.168.30.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip forward-protocol nd

no ip http server

no ip http secure-server

ip nat inside source list INTERNET interface FastEthernet4 overload

ip route 0.0.0.0 0.0.0.0 10.20.4.1

ip access-list standard INTERNET

permit 192.168.10.0 0.0.0.255

permit 192.168.20.0 0.0.0.255

permit 182.168.30.0 0.0.0.255

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

login

transport input all

scheduler allocate 20000 1000

end

router-881c#

 

Only for curiosity, I've typed the same loggin commands to view the differences between 881c and 881w, and there is some interesting to view...

 

  1. The main difference is about the VLAN1, on the 881w DHCPDISCOVER event from VLAN1, but this not occur into the 881c...
  2. The other main difference is about the message: "no opcion 125" on the 881c, what is this? In the 881w this message doesn't appear, so, I think that for this way may be the problem. I'm right?
  3. Other point is about of the ARP Entry in the 881c, If you look, initially the router send the 192.168.10.13 to the MAC 01e0.cb4e.42f1.9d, but at the bottom the ARP entry change the ip to 192.168.10.14 for the same MAC 01e0.cb4e.42f1.9d, that's right? In the 881w this no occur.
  4. And the last one: Through the loggin I realized about the clock and date from the 881c. It are incorrect (Wed Feb 6 2036). I changed the clock with 'clock set' command. But strangely after reload the router, the clock return to the incorrect date. Does this have to do with the following message? = %LICENSE-1-VALIDITY_ENDED: Feature advipservices 1.0  has expired. UDI=C881W-A-K9:FTXxxx

 

...and of course, in the 881w the clock are right.

 

So, resuming:

881c:

Feb  6 06:51:29.346: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10.

Feb  6 06:51:29.346: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:51:29.346: DHCPD: no option 125

Feb  6 06:51:29.346: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

Feb  6 06:51:29.346: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.13).

Feb  6 06:52:06.813: DHCPD: removing ARP entry (192.168.10.13 vrf default).

Feb  6 06:52:31.801: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.10.14).

Feb  6 06:52:31.801: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:52:31.801: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.14).

Feb  6 06:52:31.801: DHCPD: creating ARP entry (192.168.10.14, e0cb.4e42.f19d, vrf default).

 

881w:

*Nov  3 21:07:02.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1.

*Nov  3 21:07:09.255: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10.

*Nov  3 21:07:09.255: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.11).

*Nov  3 21:07:09.255: DHCPD: creating ARP entry (192.168.10.11, e0cb.4e42.f19d, vrf default).

*Nov  3 21:07:12.467: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

*Nov  3 21:07:09.255: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.10.11).

 

The loggin from 881w:

router-881w#show logging

Syslog logging: enabled (0 messages dropped, 2 messages rate-limited,

                0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.

    Console logging: level debugging, 83 messages logged, xml disabled,

                     filtering disabled

    Monitor logging: level debugging, 0 messages logged, xml disabled,

                     filtering disabled

    Buffer logging:  level debugging, 47 messages logged, xml disabled,

                     filtering disabled

    Logging Exception size (4096 bytes)

    Count and timestamp logging messages: disabled

    Persistent logging: disabled

No active filter modules.

ESM: 0 messages dropped

    Trap logging: level informational, 46 message lines logged

Log Buffer (4096 bytes):

*Nov  3 21:03:43.747: %SYS-5-CONFIG_I: Configured from console by console

*Nov  3 21:04:00.607: DHCPD: client's VPN is .

*Nov  3 21:04:00.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:04:48.795: DHCPD: client's VPN is .

*Nov  3 21:04:48.795: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:04:52.607: DHCPD: client's VPN is .

*Nov  3 21:04:52.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:04:56.607: DHCPD: client's VPN is .

*Nov  3 21:04:56.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:05:38.775: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Nov  3 21:05:39.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

*Nov  3 21:05:49.275: DHCPD: client's VPN is .

*Nov  3 21:05:49.275: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:05:52.607: DHCPD: client's VPN is .

*Nov  3 21:05:52.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:05:56.607: DHCPD: client's VPN is .

*Nov  3 21:05:56.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:06:07.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to down

*Nov  3 21:06:08.355: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Nov  3 21:06:09.355: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

*Nov  3 21:06:54.755: DHCPD: client's VPN is .

*Nov  3 21:06:54.755: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:06:58.607: DHCPD: client's VPN is .

*Nov  3 21:06:58.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:07:02.607: DHCPD: client's VPN is .

*Nov  3 21:07:02.607: DHCPD: DHCPDISCOVER received from client 0164.00f1.7794.32 on interface Vlan1

*Nov  3 21:07:07.255: DHCPD: client's VPN is .

*Nov  3 21:07:07.255: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10.

*Nov  3 21:07:07.255: DHCPD: Allocate an address without class information (192.168.10.0)

*Nov  3 21:07:07.255: DHCPD: Saving workspace (ID=0x1D000001)

*Nov  3 21:07:09.255: DHCPD: Reprocessing saved workspace (ID=0x1D000001)

*Nov  3 21:07:09.255: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan10.

*Nov  3 21:07:09.255: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.10.11).

*Nov  3 21:07:09.255: DHCPD: creating ARP entry (192.168.10.11, e0cb.4e42.f19d, vrf default).

*Nov  3 21:07:09.255: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.10.11).

*Nov  3 21:07:09.255: DHCPD: removing ARP entry (192.168.10.11 vrf default).

*Nov  3 21:07:09.255: DHCPD: client's VPN is .

*Nov  3 21:07:09.255: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

*Nov  3 21:07:09.255: DHCPD: No default domain to append - abort update

*Nov  3 21:07:09.255: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.11).

*Nov  3 21:07:09.255: DHCPD: creating ARP entry (192.168.10.11, e0cb.4e42.f19d, vrf default).

*Nov  3 21:07:09.255: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.10.11).

*Nov  3 21:07:12.467: DHCPD: client's VPN is .

*Nov  3 21:07:12.467: DHCPD: DHCPINFORM received from client 01e0.cb4e.42f1.9d (192.168.10.11).

*Nov  3 21:07:12.467: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.10.11).

*Nov  3 21:07:12.467: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

router-881w#

 

However, all this information above doesn't clarify the problem.

New Member

Later, I've been watching the

Later, I've been watching the behavior of the CISCO 881c, and I've found two extrange messages from the debug of the DHCP Server Packets:

    DHCPD: No option 125

    DHCPD: Finding a relay for client 01e0.cb4e.42f1.9d on interface Vlan1

    DHCPD: ARP Entrys removed

    DHCPD: MAC Addresses that not appears on the router and do not correspond to any host

 

So, I've erased the above settings of of the startup-config and now I've configured only the DHCP Server. But the DHCP not really working.

 

If you look closely, the messages "No option 125" and the "Finding a relay for client" constantly.

 

Other notorious problem, is that the assigned IP's are removed from the ARP Entry time after time.

 

Finally, a extrange MAC ADDRESS appears from the "limbo" requesting to the router.

 

Example: 0144.03a7.81b5.2e

 

I can not find where it comes from this suprise MAC!

 

My startup-config:

R-881c#show running-config

Building configuration...

Current configuration : 1371 bytes

No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname R-881c

boot-start-marker

boot-end-marker

no aaa new-model

crypto pki token default removal timeout 0

ip source-route

ip cef

ip dhcp excluded-address 192.168.30.1 192.168.30.10

ip dhcp pool LAN

network 192.168.30.0 255.255.255.0

default-router 192.168.30.1

no ipv6 cef

license udi pid C881W-A-K9 sn FTXxxxxxxx

interface FastEthernet0

no ip address

interface FastEthernet1

no ip address

interface FastEthernet2

no ip address

interface FastEthernet3

no ip address

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

no ip address

interface Vlan1

ip address 192.168.30.1 255.255.255.0

ip forward-protocol nd

no ip http server

no ip http secure-server

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

login

transport input all

scheduler allocate 20000 1000

end

 

DHCP Server Packet Debug: 

Feb  6 06:46:05.993: DHCPD: client's VPN is .

Feb  6 06:46:05.993: DHCPD: No option 125

Feb  6 06:46:05.993: DHCPD: DHCPDISCOVER received from client 0144.03a7.81b5.2e (Where does it come this MAC?)

on interface Vlan1.

Feb  6 06:46:05.993: DHCPD: Allocate an address without class information (192.168.30.0)

Feb  6 06:46:05.993: DHCPD: Saving workspace (ID=0xB4000009)

Feb  6 06:46:07.993: DHCPD: Reprocessing saved workspace (ID=0xB4000009)

Feb  6 06:46:07.993: DHCPD: DHCPDISCOVER received from client 0144.03a7.81b5.2e on interface Vlan1.

Feb  6 06:46:07.993: DHCPD: Sending DHCPOFFER to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:46:07.993: DHCPD: no option 125

Feb  6 06:46:07.993: DHCPD: broadcasting BOOTREPLY to client 4403.a781.b52e.

Feb  6 06:46:07.993: DHCPD: client's VPN is .

Feb  6 06:46:07.993: DHCPD: No option 125

Feb  6 06:46:07.993: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:46:07.993: DHCPD: No default domain to append - abort update

Feb  6 06:46:07.993: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:46:10.161: DHCPD: client's VPN is .

Feb  6 06:46:10.161: DHCPD: No option 125

Feb  6 06:46:10.161: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:46:10.161: DHCPD: No default domain to append - abort update

Feb  6 06:46:10.161: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:46:12.889: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

Feb  6 06:46:13.161: DHCPD: client's VPN is .

Feb  6 06:46:13.161: DHCPD: No option 125

Feb  6 06:46:13.161: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:46:13.161: DHCPD: No default domain to append - abort update

Feb  6 06:46:13.161: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:46:13.889: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

Feb  6 06:46:16.161: DHCPD: client's VPN is .

Feb  6 06:46:16.161: DHCPD: No option 125

Feb  6 06:46:16.161: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:46:16.161: DHCPD: No default domain to append - abort update

Feb  6 06:46:16.161: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:46:42.453: DHCPD: client's VPN is .

Feb  6 06:46:42.453: DHCPD: No option 125

Feb  6 06:46:42.453: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d (MY HOST INTERFACE).

Feb  6 06:46:42.453: DHCPD: client has moved to a new subnet.

Feb  6 06:46:42.453: DHCPD: Sending DHCPNAK to client 01e0.cb4e.42f1.9d.

Feb  6 06:46:42.453: DHCPD: no option 125

Feb  6 06:46:42.453: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

Feb  6 06:46:42.509: DHCPD: client's VPN is .

Feb  6 06:46:42.509: DHCPD: No option 125

Feb  6 06:46:42.509: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan1.

Feb  6 06:46:42.509: DHCPD: Allocate an address without class information (192.168.30.0)

Feb  6 06:46:42.513: DHCPD: Saving workspace (ID=0x4200000A)

Feb  6 06:46:44.509: DHCPD: Reprocessing saved workspace (ID=0x4200000A)

Feb  6 06:46:44.509: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan1.

Feb  6 06:46:44.509: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:46:44.509: DHCPD: no option 125

Feb  6 06:46:44.509: DHCPD: broadcasting BOOTREPLY to client e0cb.4e42.f19d.

Feb  6 06:46:44.509: DHCPD: client's VPN is .

Feb  6 06:46:44.509: DHCPD: No option 125

Feb  6 06:46:44.509: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:46:44.509: DHCPD: No default domain to append - abort update

Feb  6 06:46:44.509: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:46:48.509: DHCPD: client's VPN is .

Feb  6 06:46:48.509: DHCPD: No option 125

Feb  6 06:46:48.509: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:46:48.509: DHCPD: No default domain to append - abort update

Feb  6 06:46:48.509: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:46:54.960: DHCPD: client's VPN is .

Feb  6 06:46:54.960: DHCPD: No option 125

Feb  6 06:46:54.960: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:46:54.960: DHCPD: No default domain to append - abort update

Feb  6 06:46:54.960: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:47:11.824: DHCPD: client's VPN is .

Feb  6 06:47:11.824: DHCPD: No option 125

Feb  6 06:47:11.824: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:47:11.824: DHCPD: No default domain to append - abort update

Feb  6 06:47:11.824: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:47:26.480: DHCPD: client's VPN is .

Feb  6 06:47:26.480: DHCPD: No option 125

Feb  6 06:47:26.480: DHCPD: DHCPDISCOVER received from client 0144.03a7.81b5.2e on interface Vlan1.

Feb  6 06:47:26.480: DHCPD: Sending DHCPOFFER to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:47:26.480: DHCPD: no option 125

Feb  6 06:47:26.480: DHCPD: broadcasting BOOTREPLY to client 4403.a781.b52e.

Feb  6 06:47:27.160: DHCPD: client's VPN is .

Feb  6 06:47:27.160: DHCPD: No option 125

Feb  6 06:47:27.160: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:47:27.160: DHCPD: No default domain to append - abort update

Feb  6 06:47:27.160: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:47:30.160: DHCPD: client's VPN is .

Feb  6 06:47:30.160: DHCPD: No option 125

Feb  6 06:47:30.160: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:47:30.160: DHCPD: No default domain to append - abort update

Feb  6 06:47:30.160: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:47:33.160: DHCPD: client's VPN is .

Feb  6 06:47:33.160: DHCPD: No option 125

Feb  6 06:47:33.160: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:47:33.160: DHCPD: No default domain to append - abort update

Feb  6 06:47:33.160: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:47:36.160: DHCPD: client's VPN is .

Feb  6 06:47:36.160: DHCPD: No option 125

Feb  6 06:47:36.160: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:47:36.160: DHCPD: No default domain to append - abort update

Feb  6 06:47:36.160: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.19).

Feb  6 06:47:43.792: DHCPD: client's VPN is .

Feb  6 06:47:43.792: DHCPD: No option 125

Feb  6 06:47:43.792: DHCPD: DHCPDISCOVER received from client 01e0.cb4e.42f1.9d on interface Vlan1.

Feb  6 06:47:43.792: DHCPD: Sending DHCPOFFER to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:47:43.792: DHCPD: no option 125

Feb  6 06:47:43.792: DHCPD: creating ARP entry (192.168.30.20, e0cb.4e42.f19d, vrf default).

Feb  6 06:47:43.792: DHCPD: unicasting BOOTREPLY to client e0cb.4e42.f19d (192.168.30.20).

Feb  6 06:47:43.792: DHCPD: client's VPN is .

Feb  6 06:47:43.792: DHCPD: No option 125

Feb  6 06:47:43.792: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:47:43.792: DHCPD: No default domain to append - abort update

Feb  6 06:47:43.792: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:47:48.796: DHCPD: client's VPN is .

Feb  6 06:47:48.796: DHCPD: No option 125

Feb  6 06:47:48.796: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:47:48.796: DHCPD: No default domain to append - abort update

Feb  6 06:47:48.796: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:47:55.796: DHCPD: client's VPN is .

Feb  6 06:47:55.796: DHCPD: No option 125

Feb  6 06:47:55.796: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d.

Feb  6 06:47:55.796: DHCPD: No default domain to append - abort update

Feb  6 06:47:55.796: DHCPD: Sending DHCPACK to client 01e0.cb4e.42f1.9d (192.168.30.20).

Feb  6 06:48:02.744: DHCPD: removing ARP entry (192.168.30.20 vrf default).

Feb  6 06:48:02.744: DHCPD: removing ARP entry (192.168.30.19 vrf default).

Feb  6 06:48:11.848: DHCPD: client's VPN is .

Feb  6 06:48:11.848: DHCPD: No option 125

Feb  6 06:48:11.848: DHCPD: DHCPREQUEST received from client 01e0.cb4e.42f1.9d. (MY HOST INTERFACE)

Feb  6 06:48:11.848: DHCPD: Finding a relay for client 01e0.cb4e.42f1.9d (MY HOST INTERFACE) on interface Vlan1.

Feb  6 06:48:46.963: DHCPD: client's VPN is .

Feb  6 06:48:46.963: DHCPD: No option 125

Feb  6 06:48:46.963: DHCPD: DHCPDISCOVER received from client 0144.03a7.81b5.2e on interface Vlan1.

Feb  6 06:48:46.963: DHCPD: Allocate an address without class information (192.168.30.0)

Feb  6 06:48:46.963: DHCPD: Saving workspace (ID=0x6A00000B)

Feb  6 06:48:48.963: DHCPD: Reprocessing saved workspace (ID=0x6A00000B)

Feb  6 06:48:48.963: DHCPD: DHCPDISCOVER received from client 0144.03a7.81b5.2e on interface Vlan1.

Feb  6 06:48:48.963: DHCPD: Sending DHCPOFFER to client 0144.03a7.81b5.2e (192.168.30.21).

Feb  6 06:48:48.963: DHCPD: no option 125

Feb  6 06:48:48.963: DHCPD: broadcasting BOOTREPLY to client 4403.a781.b52e.

Feb  6 06:48:48.963: DHCPD: client's VPN is .

Feb  6 06:48:48.963: DHCPD: No option 125

Feb  6 06:48:48.963: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:48:48.963: DHCPD: No default domain to append - abort update

Feb  6 06:48:48.963: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.21).

Feb  6 06:48:51.159: DHCPD: client's VPN is .

Feb  6 06:48:51.159: DHCPD: No option 125

Feb  6 06:48:51.159: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:48:51.159: DHCPD: No default domain to append - abort update

Feb  6 06:48:51.159: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.21).

Feb  6 06:48:54.159: DHCPD: client's VPN is .

Feb  6 06:48:54.159: DHCPD: No option 125

Feb  6 06:48:54.159: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:48:54.159: DHCPD: No default domain to append - abort update

Feb  6 06:48:54.159: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.21).

Feb  6 06:48:57.159: DHCPD: client's VPN is .

Feb  6 06:48:57.159: DHCPD: No option 125

Feb  6 06:48:57.159: DHCPD: DHCPREQUEST received from client 0144.03a7.81b5.2e.

Feb  6 06:48:57.159: DHCPD: No default domain to append - abort update

Feb  6 06:48:57.159: DHCPD: Sending DHCPACK to client 0144.03a7.81b5.2e (192.168.30.21).

Feb  6 06:50:02.743: DHCPD: removing ARP entry (192.168.30.21 vrf default).

Feb  6 06:50:07.442: DHCPD: client's VPN is .

 

SH INT BR:

R-881c#show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              unassigned      YES NVRAM  administratively down down

Vlan1                      192.168.30.1    YES NVRAM  up                    up

Wlan-GigabitEthernet0      unassigned      YES unset  up                    up

wlan-ap0                   unassigned      YES NVRAM  up                    up

 

SH MAC INTERFACES:

R-881c#show interfaces f0

FastEthernet0 is up, line protocol is up

Hardware is Fast Ethernet, address is 4403.a781.b520 (bia 4403.a781.b520)

R-881c#show interfaces f1

FastEthernet1 is up, line protocol is down

Hardware is Fast Ethernet, address is 4403.a781.b521 (bia 4403.a781.b521)

R-881c#show interfaces f2

FastEthernet2 is up, line protocol is down

Hardware is Fast Ethernet, address is 4403.a781.b522 (bia 4403.a781.b522)

R-881c#show interfaces f3

FastEthernet3 is up, line protocol is down

Hardware is Fast Ethernet, address is 4403.a781.b523 (bia 4403.a781.b523)

R-881c#show interfaces f4

FastEthernet4 is administratively down, line protocol is down

Hardware is PQ3_TSEC, address is 4403.a781.b524 (bia 4403.a781.b524)

R-881c#show interfaces vlan 1

Vlan1 is up, line protocol is up

Hardware is EtherSVI, address is 4403.a781.b520 (bia 4403.a781.b520)

R-881c#show interfaces wlan-gigabitEthernet 0

Wlan-GigabitEthernet0 is up, line protocol is up

Hardware is WLAN Gigabit Ethernet, address is 4403.a781.b524 (bia 4403.a781.b524)

My host interface NIC

E0-CB-4E-42-F1-9D

 

Should be noted that this same simple config works on the CISCO 881w

 

But again, all this information doesn't help me to find the problem.

New Member

Well,

Well,

 

Finally I want to share the REAL solution of this terrible problem.

 

All this problem began past year 2013, around November.

 

The solution was found in 5 December of 2013, too late to share today in June of 2014, hahaha.

 

But I think that always is convenient to show this type of information to the CISCO community.

 

I entered the following for debugging:

debug ip packet detail 100

This step only shows me that packet are sent from the client to the server via the udp ports 67 and 68. But on this step, the debug showed me a strange message:

1) FIBipv4-packet-proc: packet routing failed

2) IP: s=0.0.0.0 (Vlan1), d=255.255.255.255, len 330, stop process pak for forus packet

This error correspond to DHCP ACK, the last stage of negotiation of the router and host.

So, I read a little further on netacad I found another command:

debug ip dhcp server events

So, on this step, the debugging messages are similar to the [debug ip dhcp server packets], but these messages helped me to find a clear indication of the cause of the problem:

1) DHCPD: the lease for address 192.168.30.36 has expired.
2) DHCPD: reason flags: timeout

This correspond to the [lease] option of the [dhcp pool].

The lease option are in 1 day by default. But something does not let sync correctly the router with the host.

Finally I've checked the clock of the router and this was not set correctly, the clock was set in 2036.

So I proceeded to change the date of the clock and DHCP worked! That's all!

The clock returns to be misconfigured if I reset the router.
Wherein we could see that the DHCP Ack message was sent from the server but never received by the client.
I’ve found the correct reasoning for seeing the Expired address message and have taken the right approach towards fixing it, so congrats on that for me! hahaha.
The clock issue is due to bug which is not currently fixed by CISCO and has been advised to replace those router where this problem is seen. Here is bug id CSCue79402.

You can read more about this here: (you need High Level Permissions to view this bug)
http://tools.cisco.com/squish/BBCb2

 

Here other link with low level access to view this bug CSCue79402:

http://www.cisco.com/c/en/us/td/docs/ios/15_3m_and_t/release/notes/15_3m_and_t/153-2TCAVS.html

 

CSCue79402 details:

Symptoms: The router fails to save the last clock set ... command even after applied clock update-calendar command.

Conditions: This symptom occurs when you powercycle the router.

Workaround: Re-enter clock set ... and clock update-calendar commands, after the router is rebooted.


At last, this problem has been fixed, now I've a new router actually working in production in the company from the past year.

 

See ya CISCO community !

772
Views
0
Helpful
3
Replies
CreatePlease login to create content