Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP doesnt work through cisco switch.

hi mates,

I am hoping some one can help me about the below problem:

DHCP doesnt work through cisco switch.

on my LAN;

- there is a DHCP server(PC) and clients(PCs) with 192.1.1.0 network

- all computers are connected to cisco switch (IOS 12.25), switch's IP address is on 10.0.0.0 network (interface vlan1)

- I havent configure anything about DHCP on the switch. all the DHCP configurations are default.

- Clients do not get IP addresses from DHCP server.

- When I replace cisco switch with a unmanaged switch, DHCP works !!! (everything is same I replace only cisco switch with a unmanaged switch)

I'll appreciate any help,tx in advance :)

ohalnet

9 REPLIES
Purple

Re: DHCP doesnt work through cisco switch.

On each user port enter the "switchport host" , or just use the interface range command to apply it to all "user ports" . This will turn on spanning tree portfast and turn off trunking and channeling, this should fix your problem .

Purple

Re: DHCP doesnt work through cisco switch.

On all user ports enter the "switchport host" command or use the interface range command to apply to all user ports at one time . This will turn on spanning tree portfast and turn off trunking and channeling , this should fix your issue.

New Member

Re: DHCP doesnt work through cisco switch.

Hi Glen :)

thanks for response

I have already enabled spanning tree on user ports. Here is the configuration:

interface GigabitEthernet1/1

spanning-tree portfast

!

interface GigabitEthernet1/2

spanning-tree portfast

!

interface GigabitEthernet1/3

spanning-tree portfast

.....

there is an etherchannel running between two cisco switches,but I think etherchannel shouldnt be cause of the problem because WHEN I shutdown one of the switches DHCP still does not work.

here is my ether-channel configuration:

interface Port-channel1

switchport

!

interface GigabitEthernet1/5

channel-group 1 mode desirable

!

interface GigabitEthernet1/6

channel-group 1 mode desirable

tx for helping :)

Purple

Re: DHCP doesnt work through cisco switch.

What kind of switch is it ? If its a L3 switch did you make the user ports switchports instead of routed ports ?

New Member

Re: DHCP doesnt work through cisco switch.

Do you have any VLANS Configured?

Does your router know the DHCP server address?

ip-helper x.x.x.x

New Member

Re: DHCP doesnt work through cisco switch.

You will need to create another VLAN to support the 192.1.1.0 network. All interfaces right now are in the 10.0.0.0 (vlan 1) network and are unable to communicate with the DHCP server.

config t

interface vlan 2

ip add 192.1.1.x 255.255.255.0

int range fa0/1 - 24

switchport access vlan 2

switchport mode access

All switchports must be members of a VLAN, and, by default, it is VLAN 1. Because VLAN 1 was selected as the default VLAN for all switchports, it was also chosen to handle special traffic such as VLAN Trunking Protocol (VTP) advertisements, CDP, Port Aggregation Protocol (PAgP), or Link Aggregation Control Protocol messages (LACP). By default, in-band management interfaces such as sc0 are members of VLAN 1.

HTH

New Member

Re: DHCP doesnt work through cisco switch.

it is a L3 switch.

Unfortunately I need all switchports to be the member of VLAN1 (10.0.0.0 network)

Switch is not a DHCP server nor is it client only computers are using DHCP.

Can't I simply make switches just forward DHCP pazkets as other packets without interpreting them? (For the uniq application running on my system, I need to keep 10.0.0.0 network and switchports must be member of this VLAN)

tx for helping :)

Purple

Re: DHCP doesnt work through cisco switch.

I think you need to provide a little more info like the current config and how it is connected to the upstream devices . Some device must be routing if you are using 2 separate networks otherwise you would not be able to talk between them .

New Member

Re: DHCP doesnt work through cisco switch.

Is your DHCP server going to be on this switch? If so, can put that server's switchport on a different vlan? Then you can use the ip helper-address command and forward DHCP requests to that server.

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/swipaddr.htm

219
Views
5
Helpful
9
Replies