Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP=IP assignment issue.

Hi

i am using cisco 871 router for wireless connectivity.the ethernet port is connecte to lan and users are connected to wireless interface.problem is users are getting connected to wireless network but not getting ip address from dhcp server.dhcp server reeachable from lan.even tried using internel dhcp server.if we connect teh laptop to ethernet port of the router,the laptop is getting ip from dhcp server but its not happeneing on wireless.

anyone can help on this.present config attached.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: DHCP=IP assignment issue.

Hello Sameer,

of course you can use the subnet mask that is required no problem on this.

the configuration I've suggested will work it has been used by other collegues in other threads and is reported in C877 configuration guide.

>> Only the vlan is part of bvi or the ethernet port also which is connected in lan ????

this is the key point: in this platform ethernet interfaces are like switchports so bridge-group command is placed in the SVI vlan1.

by default all ports are switchport in Vlan1 (L2 broadcast domain).

see

http://www.cisco.com/en/US/partner/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999879

or

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999879

Hope to help

Giuseppe

5 REPLIES
Hall of Fame Super Silver

Re: DHCP=IP assignment issue.

Hello Sameer,

you need to use IRB also for SVI Vlan1

int vlan1

no ip address

bridge-group 1

no shut

int BVI1

ip address 10.x.y.z 255.255.255.0

ip helper-address

no shut

the BVI is the interface with L3 information.

Hope to help

Giuseppe

New Member

Re: DHCP=IP assignment issue.

Hi

i will check the same tomorrow morning and let u know the result.

anyway apart from the changes suggested by you do you suggest anything to be deleted from the present config ??.(Subnet mask on ethernet is /20 and not /24)

New Member

Re: DHCP=IP assignment issue.

Hi

Only the vlan is part of bvi or the ethernet port also which is connected in lan ????

last time i tried making ethernet port part of bvi group but the bvi was not coming up even though ethernet port was up.this is just a observation am sharing with u during the testing.

Hall of Fame Super Silver

Re: DHCP=IP assignment issue.

Hello Sameer,

of course you can use the subnet mask that is required no problem on this.

the configuration I've suggested will work it has been used by other collegues in other threads and is reported in C877 configuration guide.

>> Only the vlan is part of bvi or the ethernet port also which is connected in lan ????

this is the key point: in this platform ethernet interfaces are like switchports so bridge-group command is placed in the SVI vlan1.

by default all ports are switchport in Vlan1 (L2 broadcast domain).

see

http://www.cisco.com/en/US/partner/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999879

or

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999879

Hope to help

Giuseppe

New Member

Re: DHCP=IP assignment issue.

Hi

We tried the same and its working.

Thanks for the great input.

Thanks again

153
Views
0
Helpful
5
Replies