Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP, ip helper issue

Guys,

should this work,

I have two routers on one side, with ip helper enabled, in HSRP mode these two router,

acorss the wan link, where the dhcp is, I have two routers, in hsrp mode also, with secondary ip on each router, the subnet of the DHCP server is the same as the main interface, not the secondary

?

here is a sample config:

Router config where the dhcp is needed:

interface FastEthernet0/0

description Customer LAN interface

ip address 32.80.228.131 255.255.255.128

ip helper-address 32.80.183.23

service-policy input PolicyMap_2

service-policy output PolicyMap_1

ip ospf cost 100

duplex full

speed 100

no cdp enable

standby 1 ip 32.80.228.129

standby 1 priority 110

standby 1 preempt

standby 1 track Serial0/0/0.1

router config where DHCP is:

interface FastEthernet0/0

description Customer LAN interface

ip address 32.91.247.130 255.255.255.128 secondary

ip address 32.80.183.17 255.255.255.0

service-policy input PolicyMap_0

service-policy output PolicyMap_1

ip ospf cost 100

duplex full

speed 100

no cdp enable

standby 1 ip 32.80.183.1

standby 1 ip 32.91.247.129 secondary

standby 1 priority 110

standby 1 preempt

standby 1 track Serial0/0/0.1

thx

2 REPLIES
Hall of Fame Super Silver

Re: DHCP, ip helper issue

Jafar

Based on what you have posted I would not see any problem with ip helper-address working, assuming that you have appropriate routing so the 32.80.183.0 is reachable from the first router and that 32.80.228.128 is reachable from the second router.

Since you are running HSRP on the first router, I assume that there is a second router on that segment. Have you also configured ip helper-address on the second router? I would think that you should so that if there is a problem and the first router is not functioning you would need the second router to forward the DHCP packets.

HTH

Rick

New Member

Re: DHCP, ip helper issue

I added the global command: SERVICE DHCP on the two routers, where the clients are, this worked.

Thanks

325
Views
5
Helpful
2
Replies