Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

DHCP issue - Cisco 3750X series switch

Issue:

DHCP is not working in my network between two different vlans even after configuring ip helper-address in the switch. Provided below the configuration of switch. Please help to identify the problem:

DHCP Server is part of vlan 100, primary - x.y.112,141 and secondary - x.y.112.142. 

 

XYZABCDMZ-SW2#sh run

Building configuration...

 

Current configuration : 24037 bytes

!

version 12.2

no service pad

service tcp-keepalives-in

service timestamps debug datetime msec show-timezone

service timestamps log datetime msec show-timezone

service password-encryption

!

hostname XYZABCDMZ-SW2

!

boot-start-marker

boot-end-marker

!

logging buffered 5000 informational

!

!

aaa new-model

!

 --More--         !

aaa authentication login default group tacacs+ local

aaa authentication login LOCAL local

aaa authentication dot1x default group radius

aaa authorization exec default group tacacs+

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

!

!

!

aaa session-id common

clock timezone gmt -6

clock summer-time GMT recurring

switch 2 provision ws-c3750x-48

system mtu routing 1500

authentication mac-move permit

no ip subnet-zero

no ip source-route

no ip domain-lookup

ip domain-name XYZABC.com

!

!

 

dot1x system-auth-control

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree portfast bpduguard default

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

spanning-tree uplinkfast

spanning-tree backbonefast

!

!

!

errdisable recovery cause udld

errdisable recovery cause bpduguard

errdisable recovery cause channel-misconfig (STP)

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

 --More--         errdisable recovery cause link-flap

errdisable recovery cause sfp-config-mismatch

errdisable recovery cause gbic-invalid

errdisable recovery cause dhcp-rate-limit

errdisable recovery cause storm-control

errdisable recovery cause arp-inspection

errdisable recovery cause loopback

errdisable recovery interval 30

!

vlan internal allocation policy ascending

vlan dot1q tag native

!

!

!

interface Port-channel1

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface FastEthernet0

 no ip address

 no ip route-cache

 no ip mroute-cache

 shutdown

 --More--         !

interface GigabitEthernet2/0/1

 switchport access vlan 10

 switchport mode access

 switchport nonegotiate

 switchport port-security

 switchport port-security violation restrict

 storm-control broadcast level 3.00

 storm-control multicast level 3.00

 spanning-tree portfast

 spanning-tree guard root

!

interface GigabitEthernet2/0/2

 switchport access vlan 10

 switchport mode access

 switchport nonegotiate

 switchport port-security

 switchport port-security violation restrict

 shutdown

 authentication port-control auto

 dot1x pae authenticator

 storm-control broadcast level 3.00

 storm-control multicast level 3.00

 --More--         spanning-tree portfast

 spanning-tree guard root

!

interface GigabitEthernet2/0/43

!

interface GigabitEthernet2/0/44

!

interface GigabitEthernet2/0/45

 switchport access vlan 10

 shutdown

!

interface GigabitEthernet2/0/46

 switchport access vlan 100

!

interface GigabitEthernet2/0/47

 switchport access vlan 10

 switchport mode access

!

 --More--         interface GigabitEthernet2/0/48

 switchport access vlan 100

!

interface GigabitEthernet2/1/1

 description XYZABCDMZ-SW1

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet2/1/2

 shutdown

!

interface GigabitEthernet2/1/3

 description XYZABCDMZ-SW2

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet2/1/4

 switchport trunk encapsulation dot1q

 switchport mode trunk

 shutdown

!

interface TenGigabitEthernet2/1/1

!

 --More--         interface TenGigabitEthernet2/1/2

!

interface Vlan1

 no ip address

 no ip route-cache

 no ip mroute-cache

 shutdown

!

interface Vlan10

 ip address x.y.116.19 255.255.252.0

 ip helper-address x.y.112.142

 ip helper-address x.y.112.141

 no ip route-cache

 no ip mroute-cache

!

interface Vlan100

 ip address x.y.112.151 255.255.255.192

 no ip route-cache

 no ip mroute-cache

!

ip default-gateway x.y.116.1

ip classless

no ip http server

 --More--         ip http secure-server

!

ip sla enable reaction-alerts

logging x.y.116.144

logging x.y.112.144

access-list 1 permit x.y.112.144

access-list 4 permit x.y.112.142

tacacs-server timeout 30

--More--         !

line con 0

 exec-timeout 5 0

 logging synchronous

 login authentication LOCAL

line vty 0 4

 access-class 1 in

 exec-timeout 5 0

 logging synchronous

 transport input ssh

line vty 5 15

 exec-timeout 5 0

 logging synchronous

 transport input ssh

!

!

monitor session 1 source interface Gi2/0/47

monitor session 1 destination interface Gi2/0/43

monitor session 2 source interface Gi2/0/48

monitor session 2 destination interface Gi2/0/44

ntp clock-period 36026795

ntp server x.y.94.11

end

 --More--        

XYZABCDMZ-SW2#      exi

Everyone's tags (2)
2 REPLIES
Green

Hi,There are many reasons why

Hi,

There are many reasons why this may not be working.

Have you looked at the DHCP server itself.

Can it ping the vlan 100 & 10  addresses

Have the scopes been set set up correctly

Regards
Alex

Regards, Alex. Please rate useful posts.
Hall of Fame Super Silver

It might be helpful if the

It might be helpful if the originl poster would post the output of show vlan from the switch.

 

HTH

 

Rick

398
Views
0
Helpful
2
Replies
CreatePlease to create content