Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP Issue

I have to configure router 2811 for Data and Voice network.

However I have only one FastEthernet interface.

interface FastEthernet0/0

description Connected to LAN

no ip address

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface FastEthernet0/0.1

description  Data Network

encapsulation dot1Q 1 native

ip address 192.168.192.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.2

description VOIP Network

encapsulation dot1Q 2

ip address 192.168.193.1 255.255.255.0

ip helper-address 192.168.192.75

Again this router is connected with 2950 cisco switch.

Switch port configuration.

interface FastEthernet0/24

description 2811:f0/0

switchport mode trunk

switchport nonegotiate

spanning-tree portfast

Question, what else do I need to configure on switchport on which Avaya phones are connected.

And is there any extra command, i need to configure on the router and 2950 switch.

Everyone's tags (1)
4 REPLIES

DHCP Issue

You'll need to create vlan 2 on the 2950. On the ports that phones connect to, you can configure this vlan to be your voice vlan:

int fa0/2

switchport voice vlan 2

switchport access vlan 1

On your dhcp server, you'll need to pass Option 242 to the phones describing the call server's address and the vlan information that you want the phone to pull. You'll need to put the 242 option on the dhcp server that serves your hosts on the data vlan. The hosts don't understand the 242 option, so they just ignore it but the phones will pick it up and reboot on the new vlan 2.

For a Windows server, you'll need to add the 242 string to both the data vlan (reasons above) and the voice vlan.

"MCIPADD=,MCPORT=1719,L2QVLAN=2,VLANTEST=60"

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

DHCP Issue

Thanks for replying.

Vlan 2 is already configured on the Vlan 2950 switch.

I have couple of questions.

First, do I need to configure commands like you mentioned on every switchport, on which Avaya phone is connected. Again workstation will then be connected with Avaya phone.

switchport voice vlan 2

switchport access vlan 1( I believe this is optional)

Again, as we have windows based DHCP server under different team.

Can you please explain again, what needs to be done, as I got confused.

Again,

"MCIPADD=,MCPORT=1719,L2QVLAN=2,VLANTEST=60"

What does VLANTEST=60 MEAN

Re: DHCP Issue

VLANTEST=60 is the timeout period for getting a dhcp response on the vlan specified.

switchport access vlan 1 was just to show you that you don't have to trunk the port for the phone. So in your case being that your native vlan is 1, it's purely optional and probably won't even show up in the running config. Other than that, you'll want to configure your port in access mode though.

Yes, on every switchport that has a phone. An alternative would be to trunk all ports across the switch and add vlan 2 to the trunk.

HTH, John *** Please rate all useful posts ***
Gold

DHCP Issue

Hi,

you have to enable mls qos on you switch (global config) and mls qos trust cos on the interfaces with IP phones on them.

assign the interfaces with an ip phone attached to the voice vlan as John instructed you, and if there are work stations connected to the ip phones, the switchport access vlan 1 makes your switch to put DATA traffic in vlan 1 and voice in vlan 2.

for windows DHCP server to serve Avaya phones check this:

http://www.ipofficeassistance.com/HOWTO_DHCP_IP_Phones.html

plz Rate if it helped.

Soroush

Hope it Helps, Soroush.
897
Views
0
Helpful
4
Replies