Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dhcp pool for vlan no native

Hi,

I need to give ip addresses at an a Vlan (4) which isn't native on my switch and

not even management.

This command below are for native vlan.

How have to I modify it for another vlan configured on my switch ?

Can anybody advice me an a document about ?

Best regards

Lorenzo

interface vlan1

ip address 192.168.22.1 255.255.255.0

ip dhcp pool myvlan

network 192.168.22.128 255.255.255.128

dns-server 192.168.1.13 192.168.1.6

default-router 192.168.22.254

lease 10

3 REPLIES

Re: dhcp pool for vlan no native

Hi Lorenzo,

You need to add new configuration, the same way as you have for the existing IP range. For example

ip dhcp excuded-address 192.168.200.1

interface vlan4

ip address 192.168.200.1 255.255.255.0

ip dhcp pool NewVlan4

network 192.168.200.0 255.255.255.0

dns-server 192.168.1.13 192.168.1.6

default-router 192.168.200.1

lease 10

Here I am assuming your new range will be 192.168.200.1/24 in VLAN4.

Hope this helps... please rate all helpfull posts.

Shaheen

New Member

Re: dhcp pool for vlan no native

Hi Shaheen ,

can I add this command

at my existing configuration ?

best regards

Lorenzo

Re: dhcp pool for vlan no native

You can add as many networks statements as you want for DNS.

Basically the interface on a subnet A will provide DHCP as a DHCP server if there is a network statement for this subnet A under the DHCP pool.

236
Views
0
Helpful
3
Replies