Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP Problems

Hi all,

I have a Catalyst 3560 with a 12.4 ipservices image, in which I configured DHCP server for a data vlan and a voice vlan. the configuration is:

ip dhcp pool <pool name>

network 10.0.0.0 255.0.0.0

default-router 10.0.0.1

Pool 1 is for data and pool 2 for voice

The interface config is

interface range FastEthernet0/1-24

switchport host

switchport access vlan 109

switchport voice vlan 209

mls qos trust dscp

The problem is when I connect a phone it gets an IP address from the data pool, not the voice pool.

What am I doing wrong or what is missing in the configuration?

Thanks

10 REPLIES

Re: DHCP Problems

What are the types of IP phones?

Community Member

Re: DHCP Problems

The type is nonCisco SIP phones

Re: DHCP Problems

OK - the reason why is your SIP phones are not tagging their traffic with a 802.1q value.

HTH>

Community Member

Re: DHCP Problems

I changed the port to trunk and now is getting no Ip address at all

Re: DHCP Problems

That is because the switch port is expecting a 802.1q tag in the ethernet frame.

Does your IP hardphone support 802.1q? You also need to tell the trunk port, what the native VLAN is, i.e which vlan should the switch place all un-tagged frames into.

I would suggest you find out what the SIP phones can do before you make config changes.

Re: DHCP Problems

Hi,

I dnot see the pool for voice..?

Can u paste the config.

Thanks

Mahmood

Community Member

Re: DHCP Problems

ip dhcp pool 2

network 10.16.109.0 /24

default-router 10.16.109.1

Community Member

Re: DHCP Problems

option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719,L2Q=1,L2QVLAN=109,L2QAUD,L2QSIG=3"

This option needs to be bound to your data vlan, your phone will then get this ip address and see that the L2QVLAN=109 is the voice vlan, it will release the IP address then collect a new one from the voice vlan.

This then needs to be added to the voice vlan pool

option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719"

The other options are for the telephone controller.

The above syntax is for avaya

;-)

Cheers

Matt

Community Member

Re: DHCP Problems

What changes should I do on the switch for option 176

Tnaks

Community Member

Re: DHCP Problems

try just....

option 176 ascii "L2QVLAN=109"

on the data vlan

see if this makes the phone release the ip from the data vlan and grab one form the voice vlan

What model of phone is it, do you have a controller for it?

or are you just connecting it to a remote sip provider?

The other options are to specify things like the firmware for the phone.

We use mitel which luckily uses cdp to determined its voice vlan ;-)

Matt

208
Views
0
Helpful
10
Replies
CreatePlease to create content