Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP Relay across VLAN problem

I have a client on a swtich plugged into an access port vlan 98

I have a trunk on the same switch that carries two VLAN's 98 and 50 - where 98 is the native vlan.

This trunk connects to a router/fw. The router that has a helper address configured on each vlan to the DHCP Server configured with two scopes.

I run a debug on the router and see the following:

When the client requests a DHCP address, I can see two requests - one from VLAN 50 and one from VLAN 98. I can also see the reply from the DHCP Server giving two IP's one from the 50 scope and one from the 98 scope to the same mac address.

If I turn off the helper address for the 50 subinterface of the router the client gets the correct 98 address, the problenm is I need DHCP to work on both of these VLANS.

Any ideas?

9 REPLIES

Re: DHCP Relay across VLAN problem

Hi,

May I request you to paste some of your config please, as this really helps us to figure out the things pretty soon.

Secondly on the other hand, I was wondering if you have already used, IP Helper command in order to get the DHCP Relay Agent working across the VLANs.

Kindly rate if it helps.

Regards,

Wilson Samuel

New Member

Re: DHCP Relay across VLAN problem

interface FastEthernet0/29

switchport access vlan 98

switchport mode access

spanning-tree portfast

interface FastEthernet0/47

switchport trunk allowed vlan 50,98

switchport mode trunk

spanning-tree portfast

Not much more to it. The other device that the trunk connects to is not a Cisco, but the debugs clearly show two requests comming in - one from VLAN 98 and one from VLAN 50 - at this point only one client is connected to the switch.

## 2006-11-10 15:52:38 : DHCP: got packet from if .

## 2006-11-10 15:52:38 : DHCP: got packet from if .

New Member

Re: DHCP Relay across VLAN problem

It sounds like you have these two VLANs bridged together at some point in your network.

New Member

Re: DHCP Relay across VLAN problem

I don't think so - I just built these two networks (98 and 50) new and am integrating them into my existing network.

New Member

Re: DHCP Relay across VLAN problem

You mentioned that vlan 98 was your native VLAN (is that how the router is configured) Your switch doesn't have a nativel VLAN configured making it VLAN 1 by default

New Member

Re: DHCP Relay across VLAN problem

Here is the native VLAN info....The router it connects to is not a Cisco, so the native VLAN concept does not exist.

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan98

ip address 10.161.98.2 255.255.255.0

no ip route-cache

Purple

Re: DHCP Relay across VLAN problem

Where is the dhcp server ? Is it on one of the 2 vlans ? If so technically you would only need 1 helper address on the vlan that the dhcp server is not . This shouldn't be the problem , really can't imagine how you could get 2 requests . You have a user on 98 it gets passed to the trunk interface which then tags the packet with a 98 tag and trunks it across , my guess would the router is doing something strange with it or is not configured quite right . Possibly check the router docs on how to trunk the vlan for any config mistakes ,the switch end looks fine though . Sure the dhcp server is correct ?

New Member

Re: DHCP Relay across VLAN problem

DHCP Server is on a separate segment. If I turn off helper address for the 50 VLAN the 98 gets his address via DHCP. and if I turn off helper on the 98 the 50 gets his address. I am leaningtowards a probelm with the router running Helper - although I am not sure why I am seeing two request come from the 2950 - one for each VLAN.

New Member

Re: DHCP Relay across VLAN problem

Hi -

Can you provide a sh interface trunk from the Cisco device. The Native VLAN concept is a part of the 802.1Q standard, and must be identical in both ends of trunk (according to Cisco to prevent Spanning Tree loops).

590
Views
0
Helpful
9
Replies