Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP Relay on 3560

Would like to impliment VLAN's on

Cisco IOS Software, C3560 Software (C3560-IPSERVICES-M), Version 12.2(25)SEB4

But I need a DHCP Realy to my Windows Based DHCP Server.  How do I enable DHCP Relay on the 3560?

Thanks!

Mark Berry

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: DHCP Relay on 3560

the ip helper command would be on your Layer 3 interface.  based on the output you are showing I suspect you are looking at a layer 2 interface.  for example a basic config might see something like this:

...

interface GigabitEthernet1/0/1

description L2 interface in vlan 10

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/1

description L2 interface in vlan 11

switchport access vlan 10

switchport mode access

!

...

interface Vlan10

description Data Vlan

ip address 10.10.10.254 255.255.255.0

interface Vlan11

description Data Vlan two

ip address 10.10.11.254 255.255.255.0

ip helper-address 10.10.10.10

also ensure ip routing is enabled on global config

8 REPLIES
New Member

DHCP Relay on 3560

I think it is enabled by default.

Otherwise command:

#:config t

#:service dhcp

New Member

DHCP Relay on 3560

Oh and surely, i forgot to add

you will have to configure ip helper-address "DHCP server IP" on the interface you want to relay.

New Member

Re: DHCP Relay on 3560

Thank you for your reply.

But I don’t see a “ip helper-address option.

switch(config-if)#ip ? Shows only

access-group

arp

dhcp

igmp

verify

switch(config-if)#ip dhcp ? reveals only

snooping DHCP Snooping

New Member

Re: DHCP Relay on 3560

the ip helper command would be on your Layer 3 interface.  based on the output you are showing I suspect you are looking at a layer 2 interface.  for example a basic config might see something like this:

...

interface GigabitEthernet1/0/1

description L2 interface in vlan 10

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/1

description L2 interface in vlan 11

switchport access vlan 10

switchport mode access

!

...

interface Vlan10

description Data Vlan

ip address 10.10.10.254 255.255.255.0

interface Vlan11

description Data Vlan two

ip address 10.10.11.254 255.255.255.0

ip helper-address 10.10.10.10

also ensure ip routing is enabled on global config

New Member

Re: DHCP Relay on 3560

That looks like it!  Thanks!

So to recap:

1.  Verify DCHP enabled globaly

2.  Set ip helper-address on the VLAN (Layer 3) interface that points to the DHCP server.

and that's it eh?

Purple

Re: DHCP Relay on 3560

  If you  have your own dhcp server then all you need is the ip helper statement on any L3 interface that is not on the dhcp server subnet.

New Member

Re: DHCP Relay on 3560

Had never heard the term "Layer Three Interface".  Just assumed that all "interfaces" on a L3 switch would be "layer 3 interfaces".  So are all "VLAN" interfaces considered "Layer 3 Interfaces" and the physical "ports/interfaces" are considered "layer 2 interfaces"?

Purple

Re: DHCP Relay on 3560

   The answer is the ports can be either .  You can make the ports a "routed" L3  port where you put the ip address directly on the port itself  with the "no switchport"  command  or you can make the ports a layer 2 port with the "switchport" command and then if you want to route traffic on that port you would create a "SVI"  aka "interface vlan X   and assign those ports into the vlan .  It really depends on what you are trying to accomplish with the port or design considerations on how you set it up . 

1149
Views
0
Helpful
8
Replies
CreatePlease to create content