Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP relay problem

*** the following topology

- router1 with VLAN1: 10.32.214.161/24 and VLAN2: 215.161/24

- interface on this router1 for VLAN2 configured with ip helper-address 10.32.214.163

- router2 with DHCP server for both subnets: only one interface: 10.32.214.163

- PC connected to VLAN2: DHCP client

- sniffer on both the PC and a PC connected to VLAN1

** problem

- When the PC in in VLAN2, it sends out DHCP discover packets - as you should expect it is a normal broadcast

- the sniffer on VLAN1 sees DHCP discover packets coming from 10.32.215.161 going to 10.32.214.163 - also as you should expect

- BUT no answer comes from the DHCP server

- ALSO WEIRD: an 'sh ip d b' on router 2 shows a lease 10.32.215.1 for the MACaddress of the portable!!

** part of the config of router2:

ip subnet-zero

ip dhcp excluded-address 10.32.215.160 10.32.215.255

!

ip dhcp pool EFT-IT2

network 10.32.215.0 255.255.255.0

domain-name univeg.local

default-router 10.32.215.161

netbios-node-type h-node

dns-server 192.168.205.30 4.2.2.1

lease 0 8

!

interface FastEthernet0

ip address 10.32.214.163 255.255.255.0

no ip directed-broadcast

!

ip classless

** part of the config of router1:

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0

description IT-Lan

!

interface FastEthernet1

switchport access vlan 2

!

interface FastEthernet2

shutdown

!

interface FastEthernet3

shutdown

!

interface Vlan1

ip address 10.32.214.161 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan2

ip address 10.32.215.161 255.255.255.0

ip helper-address 10.32.214.163

ip nat inside

ip virtual-reassembly

!

interface Dialer0

description toevoegen: 'ip access-group 101 in' (winAmp werkt dan niet - nakijk

en)

ip address negotiated

ip access-group 102 out

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password xxx

ppp pap sent-username xxx password xxx

---

Can anyone help me with this?

Thanks!

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: DHCP relay problem

Hi Johan,

i can see "ip dhcp excluded-address 10.32.215.160 10.32.215.255" you have also mentioned the broadcast IP address in the excluded list, so can you make that up 10.32.215.254 & try, it workz fine.

rate this post if cleared.

Hall of Fame Super Silver

Re: DHCP relay problem

Johan

I am going to make a guess at the problem here. As you describe it the processing of DHCP seems normal, the request is received, an address is assigned, but no response is sent. My guess is that the request came from 10.32.215.161 and that router2 has no route to the 10.32.215 network. That would explain the failure to send the response - if the router does not know where to send the response. Can you post the output of show ip route from router2 which will verify my guess.

HTH

Rick

2 REPLIES

Re: DHCP relay problem

Hi Johan,

i can see "ip dhcp excluded-address 10.32.215.160 10.32.215.255" you have also mentioned the broadcast IP address in the excluded list, so can you make that up 10.32.215.254 & try, it workz fine.

rate this post if cleared.

Hall of Fame Super Silver

Re: DHCP relay problem

Johan

I am going to make a guess at the problem here. As you describe it the processing of DHCP seems normal, the request is received, an address is assigned, but no response is sent. My guess is that the request came from 10.32.215.161 and that router2 has no route to the 10.32.215 network. That would explain the failure to send the response - if the router does not know where to send the response. Can you post the output of show ip route from router2 which will verify my guess.

HTH

Rick

183
Views
0
Helpful
2
Replies
CreatePlease login to create content