Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

DHCP Relay problem

I have two routers on my lan, both with the same function: bootp relay.

Both have exact the same config:

Router1 (C1720):

---

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname DHCPRelay_tst2_C1720

!

enable password test

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface BRI0

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet0

ip address 10.32.214.163 255.255.255.0

ip helper-address 192.168.205.30

no ip directed-broadcast

!

router eigrp 1

network 10.0.0.0

!

router rip

network 10.0.0.0

!

ip classless

!

!

line con 0

password test

login

transport input none

line aux 0

line vty 0 4

password test

login

!

no scheduler allocate

end

---

Router2 (C1601):

---Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname DHCPRelay_tst1_C1601R

!

enable password test

!

ip subnet-zero

no ip domain-lookup

!

!

!

interface Ethernet0

ip address 10.32.214.164 255.255.255.0

ip helper-address 192.168.205.30

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

shutdown

!

router eigrp 1

network 10.0.0.0

!

router rip

network 10.0.0.0

!

ip classless

!

!

line con 0

password test

login

transport input none

line vty 0 4

password test

login

!

end

---

Problem: when a client request an IP, both routers relay the request to the DHCP server, but on the DHCPserverLAN, only the request from the 1st router is received. Both routers have a correct route to that server, and no firewalls are in between.

I notice the following however:

- the original DHCP discovery request from the client is a broadcast with soruceport 68 to destport 67 - seems normal.

- router 1 sends to the DHCPserver using sourceport 67 to destport 67

- router 2 sends to the DHCPserver using sourceport 68 to destport 67

So both routers have a different behaviour - anybody know why?

And why doens't the 2nd DHCP disc relay request doens't get through to the DHCPserver?

thanks!!!!

2 REPLIES

Re: DHCP Relay problem

are u able to ping DHCP server 192.168.205.30 from 2nd router using source IP 10.32.214.164 ?

Community Member

Re: DHCP Relay problem

yes, that is no problem.

I find it strange that both routers use a different sourceport (67 vs. 68) to relay the discovery packet.

I don't know if this is the source of my problem though.

167
Views
0
Helpful
2
Replies
CreatePlease to create content