Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

DHCP Relay question

Hello experts,

Hope you can help me with this scenario:

PC

|

(NM-16ESW)

c2691#1

(Fast0/0)

|

L2_Sw - PCs

|

(Fast0/0)

c2691#2

I have a DHCP pool configured in router c2691#2, which leases IP addresses to the PCs

attached to L2_Sw. I need to plug a PC on one of the 16 ports available in the NM-16ESW

module of the c2691#1 router and that PC should take an IP address from the DHCP pool

configured in c2691#2 router.

I have done a lot of configuration but I haven't had any luck so far. Is this possible?

Can somebody help me with the correct configuration of both routers?

Here is my last try:

*********

c2691#1

*********

ip dhcp relay information option

ip dhcp relay information trust-all

!

!

interface FastEthernet0/0

ip address 172.31.34.6 255.255.255.0

ip helper-address 172.31.34.2

duplex auto

speed auto

standby ip 172.31.34.1

standby priority 130

!

!

interface FastEthernet1/0

Description PC goes here!!!

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet1/1

spanning-tree portfast

!

interface FastEthernet1/2

spanning-tree portfast

!

:

interface FastEthernet1/15

spanning-tree portfast

!

interface Vlan1

no ip address

!

*********

c2691#2

*********

ip dhcp relay information trust-all

no ip dhcp use vrf connected

ip dhcp excluded-address 172.31.34.1 172.31.34.89

ip dhcp excluded-address 172.31.34.99

!

ip dhcp pool POOL

network 172.31.34.0 255.255.255.0

default-router 172.31.34.1

dns-server 172.16.3.100 172.16.3.101 172.17.4.11

lease 2

!

interface FastEthernet0/0

description CONEXION LAN

ip address 172.31.34.2 255.255.255.0

duplex auto

speed auto

standby ip 172.31.34.1

standby priority 150

standby preempt

!

Thanks in advanced!!!

Juan Corrales

Network Specialist

ITS/FIFCO CR

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: DHCP Relay question

Could you connect router to switch via switch module? Use fa1/15 instead of fa0/0?

10 REPLIES
New Member

Re: DHCP Relay question

Hello Juan,

did you try to configure fa0/0 on c2691#1 as standard switched interface?

Karel Vins

Re: DHCP Relay question

Hello Karel,

I cannot do that because I need f0/0 as a layer 3 interface doing HSRP with f0/0 of router 2691#2.

Juan Corrales

New Member

Re: DHCP Relay question

Hi Juan,

is it possible to use Vlan 1 interface as L3 interface instead of fa0/0?

Karel

Re: DHCP Relay question

What's the configuration you're suggesting? Configure F0/0 as a trunk and use Vlan 1 as the L3/HSRP interface?

New Member

Re: DHCP Relay question

My suggestion is:

1) configure fa0/0 as switched access port in Vlan 1 and try if DHCP is working,

2) configure Vlan 1 as L3/HSRP interface.

I thing that fa0/0 can be access port not trunk port if you don't need more than one Vlan between router and switch.

Re: DHCP Relay question

How can I configure a pure Layer 3 interface as an access switch port? I don't have any switchport commands available.

New Member

Re: DHCP Relay question

Ou, it's my mistake. I didn't realize that fa0/0 is not interface of switch module.

Re: DHCP Relay question

No problem... The interfaces of switching module are fa1/0-15. Any other thought?

New Member

Re: DHCP Relay question

Could you connect router to switch via switch module? Use fa1/15 instead of fa0/0?

Re: DHCP Relay question

I think that is the best solution.

Thanks a lot!

282
Views
5
Helpful
10
Replies