Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

dhcp server and vlans

Hi all, If I have my network say on a 10.1.0.0/16 on vlan 1 and a dhcp server on that network also, and I have a scope on my dhcp server for this, say 10.1.0.1 to 10.1.1.254, If I create another scope on my dhcp server say 10.5.0.1 to 10.6.1.254 /24 will the hosts be able to see this scope on vlan 1 ?

3 REPLIES
New Member

Re: dhcp server and vlans

Yes. It is a broadcast remember.

If you want the DHCP server to give out specific IP addresses to specific workstations then I would not put the DHCP server in the same VLAN as all of the other hosts.

Consider creating 3 VLANs.

1 for your servers

1 for your workstations 10.1.0.0/16 (I would make this a smaller network)

1 for your workstations 10.5.0.0/15 (make this a smaller network also)

Then configure ip helper on your vlan interfaces. The DHCP server will get a relay message from the gateway of the respective network and it will understand to supply the IP address accordingly.

vlan 2

name server-net-10.7.1.0/24

vlan 3

name workstation-net-10.1.0.0/16

vlan 4

name workstation-net-10.5.0.0/15

interface vlan 2

ip address 10.7.1.254 255.255.255.0

no shut

interface vlan 3

ip address 10.1.x.x/16

no shut

ip helper-address

interface vlan 4

ip address 10.5.x.x/16

no shut

ip helper-address

Not sure if that is what you are looking to do but good luck.

New Member

Re: dhcp server and vlans

If the server is on say 10.112.0.0/16 network and there is a scope on the server for this same subnet and also a scaope of there for say 192.168.1.0/24 network, which scope would it give out? would it give the 10.112.0.0 scope out as the server has an interface on that subnet ?

New Member

Re: dhcp server and vlans

It will give out whatever the forwarding network is. 10.112.0.0 in this case. 192.168.1.0/24 will never be assigned, unless you specify another vlan that contains hosts that will potentially be on this network. You will then have to setup the ip helper-address to forward the dhcp requests to the dhcp server.

114
Views
0
Helpful
3
Replies