Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DHCP Server not working on 1721?

I've setup a 1721 on an adsl connection. Everything works ok except the local dhcp server. Its setup as per all the proper cisco documentation but for some reason it just will not serve addresses to client pc's.

Ive ran a dhcp debug and tried an ipconfig /renew from a client, but the router just sits there and see's no events.

ANyone got any ideas?

6 REPLIES

Re: DHCP Server not working on 1721?

can you post the configs

Narayan

Cisco Employee

Re: DHCP Server not working on 1721?

Did you enable " Service DHCP " in the global configuration mode. Please paste the router configuration.

-amit singh

New Member

Re: DHCP Server not working on 1721?

hi Guys

Here is my config, passwords and WAN IP addresses have been removed to protect the innocent :D

!

version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret ********************

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.7.1

!

ip dhcp pool HOME

import all

network 192.168.7.0 255.255.255.0

default-router 192.168.7.1

dns-server **************** ****************

lease infinite

!

!

no ip ips deny-action ips-interface

ip name-server 212.87.64.7

ip name-server 212.87.64.10

!

no ftp-server write-enable

!

!

interface ATM0

description ADSL line interface

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Ethernet0

no ip address

shutdown

!

interface FastEthernet0

description LAN

ip address 192.168.7.1 255.255.255.0

ip access-group 101 in

ip nat inside

ip virtual-reassembly

speed auto

no cdp enable

!

interface Dialer1

description Connection to ADSL

ip address *********** 255.255.255.252

ip access-group 102 in

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname ****************

ppp chap password ****************

ppp pap sent-username **************** password ****************

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 101 interface Dialer1 overload

ip nat inside source static tcp 192.168.7.2 3389 80.175.102.137 3389 extendable

ip nat inside source static tcp 192.168.7.2 29310 80.175.102.137 29310 extendable

ip nat inside source static udp 192.168.7.2 29310 80.175.102.137 29310 extendable

!

access-list 100 deny ip any any

access-list 101 permit ip 192.168.7.0 0.0.0.255 any

control-plane

!

!

line con 0

exec-timeout 0 0

password ****************

login

line aux 0

line vty 0 4

privilege level 15

password ****************

login local

transport input telnet ssh

!

end

Hall of Fame Super Gold

Re: DHCP Server not working on 1721?

Josh

I believe that the problem is the access list which is applied inbound on the FastEthernet interface:

access-list 101 permit ip 192.168.7.0 0.0.0.255 any

The problem is that the DHCP request from the client has source address of 0.0.0.0 and this is not permitted by your access list. If you add a permit for host 0.0.0.0 I think that you will see DHCP work.

HTH

Rick

Re: DHCP Server not working on 1721?

Add either of the following to your access-list

as suggested by Rick

access-list 101 permit ip host 0.0.0.0 host 255.255.255.255

A better option would be to use the below

access-list 101 permit udp any any eq 67

access-list 101 permit udp any any eq 68

Try this and let us know how it goes

HTH, rate if it does

Narayan

New Member

Re: DHCP Server not working on 1721?

Hi Guys

The first options works, thanks!

Ive not tried the second option, but will consider that if i fix the other issue ive been having...

Which is that the router seems to drop the adsl connection regylarly, almost hourly. Ive rebuild a new config using SDM and also upgraded to the latest IOS, but nothing seems to fix the issue.

I know my line is ok as my old cheapy router stays connected forever pretty much.

Is there a chance the WIC is faulty?

882
Views
0
Helpful
6
Replies
CreatePlease to create content