Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP Server on 3550

Hi all,

I have Cisco 3550, i wan to configure DHCP server on same.

i have done following configuration

ip dhcp pool LAB_N/W

network 172.168.1.0 0.0.0.255

default-router 172.168.1.100

dns-server 202.x.x.6

service dhcp

is that all or i still need to heve more configuraton.?

after this much configuration i am not getting the ip-address from DHCP server (3550).

Thanks

Dhaval Tandel

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: DHCP Server on 3550

Hi Dhaval,

It should work in both the scenarios. In first scenario on which vlan you have configured this ip address and also on which vlan you have connected your client.

Do something like this taking an example of vlan 10

interface vlan 10

ip address 172.168.1.100 255.255.255.0

interface fa0/10

switchport mode access

switchport access vlan 10

Connect you client on this interface and it should be able to get an ip adfdress frm your DHCP pool.

HTH

Ankur

*Pls rate all helpfull post

5 REPLIES
Cisco Employee

Re: DHCP Server on 3550

Hi Dhavel,

Try changing your network statement to

network 172.168.1.0 255.255.255.0

or

network 172.168.1.0/24

Also you can exclude your default-router address from the DHCP pool list with command

"ip dhcp excluded-address 173.168.1.100" to be issued on global config mode.

Also can you confirm which vlan this subnet belongs to and you have connected you clients on same vlan?

Regards,

Ankur

Re: DHCP Server on 3550

Dhaval,

You need to have a normal subnet mask and not the inverse wild card mask when defining the network range

Also it is always wise to exclude the ip address configured on the 3550 if any

If you have any access-lists make sure it allows UDP ports 67 & 68

HTH, rate if it does

Narayan

New Member

Re: DHCP Server on 3550

Hi all,

Thanks for takin interest,

i did same

i exclude the address as well given the correct sub-net mask. and i don have any access-list between.

my scenario is

Laptop (Client)----3500 (DHCP Server)

i am confuse with this scenarion, i don have hand on with layer-3 devices. is this connection looks good.? i also tried as,

Client---L-2-Switch-----3550 (DHCP Server)

where 3550 has one port as layer-3 (no switchport & also assigned ip-address)

still it dosent work.

thanks

dhaval tandel

Cisco Employee

Re: DHCP Server on 3550

Hi Dhaval,

It should work in both the scenarios. In first scenario on which vlan you have configured this ip address and also on which vlan you have connected your client.

Do something like this taking an example of vlan 10

interface vlan 10

ip address 172.168.1.100 255.255.255.0

interface fa0/10

switchport mode access

switchport access vlan 10

Connect you client on this interface and it should be able to get an ip adfdress frm your DHCP pool.

HTH

Ankur

*Pls rate all helpfull post

New Member

Re: DHCP Server on 3550

thanks,

ANkbhsi

i was just missing VLAN.

now i got resolved.

thanks

dhaval tandel

7010
Views
0
Helpful
5
Replies