Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DHCP Snooping logging

I set up a simple lab and enabled dhcp snooping

 

PC1---F0/1--SWITCH--F0/24---DHCP Server

 

I added 'trust' under f0/24 and pc received an ip address, there was a dhcp snooping binding. I removed 'trust', release an ip from the pc and pc did not get an ip. that's great however the switch did NOT report anything on the screen and in the stats I cannot see any dropped dhcp messages? I tried on two Cisco switches...

 

Switch#sh ip dhc snooping stat det
 Packets Processed by DHCP Snooping                    = 22
 Packets Dropped Because
   IDB not known                                       = 0
   Queue full                                          = 0
   Interface is in errdisabled                         = 0
   Rate limit exceeded                                 = 0
   Received on untrusted ports                         = 0
   Nonzero giaddr                                      = 0
   Source mac not equal to chaddr                      = 0
   No binding entry                                    = 0
   Insertion of opt82 fail                             = 0
   Unknown packet                                      = 0
   Interface Down                                      = 0
   Unknown output interface                            = 0
   Misdirected Packets                                 = 0
   Packets with Invalid Size                           = 0
   Packets with Invalid Option                         = 0

 

Switch#sh ip dhcp snooping

Switch DHCP snooping is enabled
DHCP snooping is configured on following VLANs:
1
DHCP snooping is operational on following VLANs:
1
DHCP snooping is configured on the following L3 Interfaces:

Insertion of option 82 is disabled
   circuit-id default format: vlan-mod-port
   remote-id: 0019.e8a3.df80 (MAC)
Option 82 on untrusted port is not allowed
Verification of hwaddr field is enabled
Verification of giaddr field is enabled
DHCP snooping trust/rate is configured on the following Interfaces:

Interface                  Trusted    Allow option    Rate limit (pps)
-----------------------    -------    ------------    ----------------
Switch#

 

Switch#sh ip dhc sno sta
 Packets Forwarded                                     = 38
 Packets Dropped                                       = 0
 Packets Dropped From untrusted ports                  = 0
Switch#

 

 

 

 

 

 

PC says

C:\Users\user>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.

 

No other config on the switch, just

ip dhcp snooping vlan 1
ip dhcp snooping

 

Have I missed sth easy here?

7 REPLIES
New Member

Any ideas please?

Any ideas please?

New Member

"Insertion of option 82 is

"Insertion of option 82 is disabled"

 

What is the dhcp snooping configuration that you are running?

New Member

one switch, dhcp server and

one switch, dhcp server and pc connected to vlan 1

New Member

I meant the IOS command

I meant the IOS command configuration.

New Member

I tried on a 2960 and it is

I tried on a 2960 and it is the same - no logs, no stats. Any ideas please?

New Member

Switch#sh run

Switch#sh run
Building configuration...

Current configuration : 1392 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
!
ip dhcp snooping vlan 1
ip dhcp snooping
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2,6,9,74,77
!
vlan 99
 name MGMT
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address dhcp
!
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end


[b]Switch#sh ip dhcp binding[/b]
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
Switch#
Switch#
Switch#sh ip dh
Switch#sh ip dhcp sn
Switch#sh ip dhcp snooping stat
 Packets Forwarded                                     = 147
 Packets Dropped                                       = 0
 Packets Dropped From untrusted ports                  = 0

[b]Switch#sh ip dhcp snooping dat[/b]
Agent URL :
Write delay Timer : 300 seconds
Abort Timer : 300 seconds

Agent Running : No
Delay Timer Expiry : Not Running
Abort Timer Expiry : Not Running

Last Succeded Time : None
Last Failed Time : None
Last Failed Reason : No failure recorded.

Total Attempts       :        0   Startup Failures :        0
Successful Transfers :        0   Failed Transfers :        0
Successful Reads     :        0   Failed Reads     :        0
Successful Writes    :        0   Failed Writes    :        0
Media Failures       :        0

---------------------------
PC:
C:\Users\user>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.
An error occurred while releasing interface Loopback Pseudo-Interface 1 : The sy
stem cannot find the file specified.
                                            
New Member

I know this post is very old

I know this post is very old but I also have the same issue. Were you able to resolve it?

What I have noticed in my setup (Catalyst 3750X) is that I get the same issue in a lab environment setup with the switch logging to it's local log.

If I put the switch into a more complex live setup, logging to Unix Syslog via the logging traps and logging facility global configuration commands, then I do get the events logged to my Syslog server and the statistics are incremented as expected.

It is as if the logging/statistics are bypassed if the switch is only logging locally. I'm not sure if this is a bug or by design.

865
Views
0
Helpful
7
Replies
CreatePlease to create content