Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

dhcp-static

Hi everybody,

We 've tried to configure dhcp-static on a router.

When we use type "id" with client identifier, it works.

But when we use type "1" with mac-address, pc can't get ip address.

Could someone help, please?

9 REPLIES

Re: dhcp-static

Can you show us your config?

Kevin Dorrell

Luxembourg

New Member

Re: dhcp-static

Hi Dorrell,

Here attached (dhcp-static.txt) the config with the content of address-mapping files.

There's also output debug.

New Member

Re: dhcp-static

Sorry, here attached the conf and output debug.

New Member

Re: dhcp-static

Hi Dorrell,

Have you seen something wrong in the conf or in the map file?

config :

ip dhcp pool add

origin file tftp://192.168.102.38/add.txt

dns-server 62.56.162.33 62.56.240.40

default-router 41.204.12.9

ip dhcp pool add1

origin file tftp://192.168.102.38/add1.txt

dns-server 62.56.162.33 62.56.240.40

default-router 41.204.15.3

interface Ethernet0/0

ip dhcp relay information trusted

ip address 41.204.15.3 255.255.255.240

ip address 41.204.12.9 255.255.255.224 secondary

map file :

!IP address Type Hardware address Lease expiration

41.204.12.2 id 0100.13CE.87FA.C5

41.204.12.3 1 0014.22be.35da Infinite

Re: dhcp-static

I think in your pools, you will have to put in network statements to bind them to the interfaces:

ip dhcp pool add

 network 41.204.12.0 255.255.255.224

ip dhcp pool add1

 network 41.204.15.0 255.255.255.240

Don't forget to write exclusion clauses for your router addresses.

Kevin Dorrell

Luxembourg

New Member

Re: dhcp-static

ip dhcp pools must contain the network statments as Kevin said.

Otherwise the pools with not know which interfaces to associate the request / assignments with.

Re: dhcp-static

I was just thinking about my statement ".. in order to bind the pool to an interface .." and wondering how that related to relayed DHCP. Maybe rather it binds it to a route. So if a DHCP request comes in on an interface, and you have a pool whose network statement matches a route that can be found via that interface (connected or remote), then you serve the request. Is that how it works? If so, it somehow reminds me of the RPF check in multicast.

Can someone throw some more light on it?

Kevin Dorrell

Luxembourg

New Member

Re: dhcp-static

Kevin,

From my understanding, that is how it is applied / works.

New Member

Re: dhcp-static

Hi all,

We need to attribute IP adress depending on mac adress. So, we need to specify a map between mac - ip but not use network command.

We have problem using the command "origin file" with mac-adress.

226
Views
0
Helpful
9
Replies
CreatePlease to create content