Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP with VLAN

Hi,

Im testing a new DHCP on my network and I have 3 vlans on my core.

In this core i have the port fastethernet 4/3 on vlan 3, the port 4/4 on vlan 4 and the port 4/5 on vlan 5.

The core is on the vlan default 1, its IP is 10.0.50.1 255.255.255.0 and the DHCP is on the port fastethernet4/1 and its IP is 10.0.50.2.

When a plug a host on the port 4/3 it get a IP on the subnet of vlan 3. RIGHT. But, when i plug the same host on the port 4/4 or 4/5 the host get the SAME IP address and debugging the core i got the message: "XID NOT MATCHING dhcp_for_us"

What can be happening? What should I do?

See the configuration:

vlan 3

name SITE-3

!

vlan 4

name SITE-4

!

vlan 5

name SITE-5

!

!

!

interface FastEthernet2/1

description "DHCP IS IN THIS PORT WITH IP 10.0.50.2"

!interface FastEthernet2/3

switchport access vlan 3

!

interface FastEthernet2/4

switchport access vlan 4

!

interface FastEthernet2/5

switchport access vlan 5

!

!

!

interface Vlan1

ip address 10.0.50.1 255.255.255.0

!

interface Vlan3

ip address 10.0.10.1 255.255.255.0

ip helper-address 10.0.50.2

!

interface Vlan4

ip address 10.0.20.1 255.255.255.0

ip helper-address 10.0.50.2

!

interface Vlan5

ip address 10.0.30.1 255.255.255.0

ip helper-address 10.0.50.2

Thanks.

Tauer

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: DHCP with VLAN

Tauer

I believe that there is an issue with using superscopes to provide DHCP for VLAN routing on switches. Can you try 3 individual scopes?

You might look at this link for a discussion about using superscope:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&topicID=.ee71a04&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1de0230c

HTH

Rick

5 REPLIES
Community Member

Re: DHCP with VLAN

Hi Tauer,

Your switch configuration seems to be fine, I think you need to check the scope configuration carried out at your DHCP server.

Pls rate if helpful.

Community Member

Re: DHCP with VLAN

ok. Its configured with a Superscop with 3 diferents networks. What more should I care about on DHCP server? Its a microsoft DHCP server.

Hall of Fame Super Gold

Re: DHCP with VLAN

Tauer

I believe that there is an issue with using superscopes to provide DHCP for VLAN routing on switches. Can you try 3 individual scopes?

You might look at this link for a discussion about using superscope:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&topicID=.ee71a04&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1de0230c

HTH

Rick

Hall of Fame Super Gold

Re: DHCP with VLAN

Tauer

I am glad that my information was helpful. Thank you for using the rating system to indicate that your question was resolved (and thanks for the rating). It makes the forum more useful when people can read a question and can know that there will be a response which resolved the question.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

Community Member

Re: DHCP with VLAN

Sure,

I always use the forum. I had many question solved here.

Thanks for the help, again

279
Views
0
Helpful
5
Replies
CreatePlease to create content