Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP

Hi to all members, I'm trying to configure a Cisco 2600 router to do DHCP tried following the steps here:

http://www.routergeek.net/content/view/37/37/

But no luck, my client pc cant get an IP address from the router. Any help will be appreciated. Thanks in advance and good day to all.

Jefferson Co
8 REPLIES
New Member

Re: DHCP

Hi,

Kindly describe the topology how the clients are connected to the network. Also post the running config of the router which you want to act as DHCP server.

--gaurav

New Member

Re: DHCP

from the FastEthernet of the router a straight through cable going through a Linksys 24 port switch and the client pc's are connected from the switch using straight through cable as well.

Attached in this message as well is a copy after I typed in sh running-config

Thanks in advance and good day

Jefferson Co
New Member

Re: DHCP

Hi,

I'm not able to understand anything in the file attached. The word are inter-mingled. Kindly paste it directly on the space here.

--gaurav

New Member

Re: DHCP

Also let us know if you have created some vlans in your switch. preferably paste switches' config also.

--gaurav

Gold

Re: DHCP

we can't read that config you posted. some of it's garbled. can you repost it please.

New Member

Re: DHCP

sorry for the inconvenience, let me post it here directly...

there are no vlans configured in the switch

Current configuration : 1160 bytes Director response protoco

!

version 12.3y

service timestamps debug datetime msec####################ing Monitor

service timestamps log datetime msecservices

##########

no service password-encryption Cisco Express F

!w

hostname Topect an inter

!c

boot-start-marker

Smart In

clas

boot-end-marker Follow clas

!e

enable secret xxx ID MEMORY_REQ TYP

!

no aaa new-model Add a co

ip subnet-zerotry2

ip cef980 C2

!0

!u

no ip domain lookupmm

default-gatewa

!

ip dhcp pool dhcpdhcp gateway (if not rout

network 192.168.0.0 255.255.255.0vr utility command host/portP NAT in

default-router

!

!

!C

!f

!u

!

!t

!U

!N

!N

!

!u

!a

!b

!u

!n

!a

!u

interface FastEthernet0/0t Configure p

ip address 192.168.0.254 255.255.255.0roblem andhanismPv6 configuration

Top

ip broadcast-address 192.168.0.0p-server Specify addr

duplex autoerver to use

speed autoEM up to: 4

!.

interface Serial0/0ess-l

Using 6 per

no ip address Conf

ip broadcast-address 0.0.0.0 Restricted Rights L

shutdownformation

!s

interface FastEthernet0/1 IP DNS Resolverisclos

no ip addressrnment isab

ip broadcast-address 0.0.0.0 Domain name to complete un

shutdownhost name

duplex autoparagraphm n

speed autoounting ent

!e

interface Serial0/1ble

domain-looku

no ip addressble IP Domain

ip broadcast-address 0.0.0.0 Sets the max

shutdown

Software clause

ip classless. 252.227-70

!.

!

!m

!

!

!

!

!

line con 0 global co

password consolep@ssstems, Inc.Engine str

login

speed 115200ist Add

line aux 0 community

line vty 0 4on System S

login Sa

!J

!e

endlif

Top#sh running-conf

finger

Building configuration...o Internetwork Operating

Current configuration : 1160 bytesConfigure flow aggregationS (tm) C

!0

version 12.32600-IK9O3S3

service timestamps debug datetime msec Configure netflow cache parameters

service timestamps log datetime msec pa

c3)cef

Technic

flow-expor

no service password-encryption to send flow statisticsatic m

!t

hostname Topclass

Copyri

!t

boot-start-markercisco System

fo

boot-end-marker Controls

!r

enable secret xxx

dns-server 208.67.222.222ARPs for PPP/SLIP peer addre

domain-name acs.com.ph Delivery of Cisco crypto

!a

ip audit po max-events 100y

host

ip dhcp-server 172.31.3.91stname tablerd-party autho

!t

!t

!i

!o

!,

!x

!r

!

!s

!i

!t

!o

!u

!

!c

!p

!

!o

interface FastEthernet0/0le host-based routing (pr

ip address 192.168.0.254 255.255.255.0 distributors and users are responsible

ip broadcast-address 192.168.0.0 Enable the HP proxy pr

duplex autowith U.S. an

speed autotry laws. B

!u

interface Serial0/0 http

no ip addressver configurat

ip broadcast-address 0.0.0.0to comply with applicabl

ic

shutdown

!

interface FastEthernet0/1

!l

interface Serial0/1cryptographic produ

no ip addressd at:lationix-

ip broadcast-address 0.0.0.0cify local optionson configur

shutdown

http://w

!.

interface Serial0/2ile

no ip address IP services

!

no ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

line con 0

password xxx

login

speed 115200

line aux 0

line vty 0 4

login

!

!

end

Top#

Jefferson Co
Hall of Fame Super Silver

Re: DHCP

What you have posted is still unreadable due to the intermixture of various text outputs. I suggest that you go back to the router and do a fresh capture of the running config text and post an easier to read and understand version.

HTH

Rick

New Member

Re: DHCP

Though the pasted message is not clear, Iam just thinking there should be ip dhcp on the interface where the address needs to be assaigned by dhcp.

124
Views
0
Helpful
8
Replies
CreatePlease to create content