Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Dial-Out over AUX-Port

Hi Community,

i have the follow problem:

Cisco-2800 (AUX) ---> analog-modem A <----> analog-modem B ---> serial-port (VT100)

As shown above, the Cisco connect to the modem A and be elected to the modem B.

Once there is a dial-up connection should to connect to a serial console.

So far, already works as follow:

An IP from the LAN section of the router connect to the Dial Interface

constructed and selected the appropriate telephone number for the

modem B. Unfortunately it didn't comes a prompt for the serial device.

To cut a long story short: Here's the config:

Router#show run
Building configuration...

Current configuration : 2041 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$u3xd$iwBXXQtuw4FHAYvdEhmk21
enable password XXXXXX
!
no aaa new-model
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
chat-script DD ABORT ERROR ABORT BUSY "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT \c
chat-script Sound "" ATM1
modemcap entry MyTest:MSC=&F&C1&D2S0=1H0
!
!!
username xxxxx password xxxxxxx
username xxxxx password xxxxxxx
archive
log config
  hidekeys
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 172.16.0.1 255.255.0.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
no ip address
!
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode interactive
!
interface Dialer1
ip address 172.19.1.1 255.255.255.252
encapsulation ppp
dialer pool 1
dialer idle-timeout 100
dialer string 52
dialer-group 1
!
interface Dialer2
ip address 172.20.1.1 255.255.255.252
encapsulation ppp
dialer pool 1
dialer idle-timeout 100
dialer string 43
dialer-group 1
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
!
control-plane
!
!
!
line con 0
modem autoconfigure discovery
line aux 0
script connection DD
login local
modem InOut
modem autoconfigure type MyTest
no exec
transport input all
transport output pad telnet rlogin udptn v120
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
password t
logging synchronous
login local
!
scheduler allocate 20000 1000
!
end

4 REPLIES
Community Member

Re: Dial-Out over AUX-Port

please provide more

information of VT100,also a router?

And what is the application of the a IP.

Thanks

Keisikka

Community Member

Re: Dial-Out over AUX-Port

Hi keisikka@163.com,

The serial-device is a normal serial-device without ip-address. I can connect to it with Putty over Serial.

But now we want make a connection over the AUX-Port with modem connection.

When someone (in the LAN) make a telnet session to a IP-address, the router will link it to a telephonenumber

and open a serial-session. That's the theory.

THX Daniel

Community Member

Re: Dial-Out over AUX-Port

In my understanding.

Telnet is a application depends on tcp/ip, so there shold has a connection betweem hosts.

However, serial shold has a connection over RS232.

If I mistake,please inform me.

THX

Keisikka

Hall of Fame Super Silver

Re: Dial-Out over AUX-Port

Hello Daniel,

in configuring an IOS router to act as a terminal server we can associate the usage of an async line to a specific host

you need to get the AUX line number from the output of sh line, it is typically 1.

int loop1

ip address 10.10.10.1 255.255.255.255

the TCP port to be used for reverse telnet is 2000+ line#

example:

ip host vt100 10.10.10.1 2001

Your case is different.

You need a L3 device on the other end to be able to use DDR dial out as explained here:

https://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094579.shtml

if you haven't a L3 IP device on the other end, you should look at terminal server and your trigger is the telnet to the host as defined above

Hope to help

Giuseppe

1064
Views
0
Helpful
4
Replies
CreatePlease to create content