Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dmvpn help

Hi, sorry for my little eng 

 

You help me?

 

where is my error 

 

my conf for hub is :

 

Current configuration : 1703 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Gropello
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$hNMo$gMcGQbB1WFoD4AF9F3bH61
enable password MIm80799
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key mim80799 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
 mode transport
!
crypto ipsec profile SDM_Profile1
 set transform-set ESP-3DES-SHA
!
!
!
!
!
!
interface Tunnel0
 bandwidth 1000
 ip address 192.168.100.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 90
 ip nhrp authentication DMVPN_NW
 ip nhrp map multicast dynamic
 ip nhrp network-id 100000
 ip nhrp holdtime 360
 ip tcp adjust-mss 1360
 no ip split-horizon eigrp 90
 delay 1000
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address 37.159.205.66 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.17.2 255.255.255.0
 speed auto
 half-duplex
 no mop enabled
!
router eigrp 90
 network 192.168.17.0
 network 192.168.20.0
 network 192.168.100.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 37.159.205.65
!
!
ip http server
no ip http secure-server
!
snmp-server community public RO
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
 password mim80799
 login
!
scheduler allocate 20000 1000
end

 

 

 

 

 

 

and for spoke is :

 

Current configuration : 1676 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Echo
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$VCZv$/lKOKw/.gFIYVMOxu31Mc/
enable password MIm80799
!
no aaa new-model
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key mim80799 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
 mode transport
!
crypto ipsec profile SDM_Profile1
 set transform-set ESP-3DES-SHA
!
!
!
!
!
interface Tunnel0
 bandwidth 1000
 ip address 192.168.100.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication DMVPN_NW
 ip nhrp map multicast 37.159.205.66
 ip nhrp map 192.168.100.1 37.159.205.66
 ip nhrp network-id 100000
 ip nhrp holdtime 360
 ip nhrp nhs 192.168.100.1
 ip nhrp cache non-authoritative
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source FastEthernet0/1
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address 91.81.10.74 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.20.2 255.255.255.0
 speed auto
 half-duplex
 no mop enabled
!
router eigrp 90
 network 192.168.17.0
 network 192.168.20.0
 network 192.168.100.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 37.159.205.66
!
!
ip http server
no ip http secure-server
!
snmp-server community public RO
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 password mim80799
 login
!
scheduler allocate 20000 1000
end

 

 

Best regard

 

Roberto

  • LAN Switching and Routing
5 REPLIES

On the spoke router, The

On the spoke router, The tunnel source interface should be F0/0 rather than F0/1 that you have there, also not sure why you have default route pointing to the Hub router interface IP on the spoke.

Manish

New Member

fantastic but now I have this

fantastic but now I have this problem: 

IP-EIGRP(Default-IP-Routing-Table:90): Neighbor 192.168.20.2 not on common subnet for FastEthernet0/1

 

 

how to properly configure the routing-table bearing in mind that the IP addresses of the internal network can not edit it? 

Thanks you're a big

 

 

Remove the "network 192.168

Remove the "network 192.168.20.0" from Hub router EIGRP config and "network 192.168.17.0" from the Spoke router EIGRP config. These subnets will be advertised by EIGRP automatically.

Manish

New Member

Errata corrige sorry but not

Errata corrige sorry but not work.

 

please help me 

 

New Member

hi, Are you still having

hi,

 

Are you still having problem with 192.168.20.0 not on common subnet?

 

Please check on any neighbor that directly connected to this device to see if they're on same subnet. I had this issue before when one of the interfaces on my layer-3 switch connected to a router that was on a different subnet.

 

Wish you luck,

 

John

http://www.peakipsolutions.com/easyblog/categories/listings/it-blog

81
Views
4
Helpful
5
Replies