Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DNS server

Dear All,

I have a router of 2800 series whose one interface is connected to leased line through MODEM and other interface is connected to our LAN.

Now, I have configured NAT and DHCP into this.

I am trying to give 192.168.10.1 as DNS in DHCP pool fter defining ip name servers in router as 4.2.2.2

the end devices connected to switch are getting IP addresses with the dns server as 192.168.10.1, but not able to browse internet

When I give 4.2.2.2 as dns server inside dhcp pool setting, I am able to browse.

Why is it happening even after I am defining global dns 4.2.2.2 in ip name server and assigning local dns to end device???

Pls help, Below config for your reference

sh run
Building configuration...


Current configuration : 1534 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname yyyyy
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxx!
no aaa new-model
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool hyatt
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 192.168.10.1    (when I put 4.2.2.2, it is working)
!
ip name-server 4.2.2.2
multilink bundle-name authenticated

!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address xx.xx.xx.xx 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
interface BRI0/3/0
no ip address
encapsulation hdlc
!
ip default-gateway xx.xx.xx.xx

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
!
ip http server
no ip http secure-server
ip nat pool hyatt xx.xx.xx.xx xx.xx.xx.xx netmask 255.255.255.252
ip nat inside source list 10 pool hyatt overload
!
access-list 10 permit 192.168.10.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 5
password 7 1100171112001F03112923757B32
login
!
scheduler allocate 20000 1000
!
end

AirtelRouter#sh ip inte brie
AirtelRouter#sh ip inte brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.10.1    YES NVRAM  up                    up     
FastEthernet0/1            xx.xx.xx.xx   YES NVRAM  up                    up     
Serial0/0/0                unassigned      YES NVRAM  administratively down down   
Serial0/2/0                unassigned      YES NVRAM  administratively down down   
BRI0/3/0                   unassigned      YES NVRAM  up                    up     
BRI0/3/0:1                 unassigned      YES unset  down                  down   
BRI0/3/0:2                 unassigned      YES unset  down                  down   
NVI0                       192.168.10.1    YES unset  up                    up     
AirtelRouter#

Regards,

Vishal

2 ACCEPTED SOLUTIONS

Accepted Solutions

DNS server

hi vishal,

the ip name-server is locally used by the device for its DNS translation.

you should put a separate dns-sever command under the DHCP pool for your LAN clients.

DNS server

Hi Vishal,

Looks like you may be missing the command:

ip dns server

http://www.cisco.com/en/US/docs/ios/netmgmt/command/reference/nm_08.html#wp1011412

cheers,

Seb.

3 REPLIES

DNS server

hi vishal,

the ip name-server is locally used by the device for its DNS translation.

you should put a separate dns-sever command under the DHCP pool for your LAN clients.

DNS server

Hi Vishal,

Looks like you may be missing the command:

ip dns server

http://www.cisco.com/en/US/docs/ios/netmgmt/command/reference/nm_08.html#wp1011412

cheers,

Seb.

New Member

DNS server

thanks seb and john..

it worked!!!!

167
Views
0
Helpful
3
Replies
CreatePlease login to create content