Cisco Support Community
Community Member

Do I have a memory problem?

Hey, hope that some of you have more guys have more experience than I do with this. I was checking the memory status and I got the following output from my 6500

WAN-EDGE-1#sh memory
                Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
Processor   46D48630   892008912   839803428    52205484    50735160    51748556
      I/O    8000000    67108864    21605604    45503260    45357096    45501532

As far as I can see I only have around 50Mb left of memory before it is used up.... Is this a problem or is it normal behaviour by IOS to allocate almost all the availible memory?



Do I have a memory problem?

Hi Mads,

I wouldn't concern much for the memory unless the switch starts to give mem-alloc error. If you're unable to do commands like "show run" or "show int desc" or unable to make new configuration, this is indicative of a memory leak. Cisco IOS switch does not have memory leak, it is considered a bug. So if you do run in to such symptom, a reload of the switch will resolve the problem for quite a while. Otherwise, if it is concern, upgrading the IOS will address this.

If you check your memory "show memory | inc fragment" , if you have an excessive amount of fragment, this can also cause error and will be resolved by a reboot. I have seen some IOS products with even over 15,000 fragment in memory and still work in reasonable capacity.

Now keep in mind, if you try to upgrade IOS, you may not have sufficient space for this. If you'd like to free up space you can check your flash for useless/unwanted files.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts
Hall of Fame Super Gold

Do I have a memory problem?

What IOS are you using?

Community Member

Do I have a memory problem?

@ Tom, well I have tried different commands and they all work fine until I tried this:


Not enough free memory to launch Tcl shell

So yes there seems to be some error and a restart might be required.

@Leo Laohoo

WAN-EDGE-1#sh ver
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9-M), Version 12.2(33)SXI4a, RELEASE SOFTWARE (fc2)
Technical Support:
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Fri 16-Jul-10 19:51 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)

WAN-EDGE-1 uptime is 2 years, 19 weeks, 3 days, 20 hours, 12 minutes
Uptime for this control processor is 2 years, 19 weeks, 3 days, 19 hours, 46 minutes
Time since WAN-EDGE-1 switched to active is 2 years, 19 weeks, 3 days, 19 hours, 53 minutes
System returned to ROM by  power cycle at 09:48:46 UTC Wed Aug 11 2010 (SP by power on)
System restarted at 13:32:17 CEST Sat Oct 1 2011
System image file is "sup-bootflash:s72033-adventerprisek9-mz.122-33.SXI4a.bin"
Last reload reason: Reload Command

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

cisco WS-C6506-E (R7000) processor (revision 1.2) with 983008K/65536K bytes of memory.
Processor board ID SAL1426LGDT
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from s/w reset
29 Virtual Ethernet interfaces
51 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

From this it is also obivious that it has been running for a few years now without a reboot, it might be time to schedule a restart.

CreatePlease to create content