Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Do Neighbour command work with point to multipoint ospf?

Hi all,

I was working on my LAB.

Router A  and B are configured with Frame relay - OSPF point to multipoint.

Both have direct connection back to back.

A

Router#sh run int se1/1
Building configuration...

Current configuration : 181 bytes
!
interface Serial1/1
ip address 192.168.9.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
no keepalive

Router ospf 1

neighbour 192.168.9.2

B

Router#sh run in se0/1
Building configuration...

Current configuration : 157 bytes
!
interface Serial0/1
ip address 192.168.9.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
no keepalive
end

Router ospf 1

neighbor 192.168.9.3

Both routers have nei command configured.

B  Router

Router#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
N/A               0   DOWN/  -           -        192.168.9.3     Serial0/1

OSPF nei is down at both ends.

Serial link is up up at both ends.

I know if i config frame relay map ip command on both ends then

OSPF nei relationship develops.

My question is point to multipoint network back to back serial interface does it work without frame relay map command or not?

Does the neighbour command with with point to multipont?

Thanks

mahesh

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

Do Neighbour command work with point to multipoint ospf?

Hi Mahesh,

Question: what is router model you are using?

According to this link the neighbor command is only supported on the following platforms:

Platforms

This feature is supported on these platforms:

Cisco 1003, Cisco 1004, Cisco 1005

Cisco 1600 series

Cisco 2500 series

Cisco 3600 series

Cisco 3800 series

Cisco 4000 series (Cisco 4000, 4000-M, 4500, 4500-M, 4700, 4700-M)

Cisco 5200 series

Cisco 7200 series

Cisco 7500 series

Cisco AS5300

If this feature is working on your router, can you apply the same neighbor command with priority and test again?

have a look at this link:

http://www.cisco.com/en/US/docs/ios/11_3/feature/guide/ospfpmp.html

HTH

Do Neighbour command work with point to multipoint ospf?

Hi Mahesh,

The problem you describe is actually not related to the OSPF configuration.

Essentially, what you configured for OSPF is correct on this type of environment.

The problem is with the subnet you chose for the serial link. Because this is a /24, the router cannot determine over which PVC trafic must be sent. (Typical for point-multipoint) So actually your link is not treated as point-point, even though it is connected that way.

When you change the mask on the serial link and configure the routers to be in the same /30, the link will be truly point-point and then it will work without the frame-relay map command.

The point-multipoint scenario you considered will always require a frame-relay map entry.

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a0080094051.shtml

regards,

Leo

6 REPLIES
VIP Super Bronze

Do Neighbour command work with point to multipoint ospf?

Hi Mahesh,

Question: what is router model you are using?

According to this link the neighbor command is only supported on the following platforms:

Platforms

This feature is supported on these platforms:

Cisco 1003, Cisco 1004, Cisco 1005

Cisco 1600 series

Cisco 2500 series

Cisco 3600 series

Cisco 3800 series

Cisco 4000 series (Cisco 4000, 4000-M, 4500, 4500-M, 4700, 4700-M)

Cisco 5200 series

Cisco 7200 series

Cisco 7500 series

Cisco AS5300

If this feature is working on your router, can you apply the same neighbor command with priority and test again?

have a look at this link:

http://www.cisco.com/en/US/docs/ios/11_3/feature/guide/ospfpmp.html

HTH

Do Neighbour command work with point to multipoint ospf?

Hi Mahesh,

The problem you describe is actually not related to the OSPF configuration.

Essentially, what you configured for OSPF is correct on this type of environment.

The problem is with the subnet you chose for the serial link. Because this is a /24, the router cannot determine over which PVC trafic must be sent. (Typical for point-multipoint) So actually your link is not treated as point-point, even though it is connected that way.

When you change the mask on the serial link and configure the routers to be in the same /30, the link will be truly point-point and then it will work without the frame-relay map command.

The point-multipoint scenario you considered will always require a frame-relay map entry.

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a0080094051.shtml

regards,

Leo

Cisco Employee

Do Neighbour command work with point to multipoint ospf?

Hi Mahesh,

can you pls check if you are able to ping each other. I have a doubt if the ping would work.,

-Vijay

New Member

Do Neighbour command work with point to multipoint ospf?

Hi Vijay,

i Can not ping router B  from A

Router#ping 192.168.9.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.9.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Thanks

Mahesh

Do Neighbour command work with point to multipoint ospf?

mahesh18 wrote:


i Can not ping router B  from A

Router#ping 192.168.9.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.9.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)


Which is additional proof to the explanation provided.

New Member

Do Neighbour command work with point to multipoint ospf?

Hi,

Thanks for reply.

I fig this out if we use

Point to multipoint with non broadcast  we will need frame relay MAP command and also we need atleast 1 nei command

on router.

Also it worked with nei command on each router.

I tested this with 255.255.255 subnet and it worked fine.

Thanks everyone

Mahesh

581
Views
0
Helpful
6
Replies