cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1556
Views
0
Helpful
3
Replies

Does 6509 support shaping or Hierarchical policymap anyhow?

ctaymez
Level 1
Level 1

Hello All,

I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:

1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps

But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?

access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any

class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183


policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000


policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING


65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!


65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!

65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end

1 Accepted Solution

Accepted Solutions

Jon Marshall
Hall of Fame
Hall of Fame

ctaymez wrote:

Hello All,

I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:

1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps

But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?

access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any

class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183


policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000


policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING


65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!


65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!

65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end

It depends on the module/interface you are using. It is only supported on some WAN interfaces as shaping is not generally available on Catalyst switches -

6500 Q&A

Catalyst switches have a completely different queueing system than routers so most of the MQC type configuration for queueing is not available -

6500 PFC QOS

Jon

View solution in original post

3 Replies 3

Jon Marshall
Hall of Fame
Hall of Fame

ctaymez wrote:

Hello All,

I have a ME customer that is directly connected to a 6509 w/ Version 12.2(33)SXH4. By using the following config, I am trying to:

1- Limit overall traffic at 10 mbps

2- Prioritize voip traffic w/ 2 mbps

3- Limit Netapp traffic at 3 mbps

4- Remaining traffic gets 5 mbps

But I get errors when I apply service-policy under a Gi interface. Does 6509 support shaping or Hierarchical policymap anyhow?

access-list 181 remark Define & permit customer traffic to VoIP
access-list 181 permit ip any 192.168.66.0 0.0.0.255

access-list 182 remark Define & permit customer traffic to Netapp
access-list 182 permit ip any 192.168.62.5 0.0.0.0

access-list 183 remark Define & permit customer traffic to Remaining
access-list 183 permit ip any any

class-map match-all VoIP_TRAFFIC
match access-group 181

class-map match-all Netapp_TRAFFIC
match access-group 182

class-map match-all Remaining_TRAFFIC
match access-group 183


policy-map VoIP_CLASSIFICATION
class VoIP_TRAFFIC
  priority 2000
class Netapp_TRAFFIC
  police cir 3000000 bc 375000 be 375000 conform-action transmit exceed-action drop

class Remaining_TRAFFIC
  bandwidth 5000


policy-map EGRESS_QUEUING
class class-default
  shape aver 10000
  service-policy VoIP_CLASSIFICATION

int Gi3/15
service-policy output EGRESS_QUEUING


65_01(config-if)#service-policy output EGRESS_QUEUING                                      
Hierarchical policymap is not supported for this interface. Configuration failed!


65_01(config-if)#service-policy output EGRESS_QUEUING

shape average command is not supported for this interface. Configuration failed!

65_01#sh run interface g3/15
Building configuration...

Current configuration : 250 bytes
!
interface GigabitEthernet3/15
bandwidth 10000
ip vrf forwarding XXX

ip address 10.2.127.209 255.255.255.252
load-interval 30
speed 100
duplex full
end

It depends on the module/interface you are using. It is only supported on some WAN interfaces as shaping is not generally available on Catalyst switches -

6500 Q&A

Catalyst switches have a completely different queueing system than routers so most of the MQC type configuration for queueing is not available -

6500 PFC QOS

Jon

ctaymez
Level 1
Level 1

Any suggestion how this can be done?

Like Jon said, this type of configuration can only be done on the WAN line cards, like the FlexWAN and the SIP/SPA. None of the LAN line cards (WS-X6xxx) will support HQoS.

HTH,

jerry

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: