Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Does GVRP really work on SPS-serie switches?

Hello!

I'm trying to configure GVRP between two SPS224G4 switches, but without success.

Switch A, port e24 is connected to Switch B, port e1

sw3# show run

interface ethernet e24

description sw4:e1

exit

interface range ethernet e(1,24)

switchport mode trunk

exit

vlan database

vlan 300,303

exit

interface range ethernet e(1,24)

switchport trunk allowed vlan add 300

exit

interface ethernet e2

switchport access vlan 303

exit

interface range ethernet e(1,24)

switchport trunk allowed vlan add 303

exit

interface vlan 300

name Management

exit

interface ethernet e24

gvrp enable

exit

gvrp enable

interface vlan 300

ip address 10.10.255.4 255.255.255.0

exit

ip default-gateway 10.10.255.1

hostname sw3

Switch B:

sw4# show run

interface range ethernet e(1,24)

switchport mode trunk

exit

interface ethernet e1

gvrp enable

exit

gvrp enable

hostname sw4

But vlans 300,303 configured on Switch A do not appear in VLAN table on switch B:

sw4# show vlan

Vlan Name Ports Type Authorization

---- ----------------- --------------------------- ------------ -------------

1 1 e(1-24),g(1-4),ch(1-8) other Required

Any suggestions? Thanks!

5 REPLIES

Re: Does GVRP really work on SPS-serie switches?

Hello,

In my opinion on SPS224G4 switches you need to configure following things for GVRP to work.

GVRP Enable on device

GVRP state on device (enabled/disabled)

Dynamic VLan creating enabled on interface

GVRP registration enabled on device.

See this doc, should help..

http://www.cisco.com/en/US/docs/switches/metro/csbpgss/sps/administration/guide/Cisco_SPS208G224G4_UG_OL-18486-01.pdf

Regards

Hitesh Vinzoda

New Member

Re: Does GVRP really work on SPS-serie switches?

Dear Hitesh,

Thank you for the info... Do you have LinkSys switches with enabled GVRP in your network? :)

Before writing here I read a lot of docs regarding GVRP on LinkSys switches. After 8 hours of dancing around them I succeeded in getting them to work.

Now I see dybamic VLANs on switch B:

Vlan Name Ports Type Authorization

---- ----------------- --------------------------- ------------ -------------

1 1 e(1-24),g(1-4),ch(1-8) other Required

300 300 e1 dynamicGvrp Required

303 303 e1 dynamicGvrp Required

But I cannot add any port neither to vlan 300 nor to vlan 303!

sw4# conf t

sw4(config)# int eth e2

sw4(config-if)# switchport mode access

sw4(config-if)# switchport access vlan 300

VLAN 300: VLAN was not created by user.

My conclusion: the realization of GVRP in LinkSys switches is completely weird and broken. And now I really don't know what to do with ~45 LinkSys SPS224G4 switches in my network. You know, creating one VLAN on them by hands is somewhat difficult, isn't it?

Is there anything able to change my mind? Thanks in advance!

-- Alexander

Re: Does GVRP really work on SPS-serie switches?

Hi,

I dont have any linksys switches in my network as of now but once upon a time i had Cabletron with GVRP which messed up my network when connected with Cisco switches with redundant links.

Can you please post the config of switches on which you are trying your hand, coz i can see that you have configured all ports on SW4 as trunk in first post and than you are trying to configure it as access.

Also confirm the mode you are running for GVRP ? make sure links between switches are 802.1q trunk.

Regards

Hitesh Vinzoda

New Member

Re: Does GVRP really work on SPS-serie switches?

Hello Hitesh,

I wish to describe the situation more clearly.

Scheme:

switch A:e24 ----- e1:Switch B

Trunk e24-e1 is 802.1Q. Linksys does not support another types.

Current configuration of switches:

Switch A:

-----------------------------------------------

sw_A# show run

interface range ethernet e(2-23)

shutdown

exit

interface ethernet e24

description sw4:e1

exit

interface range ethernet e(1,24)

switchport mode trunk

exit

vlan database

vlan 300,303

exit

interface range ethernet e(1,24)

switchport trunk allowed vlan add 300

exit

interface ethernet e2

switchport access vlan 303

exit

interface range ethernet e(1,24)

switchport trunk allowed vlan add 303

exit

interface vlan 300

name Management

exit

interface range ethernet e(1,24)

gvrp enable

exit

interface ethernet e1

gvrp vlan-creation-forbid

exit

gvrp enable

interface ethernet e1

gvrp registration-forbid

exit

interface vlan 300

ip address 10.10.255.4 255.255.255.0

exit

ip default-gateway 10.10.255.1

hostname sw_A

----------------------------------------------

Switch B:

----------------------------------------------

sw_B# show run

interface range ethernet e(3-24)

shutdown

exit

interface ethernet e1

switchport mode trunk

exit

interface ethernet e1

gvrp enable

exit

gvrp enable

hostname sw_B

-----------------------------------------------

On the switch B I see dynamic VLANs that it learned from switch A:

sw_B# show vlan

Vlan Name Ports Type Authorization

---- ----------------- --------------------------- ------------ -------------

1 1 e(1-24),g(1-4),ch(1-8) other Required

300 300 e1 dynamicGvrp Required

303 303 e1 dynamicGvrp Required

But when I'm trying to add a port on switch B to any of VLANs I get an error:

sw_B(config)# int eth e2

sw_B(config-if)# switchport mode access

sw_B(config-if)# switchport access vlan 300

VLAN 300: VLAN was not created by user.

Regarding the mode that I run for GVRP: I don't undestand what did yoy mean... :(

I haven't seen any modes for GVRP on linksys.

It is just enabled globally and enabled on trunk port:

sw_B# show gvrp configuration

GVRP Feature is currently Enabled on the device.

Maximum VLANs: 255

Port(s) GVRP-Status Registration Dynamic VLAN Timers(milliseconds)

Creation Join Leave Leave All

-------- ----------- ------------ ------------ ---- ----- ---------

e1 Enabled Normal Enabled 200 600 10000

e2 Disabled Normal Enabled 200 600 10000

e3 Disabled Normal Enabled 200 600 10000

e4 Disabled Normal Enabled 200 600 10000

e5 Disabled Normal Enabled 200 600 10000

...

Re: Does GVRP really work on SPS-serie switches?

Hi,

The config looks good to me. It seems that it is not allowing to manage the dynamically learned Vlan. I think there may be bug in the firmware that you are using.

See this topic, It could be helpful

http://forums.linksysbycisco.com/linksys/board/message?board.id=Switches&thread.id=3228

I ll Suggest you to confirm it from Linksys Support team.

Regards

Hitesh Vinzoda

531
Views
0
Helpful
5
Replies
CreatePlease to create content