Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Does this configuration make sense?

!

interface GigabitEthernet0/1

description Connection to UHMC Router

no switchport

ip address 1xx.4x.170.2 255.255.255.0

!

interface GigabitEthernet0/2

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 3

switchport mode access

spanning-tree portfast

interface GigabitEthernet0/14

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/17

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/20

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/21

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/22

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/23

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/24

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/25

description Access_Port_From_8R_Way

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

no ip address dhcp

interface Vlan2

description 8RW/14TP_1xx.4x.1x0.0_VLAN

ip address 1xx.4x.1y0.1 255.255.255.0

!

interface Vlan3

description HSC_1xx.4x.1y0.0_VLAN

ip address 1xx.4x.1x0.1 255.255.255.0

!

ip default-gateway 1xx.4x.170.2 (not so sure if this is right GW)

ip classless

ip route 0.0.0.0 0.0.0.0 1xx.4x.1y0.1

ip route 0.0.0.0 0.0.0.0 1xx.4x.170.2

ip route 1xx.4x.0.0 255.255.0.0 1xx.4x.170.2

ip route 1xx.4x.1y0.0 255.255.255.0 1xx.4x.170.2

ip route 1xx.4x.1x0.0 255.255.255.0 1xx.4x.170.2

ip route 172.28.118.171 255.255.255.255 2xx.1xx.2xx.53

ip route 172.28.118.172 255.255.255.255 2xx.1xx.2xx.53

ip route 1xx.1xx.2xx.46 255.255.255.0 1xx.xx.xxx.2

ip route 1xx.1xx.2xx.46 255.255.255.0 2xx.1xx.2xx.53 250

ip route 1xx.1xx.2xx.46 255.255.255.255 2xx.1xx.2xx.53

What I am trying to do here is:

- route VLAN traffic for two vlans to the router

- i assume there is no need to trunk ports to router

- right now client on VLAN 1 can not ping client on VLAN 2

- client on VLAN 2 can not ping the router IP

Any suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Does this configuration make sense?

Trunk the ports to the router.

3 REPLIES
New Member

Re: Does this configuration make sense?

Trunk the ports to the router.

Re: Does this configuration make sense?

Hi ,

You have confused the configuration , pls make it simple .

1.Enable ip routing on the switch

2.Have a default route in the switch with the next hop as the router ip ( The ip of the router that connects in g0/1)

3.Add reverse routes for the Vlan networks in the router pointing to the Switch ip ( ip configured in G0/1)

Pls let me know if your requirement is diff

regards

vanesh k

Re: Does this configuration make sense?

Hi,

You have done few things wrong. Your static routes are wrong.They are pointing as the next-hop to the switches ip address instead of the router's IP.

The simple would be.

A. Change the routes to point to next hop router.

B. Enable ip routing on the switch :

conf t

ip routing

C. Point the Routes for VlanX and Vlan to the switchport ip 1xx.4x.170.2 on the router.

it all will work fine.

HTH, Please rate if it does.

-amit singh

135
Views
0
Helpful
3
Replies
CreatePlease to create content