Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

dot1q encapsulation option not showing up under the Interface 4507R chassi Sup 7!?

                   Hi,

I am trying to configure a 4507 R chassis with Dual SUP but i cannot see teh switchpot mode trunk encapsulation dot1q?

I have typed:

interface GigabitEthernet5/1

description DOWNLINK toxxxxxx

switchport mode trunk

channel-group 11 mode on

!

I have have searched all other commands and sub-commands but could only find dot1q-tunnel which I beleive is for QINQ or some QoS featues and lot for L2 encapsulations?

the puzzling is:

XXX-Core4507#sh int gi5/1 trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi5/1       off              802.1q         notrnk-bndl   1

                                      (Po11)

Port        Vlans allowed on trunk

Gi5/1       1

Port        Vlans allowed and active in management domain

Gi5/1       1

Port        Vlans in spanning tree forwarding state and not pruned

Gi5/1       1

but:

sh int gi5/1

shows encapsulation ARPA.

when I connect the dostribution switch a 3507 to this int gi 5/1, both interfaces do come up?

and assitance would be greatly appreciated.

the IOS is the universal package.

Please advise,

Masood

9 REPLIES
Hall of Fame Super Gold

dot1q encapsulation option not showing up under the Interface 45

I am trying to configure a 4507 R chassis with Dual SUP but i cannot see teh switchpot mode trunk encapsulation dot1q?

The supervisor card isn't the only factor if the commend "switchport encap dot1q" is supported or not.  The ethernet line card is another factor.  Issue the command "sh interface 5/1 switchport" or "sh interface 5/12 capa" to see.

Can you post the config of your etherchannel interface?

New Member

Re: dot1q encapsulation option not showing up under the Interfac

Hi,

config is attached. please note that I have just started configuring this switch and all I havedone is the L2 information like vlans, Port-channel. etc.

I am not on teh device now nor I have access to it until tomorrow but you may be able to tell based on the config attached. I have no time befor ethe installation time and I HAVE NOT ORDERED TEH LINE CARDS, ETHERNET CARDS, ETC. I don;t know who has placed the order but i can findout. I ony need to know if any of the cards don;t support the dot1q encap so we can have it replaced within 24 ours but we must be certain.

I thank you in advance.

hoe can i attach a file here?

Regards,

Masood

      

Current configuration : 6655 bytes
!
! Last configuration change at 12:58:24 UTC Fri Jun 8 2012
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname xxxx-Core4507
!
boot-start-marker
boot system flash:cat4500e-universalk9.SPA.03.03.00.SG.151-1.SG.bin
boot-end-marker
!
!
!
no aaa new-model
!
ip vrf mgmtVrf
!
no ip domain-lookup
!
!
vtp mode transparent
!
!
crypto pki trustpoint CISCO_IDEVID_SUDI
revocation-check none
rsakeypair CISCO_IDEVID_SUDI
!
crypto pki trustpoint CISCO_IDEVID_SUDI0
revocation-check none
!
!
power redundancy-mode redundant
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
redundancy
mode sso
!
vlan internal allocation policy ascending
!
vlan 20,34,168,320,334
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel11
description DOWNLINK to xxx1217B
switchport
switchport mode trunk
flowcontrol receive on
!
interface Port-channel41
description DOWNLINK to xxxx4811-DIST
switchport
!
interface Port-channel51
description DOWNLINK to xxx5507-DIST
switchport
!
interface FastEthernet1
ip vrf forwarding mgmtVrf
no ip address
shutdown
speed auto
duplex auto
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3
!
interface GigabitEthernet1/4
!
interface GigabitEthernet1/5
!
interface GigabitEthernet1/6
!
interface GigabitEthernet1/7
!
interface GigabitEthernet1/8
!
interface GigabitEthernet1/9
!
interface GigabitEthernet1/10
!
interface GigabitEthernet1/11
!
interface GigabitEthernet1/12
!
interface GigabitEthernet1/13
!
interface GigabitEthernet1/14
!
interface GigabitEthernet1/15
!
interface GigabitEthernet1/16
!
interface GigabitEthernet1/17
!
interface GigabitEthernet1/18
!
interface GigabitEthernet1/19
!
interface GigabitEthernet1/20
!
interface GigabitEthernet1/21
!
interface GigabitEthernet1/22
!
interface GigabitEthernet1/23
!
interface GigabitEthernet1/24
!
interface GigabitEthernet1/25
!
interface GigabitEthernet1/26
!
interface GigabitEthernet1/27
!
interface GigabitEthernet1/28
!
interface GigabitEthernet1/29
!
interface GigabitEthernet1/30
!
interface GigabitEthernet1/31
!
interface GigabitEthernet1/32
!
interface GigabitEthernet1/33
!
interface GigabitEthernet1/34
!
interface GigabitEthernet1/35
!
interface GigabitEthernet1/36
!
interface GigabitEthernet1/37
!
interface GigabitEthernet1/38
!
interface GigabitEthernet1/39
!
interface GigabitEthernet1/40
!
interface GigabitEthernet1/41
!
interface GigabitEthernet1/42
!
interface GigabitEthernet1/43
!
interface GigabitEthernet1/44
!
interface GigabitEthernet1/45
!
interface GigabitEthernet1/46
!
interface GigabitEthernet1/47
!
interface GigabitEthernet1/48
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet2/3
!
interface GigabitEthernet2/4
!
interface GigabitEthernet2/5
!
interface GigabitEthernet2/6
!
interface GigabitEthernet2/7
!
interface GigabitEthernet2/8
!
interface GigabitEthernet2/9
!
interface GigabitEthernet2/10
!
interface GigabitEthernet2/11
!
interface GigabitEthernet2/12
!
interface GigabitEthernet2/13
!
interface GigabitEthernet2/14
!
interface GigabitEthernet2/15
!
interface GigabitEthernet2/16
!
interface GigabitEthernet2/17
!
interface GigabitEthernet2/18
!
interface GigabitEthernet2/19
!
interface GigabitEthernet2/20
!
interface GigabitEthernet2/21
!
interface GigabitEthernet2/22
!
interface GigabitEthernet2/23
!
interface GigabitEthernet2/24
!
interface GigabitEthernet2/25
!
interface GigabitEthernet2/26
!
interface GigabitEthernet2/27
!
interface GigabitEthernet2/28
!
interface GigabitEthernet2/29
!
interface GigabitEthernet2/30
!
interface GigabitEthernet2/31
!
interface GigabitEthernet2/32
!
interface GigabitEthernet2/33
!
interface GigabitEthernet2/34
!
interface GigabitEthernet2/35
!
interface GigabitEthernet2/36
!
interface GigabitEthernet2/37
!
interface GigabitEthernet2/38
!
interface GigabitEthernet2/39
!
interface GigabitEthernet2/40
!
interface GigabitEthernet2/41
!
interface GigabitEthernet2/42
!
interface GigabitEthernet2/43
!
interface GigabitEthernet2/44
!
interface GigabitEthernet2/45
!
interface GigabitEthernet2/46
!
interface GigabitEthernet2/47
!
interface GigabitEthernet2/48
!
interface TenGigabitEthernet3/1
!
interface TenGigabitEthernet3/2
!
interface TenGigabitEthernet3/3
!
interface TenGigabitEthernet3/4
!
interface TenGigabitEthernet4/1
!
interface TenGigabitEthernet4/2
!
interface TenGigabitEthernet4/3
!
interface TenGigabitEthernet4/4
!
interface GigabitEthernet5/1
description DOWNLINK to xxx1217B (DIST-PROB-Data)
switchport mode trunk
channel-group 11 mode on
!
interface GigabitEthernet5/2
description DOWNLINK to xxx4811
switchport mode trunk
channel-group 41 mode on
!
interface GigabitEthernet5/3
description DOWNLINK to xxx5507
switchport mode trunk
channel-group 51 mode on
!
interface GigabitEthernet5/4
!
interface GigabitEthernet5/5
!
interface GigabitEthernet5/6
!
interface GigabitEthernet5/7
!
interface GigabitEthernet5/8
!
interface GigabitEthernet5/9
!
interface GigabitEthernet5/10
!
interface GigabitEthernet5/11
!
interface GigabitEthernet5/12
!
interface Vlan1
no ip address
!
interface Vlan20
description xxx-DIST-Data
ip address 156.128.20.240 255.255.254.0
shutdown
!
interface Vlan34
description xxx-Data-managemnet
ip address 156.128.34.240 255.255.254.0
shutdown
!
interface Vlan168
description AT&T Switch to xxxx Switch
ip address 156.128.168.4 255.255.255.240
shutdown
!
interface Vlan320
description xxx-voice
ip address 10.188.20.240 255.255.254.0
shutdown
!
interface Vlan334
description xxxx-voice
ip address 10.188.34.240 255.255.254.0
shutdown
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 156.128.x.1
!
!
!
banner motd ^C
This system is for the use of court authorized users only.  Individuals
accessing or using this computer system without authority, or in excess of
their authority, are subject to having all of their activities on this system
monitored and recorded by system personnel.

In the course of monitoring individuals improperly accessing or using this
system, or in the course of system maintenance, the activities of authorized
users may also be monitored.

Anyone accessing or using this system expressly consents to such
monitoring and is advised that if such monitoring reveals possible evidence
of criminal activity, system personnel may provide the evidence of such
monitoring to law enforcement officials.^C
!
line con 0
privilege level 15
stopbits 1
line vty 0 4
privilege level 15
login
transport input all
!
end

when I connected the corfe (this switch)0 to a 3750 closet stack switch #1, I see the interfaces at both sides comming up like below:

GigabitEthernet5/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 2c54.2ddb.2478 (bia

2c54.2ddb.24                 78)

Description: DOWNLINK to xxx1217B

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:21, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops:

0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

     359 packets input, 26906 bytes, 0 no buffer

     Received 356 broadcasts (356 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 5 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

xxx-Core4507#sh int gi5/1 trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi5/1       off              802.1q         notrnk-bndl   1

                                      (Po11)

Port        Vlans allowed on trunk

Gi5/1       1

Port        Vlans allowed and active in management domain

Gi5/1       1

Port        Vlans in spanning tree forwarding state and not pruned

Gi5/1       1

BUT:

GigabitEthernet5/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet Port, address is 2c54.2ddb.2478 (bia 2c54.2ddb.2478)

  Description: DOWNLINK to xxxx1217B (DIST-PROB-Data)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:20, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Hall of Fame Super Gold

Re: dot1q encapsulation option not showing up under the Interfac

Your output to the command "sh interface trunk" proves the line card in slot 5 will support only 802.1Q trunking hence the command "switchport trunk encap dot1q" is not needed/required.

New Member

Re: dot1q encapsulation option not showing up under the Interfac

thanks. Now, what is the solution to my problem?

I need to configure these interfaces, uplinks to closets connecting to stacks of 3750s with:

interface GigabitEthernet 5/1

description DOWNLINK to XXXXX-LS

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 11 mode on

!

the command i cannot execute is:

switchport trunk encapsulation dot1q

what is the solution? and why it is not allowed? because of wrong hardware? wrong IOS?

please advise.

Regards,

Masood

Hall of Fame Super Gold

Re: dot1q encapsulation option not showing up under the Interfac

the command i cannot execute is:

switchport trunk encapsulation dot1q

what is the solution? and why it is not allowed? because of wrong hardware? wrong IOS?

There is nothing wrong.  It's normal.  The line card in slot 5 will only support 802.1q so this command is NOT NEEDED.

New Member

Re: dot1q encapsulation option not showing up under the Interfac

even though the output for :

sh int gi5/1

shows ARPA ac encapsulation?

even with this its ok and nothing is wrong and i do not need that command?

why is it supported under 6509E and not 4507R?

Thanks,

Masood

Purple

Re: dot1q encapsulation option not showing up under the Interfac

  Because is slowly sunsetting the  cisco proprietary format ISL encapsulation which leaves the IEEE dot1q standard . So there is only 1 encap method now .   Some Cisco earlier small switches like the 2950 were the same way.  Why cisco isn't consistent with it's implementation is anybodys guess and you would have to ask cisco.

Hall of Fame Super Gold

dot1q encapsulation option not showing up under the Interface 45

why is it supported under 6509E and not 4507R?

Again, let me repeat by saying it's got nothing to do with the IOS.  It's all in the ethernet line cards.  Some ethernet line cards support either 802.1Q and Cisco-proprietary ISL.  Some line cards simply support 802.1Q.

New Member

dot1q encapsulation option not showing up under the Interface 45

right dear... Some ethernet line cards support either 802.1Q and Cisco-proprietary ISL.  Some line cards simply support 802.1Q.... and 802.1Q is useful for intervlan routing only...

3781
Views
0
Helpful
9
Replies
CreatePlease login to create content