Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Dot1q question on 2811

I have a 2811 with a dot1q interface for vlan 10 on FastEthernet0/0. I have an int vlan 10 configured on the router with an IP address that serves as a gateway for all devices in vlan 10. From a remote switch in vlan 10 I cannot ping the gateway IP of the router 10.100.110.1. Is it a requirement to bridge traffic coming into the dot1q interface to the int vlan 10? There is an 4 port HWIC FastEhternet card in the router as well.

interface FastEthernet0/0

no ip address

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

interface Vlan10

description *** Mgmt***

ip address 10.100.10.1 255.255.255.0 secondary

ip address 10.100.110.1 255.255.255.0

ip nat inside

no ip virtual-reassembly

2 REPLIES

Re: Dot1q question on 2811

Your layer 3 info should go directly under the sub-interface.

Example-

interface FastEthernet0/0.10

encapsulation dot1Q 10

description *** Mgmt***

ip address 10.100.10.1 255.255.255.0 secondary

ip address 10.100.110.1 255.255.255.0

ip nat inside

no ip virtual-reassembly

Hope that helps.

Hall of Fame Super Blue

Re: Dot1q question on 2811

Jon

Do you want to use a subinterface or a vlan interface. If you want to use a subinterface then change your config -

nterface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.100.10.1 255.255.255.0 secondary

ip address 10.100.110.1 255.255.255.0

ip nat inside

no ip virtual-reassembly

Jon

890
Views
0
Helpful
2
Replies
CreatePlease to create content