Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Dot1q trunk between 6500 and 4948 issues

I'm having some trouble with establishing a trunk port between a Cisco 6513 and Cisco 4948.

Here is the config:

Cisco 6513

int gig 8/1

switchport

switchport encap dot1q

switchport mode trunk

switchport trunk allowed vlan 1

speed noneg

no shut

int vlan 1

description Mgmt VLAN

ip address 10.10.10.1 255.255.255.0

no shut

Cisco 4948

gig 1/48

switchport

switchport encap dot1q

switchport mode trunk

switchport  trunk allowed vlan 1

speed noneg

no shut

int vlan 1

description Mgmt VLAN

ip address  10.10.10.2 255.255.255.0

no shut

Status:

1- Both Gige's are up/up

2- But can't ping each other

Cards on Cisco 6513:

  slot:7    2  Supervisor Engine 720 (Active)         WS-SUP720-3B 
  Slot:8    2  Supervisor Engine 720 (Hot)            WS-SUP720-3B

I have Gig7/1 on Cisco 6513 and Gi1/47 on the Cisco 4948 up, as a routed port.  I hate to touch these ports or else I loose connectivity to the Cisco 4948.

-Manny

7 REPLIES

Re: Dot1q trunk between 6500 and 4948 issues

Manny,

Can you provide from both 6513 and 4948 switches the  output of  " show int gig8/1  switchport " and "show int gig1/48  switchport" , also output of "show interface gig8/1 trunk" ,  show int gig1/48 trunk  from the 4948 .

you may need to   use " switchport  trunk encap dot1q"  in the interfaces  , unless switchport encap dot1q  syntax is a typo or command was introduce in a ios version Im not aware of then is fine,  but  the output  of above interface information  as well as "show vtp status" from each switch would help to understand your l2 topology and  give us some hints on what could be the issue on the interfaces

Regards

Re: Dot1q trunk between 6500 and 4948 issues

Hi,

Can I ask you something ? Isnt is that the port are working as switchports ( trunk mode ) and you are assigning Ip address on that switchport and trying to ping them. I think ones the port is in switching mode the ip address is assigned to the SVI and then you can access the switch using that SVI ip address. It is always the routed port that are assigned the ip address.

Let me know if my understanding of switchports and routed ports are wrong !! plz

Thanks

Manish

Re: Dot1q trunk between 6500 and 4948 issues

sorry ! misread it the first time , drunk i believe ... did not see the interface vlan config. can you post

1> sh ip route

2> sh spanning tree

3> Vlan database

Thanks

Manish

New Member

Re: Dot1q trunk between 6500 and 4948 issues



Cisco 4948-

sho run int gig 1/47

interface GigabitEthernet1/47

description to Cisco 6515 – Gi7/1

ip address 20.20.20.1 255.255.255.252

speed nonegotiate

end

show run int gig 1/48

interface GigabitEthernet1/48

description to Cisco 6515   -  Gi8/1

switchport trunk encapsulation   dot1q

switchport mode trunk

shutdown

speed nonegotiate

end

show int gig 1/48

GigabitEthernet1/48 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet   Port, address is 001a.6d2e.25ef (bia 001a.6d2e.25ef)

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link   type is force-up, media type is 1000BaseLH

  Media-type configured as SFP   connector

  input flow-control is on,   output flow-control is off

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:00, output   never, output hang never

  Last clearing of "show   interface" counters never

  Input queue: 0/2000/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 7000   bits/sec, 7 packets/sec

  5 minute output rate 0   bits/sec, 0 packets/sec

     52743 packets input,   4514048 bytes, 0 no buffer

     Received 50864 broadcasts   (19152 multicast)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 input packets with   dribble condition detected

     384 packets output, 62066   bytes, 0 underruns

     0 output errors, 0   collisions, 0 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier

     0 output buffer failures, 0   output buffers swapped out

show run int vlan 1

interface Vlan1

ip address 172.22.100.28   255.255.255.0

end

ping 172.22.100.23

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.22.100.23, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

show ip ro

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP   external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external   type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type   1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS   summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, *   - candidate default, U - per-user static route

       o - ODR, P - periodic   downloaded static route

Gateway of last resort is 172.22.100.1 to network 0.0.0.0

     20.0.0.0/30 is subnetted, 1   subnets

C       20.20.20.0 is directly   connected, GigabitEthernet1/47

     172.22.0.0/24 is subnetted,   1 subnets

C       172.22.100.0 is directly   connected, Vlan1

S*   0.0.0.0/0 [1/0] via   172.22.100.1

show spanning-tree

VLAN0001

  Spanning tree enabled protocol   ieee

  Root ID    Priority    32768

             Address     0006.282b.7680

             Cost        23

             Port        48 (GigabitEthernet1/48)

             Hello Time   2 sec  Max Age 20 sec Forward Delay 15   sec

  Bridge ID  Priority    32769  (priority 32768   sys-id-ext 1)

             Address     001a.6d2e.25c0

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15   sec

             Aging Time 300

Interface        Role Sts   Cost      Prio.Nbr Type

---------------- ---- --- --------- --------   --------------------------------

Gi1/48           Root FWD 4         128.48   P2p

show int vlan 1

Vlan1 is up, line protocol is up

  Hardware is Ethernet SVI, address   is 001a.6d2e.25ff (bia 001a.6d2e.25ff)

  Internet address is   172.22.100.28/24

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:07, output   never, output hang never

  Last clearing of "show   interface" counters never

  Input queue: 0/75/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0   bits/sec, 0 packets/sec

  5 minute output rate 0   bits/sec, 0 packets/sec

  L3 in Switched: ucast: 0 pkt,   0 bytes - mcast: 0 pkt, 0 bytes

  L3 out Switched: ucast: 0 pkt,   0 bytes - mcast: 0 pkt, 0 bytes

     639 packets input, 260024   bytes, 0 no buffer

     Received 639 broadcasts (0   IP multicast)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     120 packets output, 6330   bytes, 0 underruns

     0 output errors, 0   interface resets

     0 output buffer failures, 0   output buffers swapped out

show cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route   Bridge

                  S - Switch, H   - Host, I - IGMP, r - Repeater, P - Phone

Device ID            Local Intrfce         Holdtme   Capability    Platform   Port ID

Cisco 6515     Gig 1/48              130           R S I     WS-C6513  Gig 8/1

Cisco 6515     Gig 1/47              161           R S I     WS-C6513  Gig 7/1

Cisco 6515-

show run int gig 8/1

interface GigabitEthernet8/1

description to Cisco 4948 -   Gi1/48

switchport

switchport trunk encapsulation   dot1q

switchport mode trunk

speed nonegotiate

end

show run int gig 7/1

interface GigabitEthernet7/1

description to Cisco 4948 -   Gi1/47

ip address 20.20.20.2   255.255.255.252

speed nonegotiate

show int gig 8/1

GigabitEthernet8/1 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3,   address is 0013.7f0d.3ce4 (bia 0013.7f0d.3ce4)

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media   type is LH

  input flow-control is off,   output flow-control is on

  Clock mode is auto

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 3d22h, output   00:00:07, output hang never

  Last clearing of "show   interface" counters 29w5d

  Input queue: 0/2000/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0   bits/sec, 0 packets/sec

  5 minute output rate 0   bits/sec, 0 packets/sec

     555 packets input, 89894   bytes, 0 no buffer

     Received 505 broadcasts   (500 multicasts)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0   pause input

     0 input packets with   dribble condition detected

     52504 packets output,   4595486 bytes, 0 underruns

     0 output errors, 0   collisions, 3 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier, 0 PAUSE output

     0 output buffer failures, 0   output buffers swapped out

show run int vlan 1

interface Vlan1

ip address 172.22.100.23   255.255.255.0

end

ping 172.22.100.28

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.22.100.28, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP   external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external   type 1, N2 - OSPF NSSA external type 2

      E1 - OSPF external type 1, E2 - OSPF   external type 2

       i - IS-IS, su - IS-IS   summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, *   - candidate default, U - per-user static route

       o - ODR, P - periodic   downloaded static route

Gateway of last resort is 172.22.100.1 to network 0.0.0.0

     20.0.0.0/30 is subnetted, 1   subnets

C       20.20.20.0 is directly   connected, GigabitEthernet7/1

     172.22.0.0/24 is subnetted,   1 subnets

C       172.22.100.0 is directly   connected, Vlan1

S*   0.0.0.0/0 [1/0] via   172.22.100.1

show spanning-tree

VLAN0001

  Spanning tree enabled protocol   ieee

  Root ID    Priority    32768

             Address     0006.282b.7680

             Cost        19

             Port        176 (FastEthernet2/48)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15   sec

  Bridge ID  Priority    32769  (priority 32768   sys-id-ext 1)

             Address     000b.60f3.ab80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15   sec

             Aging Time 300

Interface           Role Sts   Cost      Prio.Nbr Type

------------------- ---- --- --------- --------   --------------------------------

Fa2/48              Root FWD 19        128.176  P2p

Gi4/3               Desg FWD   4         128.387  P2p

Gi8/1               Desg FWD   4         128.897  P2p

Po4                 Desg FWD   4         128.1665 P2p

Po5                 Desg FWD   4         128.1666 P2p

show cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route   Bridge

                  S - Switch, H   - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local   Intrfce     Holdtme    Capability  Platform  Port ID

Cisco 4948 Gig 8/1           179          R S I     WS-C4948  Gig 1/48

Cisco 4948 Gig 7/1           167          R S I     WS-C4948  Gig 1/47

show int vlan 1

Vlan1 is up, line protocol is up

  Hardware is EtherSVI, address   is 000b.60f3.ab80 (bia 000b.60f3.ab80)

  Internet address is   172.22.100.23/24

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:00, output   00:00:00, output hang never

  Last clearing of "show   interface" counters 29w5d

  Input queue: 0/75/751936/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 2000   bits/sec, 4 packets/sec

  5 minute output rate 3000   bits/sec, 3 packets/sec

  L2 Switched: ucast: 1679904971   pkt, 1055602240049 bytes - mcast: 40919877 pkt, 3222830684 bytes

  L3 in Switched: ucast: 0 pkt,   0 bytes - mcast: 0 pkt, 0 bytes mcast

L3 out Switched: ucast: 26171 pkt, 2162109   bytes mcast: 0 pkt, 0 bytes

     40688097 packets input,   3317459000 bytes, 0 no buffer

     Received 40170596   broadcasts (29217 IP multicasts)

     0 runts, 0 giants, 3352   throttles

     0 input errors, 0 CRC, 0 frame,   0 overrun, 0 ignored

     532795 packets output,   158199679 bytes, 0 underruns

     0 output errors, 0   interface resets

     0 output buffer failures, 0   output buffers swapped out

Cisco Employee

Re: Dot1q trunk between 6500 and 4948 issues

Fiber

Something is not right.  The 'sh run' shows interface g1/48 as 'shutdown', but the 'sh int g1/48' shows it up/up.

Can you verify that it isn't shutdown.

Cisco Employee

Re: Dot1q trunk between 6500 and 4948 issues

Can you also post the 'show interface trunk' output ?

New Member

Re: Dot1q trunk between 6500 and 4948 issues

I dont have much experience with the Cisco 6515, can Gig8/1 on the Cisco 6515 be on-standby since its the standy card?  Card in slot 7 is active.  I figured Gig8/1 can not be used, but I maybe wrong.


Cisco   4948

ping 172.22.100.23

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.22.100.23, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)



show int gig 1/47

GigabitEthernet1/47 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet   Port, address is 001a.6d2e.25ff (bia 001a.6d2e.25ff)

  Description: to Cisco 6515 - Gi7/1

  Internet address is   20.20.20.1/30

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link   type is force-up, media type is 1000BaseLH

  Media-type configured as SFP   connector

  input flow-control is on,   output flow-control is off

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:00, output   never, output hang never

  Last clearing of "show   interface" counters never

  Input queue: 0/75/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0   bits/sec, 0 packets/sec

  5 minute output rate 1000   bits/sec, 1 packets/sec

  L3 in Switched: ucast: 2224   pkt, 92157 bytes - mcast: 0 pkt, 0 bytes

  L3 out Switched: ucast: 0 pkt,   0 bytes - mcast: 0 pkt, 0 bytes

     213212 packets input,   20240692 bytes, 0 no buffer

     Received 207575 broadcasts   (0 IP multicast)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 input packets with   dribble condition detected

     13762 packets output,   4526996 bytes, 0 underruns

     0 output errors, 0   collisions, 0 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier

     0 output buffer failures, 0   output buffers swapped out



show int gig 1/48

GigabitEthernet1/48 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet   Port, address is 001a.6d2e.25ef (bia 001a.6d2e.25ef)

  Description: to Cisco 6515 -   Gi8/1

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link   type is force-up, media type is 1000BaseLH

  Media-type configured as SFP   connector

  input flow-control is on,   output flow-control is off

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:00, output   never, output hang never

  Last clearing of "show   interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes);   Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 18000   bits/sec, 21 packets/sec

  5 minute output rate 0   bits/sec, 0 packets/sec

     70401 packets input,   5868701 bytes, 0 no buffer

     Received 67842 broadcasts   (32571 multicast)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 input packets with   dribble condition detected

     430 packets output, 67334   bytes, 0 underruns

     0 output errors, 0   collisions, 0 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier

     0 output buffer failures, 0   output buffers swapped out



show int trunk

Port        Mode         Encapsulation  Status        Native vlan

Gi1/48      on           802.1q         trunking      1

Port        Vlans allowed on   trunk

Gi1/48      1-4094

Port        Vlans allowed and   active in management domain

Gi1/48      1

Port        Vlans in spanning   tree forwarding state and not pruned

Gi1/48      1

Cisco   6515

ping 172.22.100.28

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.22.100.28, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)



show int gig 7/1

GigabitEthernet7/1 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3,   address is 000b.60f3.ab80 (bia 000b.60f3.ab80)

  Description: to Cisco 4948 -   Gi1/47

  Internet address is   20.20.20.2/30

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media   type is LH

  input flow-control is off,   output flow-control is on

  Clock mode is auto

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:20, output   00:00:20, output hang never

  Last clearing of "show   interface" counters 29w5d

  Input queue: 0/75/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0   bits/sec, 0 packets/sec

  5 minute output rate 0   bits/sec, 0 packets/sec

  L2 Switched: ucast: 1886 pkt,   181338 bytes - mcast: 5 pkt, 335 bytes

  L3 in Switched: ucast: 0 pkt,   0 bytes - mcast: 0 pkt, 0 bytes mcast

  L3 out Switched: ucast: 0 pkt,   0 bytes mcast: 0 pkt, 0 bytes

     14198 packets input,   4577862 bytes, 0 no buffer

     Received 12121 broadcasts   (0 IP multicasts)

     0 runts, 0 giants, 0   throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0   pause input

     0 input packets with   dribble condition detected

     223015 packets output,   21303395 bytes, 0 underruns

     0 output errors, 0   collisions, 5 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier, 0 PAUSE output

     0 output buffer failures, 0   output buffers swapped out



show int gig 8/1

GigabitEthernet8/1 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3,   address is 0013.7f0d.3ce4 (bia 0013.7f0d.3ce4)

  Description: to Cisco 4948 -   Gi1/48

  MTU 1500 bytes, BW 1000000   Kbit, DLY 10 usec,

     reliability 255/255, txload   1/255, rxload 1/255

  Encapsulation ARPA, loopback   not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media   type is LH

  input flow-control is off,   output flow-control is on

  Clock mode is auto

  ARP type: ARPA, ARP Timeout   04:00:00

  Last input 00:00:42, output   00:00:44, output hang never

  Last clearing of "show   interface" counters 29w5d

  Input queue: 0/2000/0/0   (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0   bits/sec, 0 packets/sec

  5 minute output rate 17000   bits/sec, 20 packets/sec

     606 packets input, 95814   bytes, 0 no buffer

     Received 534 broadcasts   (529 multicasts)

    0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0   frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0   pause input

     0 input packets with   dribble condition detected

     72853 packets output,   6150090 bytes, 0 underruns

     0 output errors, 0   collisions, 3 interface resets

     0 babbles, 0 late   collision, 0 deferred

     0 lost carrier, 0 no   carrier, 0 PAUSE output

     0 output buffer failures, 0   output buffers swapped out



show int trunk

Port                Mode         Encapsulation  Status        Native vlan

Gi4/3               on           802.1q         trunking      1

Gi8/1               on           802.1q         trunking      1

Po4                 on           802.1q         trunking      1

Po5                 on           802.1q         trunking      1

Port                Vlans   allowed on trunk

Gi4/3               1,328-348

Gi8/1               1-4094

Po4                 1,300-499,600-699

Po5                 1,300-499,600-699

Port                Vlans   allowed and active in management domain

Gi4/3               1,328-348

Gi8/1               1,149,301-349,401-406

Po4                 1,301-349,401-406

Po5                 1,301-349,401-406

Port                Vlans in   spanning tree forwarding state and not pruned

Gi4/3               1,328-348

Gi8/1               1,149,301-349,401-406

Po4                 1,301-349,401-406

Port                Vlans in   spanning tree forwarding state and not pruned

Po5                 1,301-349,401-406

2133
Views
0
Helpful
7
Replies
CreatePlease to create content