Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DSCP tags are set to zero by 3750 after routing between VLANs

Hi All,

I have a 3750 switch with the following configuration on access ports:

switchport access vlan 1
switchport mode access
switchport voice vlan 2     
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast

There are two voice vlans defined on this switch. I have two Cisco IP phones connected to access ports. If I put these access ports in the same voice VLAN and capture the traffic, I can see that incoming and outgoing traffics have EF DSCP tags on them. If I put these access port in different voice vlans and capture the traffic at each, incoming RTP traffic will lose the DSCP EF tag and DSCP will be set to zero, however the outgoing traffic will still have the  EF dscp value.

Any idea why DSCP tags are getting cleared by the switch ?

12 REPLIES
Purple

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Do you have same behavior when you remove  autoqos command  and add  mls qos trust device cisco-phone ?

Don't forget to rate helpful posts.
New Member

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Yes, same result

Re: DSCP tags are set to zero by 3750 after routing between VLAN

You have set the port to trust cos. To analyze the problem, you need to look at the dot1p value in the dot1Q header (layer2 qos).

This value should be 5 and that is the value used to set the DSCP value upon egress, due to the trust setting.

Also, the global qos config should contain a line like below:

mls qos map cos-dscp 0 10 18 26 34 46 48 56

The bold number (46) corresponds to your desired value of EF. By default, the value is often set to 40.

You can also verify this by using the command: sh mls qos mapping

This behavior is typical when you are routing traffic between switches over the native vlan. As this is untagged, the cos value is not preserved during transit and hence reset to default (0).

regards,

Leo

Cisco Employee

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Is this 3750 routing the packets or are the packets going to another device to be routed?

Look at 'show mls qos interface stat' to see how many packets come in and leave the port with which DSCP and COS values.  Make sure your phones are tagging with CoS.  If they are only setting DSCP, try to change the trust status to 'mls qos trust dscp'.

New Member

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Another 3750 which is connected to this switch by trunk does the routing. mls qos trust dscp is defined on the trunk ports. Here is the output of the "show mls qos interface x/x"  command:

trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: cisco-phone
qos mode: port-based

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Most likely you are losing the cos markings in the path to and from the routing switch.

Which type of trunking are you using?

This should be dot1Q but the 3750 will default to ISL. If so, you have found the problem.

If not, please check native vlan setting (default?) and the trust settings on the ingress ports.

regards,

Leo

New Member

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Trunks are all dot1Q. I double checked the config on the trunk ports and all of them have trust mls qos trust dscp configured on them.

Cisco Employee

Re: DSCP tags are set to zero by 3750 after routing between VLAN

What happens if you change the access switch to trust DSCP instead of COS?

New Member

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Same results as before

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Perhaps I have misunderstood your first post describing the issue.

There you state that you have attached the phones to access ports configured with the voice vlan.

Now I think you might mean: swi acc vlan {voicevlan}

This is incorrect! The phones must be on ports configured with the "switchport voice vlan xx".

If you did it as I described, the frames have no dot1Q tag and hence lose their markings.

regards,

Leo

Purple

Re: DSCP tags are set to zero by 3750 after routing between VLAN

Can you put config from each access port and tell us how you capture traffic as well as how you do the intervlan routing

Thanks.

Don't forget to rate helpful posts.
New Member

Re: DSCP tags are set to zero by 3750 after routing between VLAN

- All access-ports have the following settings:

switchport access vlan 1
switchport mode access
switchport voice vlan 2     
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust cos

mls qos trust device cisco-phone
auto qos voip cisco-phone
spanning-tree portfast

- Intervlan routing is done by another 3750 which is connected to this switch by a trunk port

- I have configured SPAN on the this switch to capture the traffc on two ports that are connected to the phones and send it to another port which I have  wireshark running on it.

1022
Views
0
Helpful
12
Replies
CreatePlease to create content