Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DSL via Router 800 Series (877)

Dear all ,

We have a new internet connection from DSL cisco router 800 Series (877).

You has been delivered it to us with Cisco Router 800 series (Ver 870), when we connect it to the PC directly it’ll work fine with the static IP.

But when we try to connect it to out Cisco Core Switch 6509 it’ll not work totally.

We try to configure it with (OSPF – EIGRP or Directly connect with static IP’s), but the result still the same (the Switch can’t reach to the Router).

Please i need your advice

DSL router 877 ---------------> Core Switch 6509 ----> PC

inter Vlan 1                         

ip address 78.x.x.x

3 REPLIES

DSL via Router 800 Series (877)

hi mohamded,

it would be helpful if you could please post your 877 and 6509 config. have you tried changing UTP cable? a cross-cable perhaps?

New Member

DSL via Router 800 Series (877)

Dear John,

Router 877 (DSL):

-----------------

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Lotfy

!

boot-start-marker

boot-end-marker

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

  pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $Internet$

ip address 96.25.31.81 255.255.255.248

ip nat inside!23

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname xxxxxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxx

!

router ospf 1

log-adjacency-changes

network 96.25.31.80 0.0.0.7 area 0

default-information originate

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

password 7 130C04

login local

!

scheduler max-task-time 5000

end

Core Switch 6509:

------------------

interface GigabitEthernet8/25

switchport

switchport access vlan 777

switchport mode access

!

!

interface Vlan777

ip address 96.25.31.82 255.255.255.248

end

!

!

interface Vlan510

description SW_to_internet

ip address 10.170.10.250 255.255.255.0

end

!

interface GigabitEthernet8/26

switchport

switchport access vlan 510

switchport mode access

!

router ospf 1

log-adjacency-changes

network 10.170.10.0 0.0.0.255 area 0

network 96.25.31.80 0.0.0.7 area 0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 96.25.31.81

===============================================

Verify:

Lotfy#ping 10.170.10.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.170.10.250, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

DC-BB16509#ping 96.25.31.81

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 96.25.31.81, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

DC-BB1#traceroute 4.2.2.2

Type escape sequence to abort.

Tracing the route to 4.2.2.2

  1 96.25.31.81 4 msec 0 msec 0 msec

  2  *  *  *

  3  *  *  *

  4  *  *  *

  5  *  *  *

Re: DSL via Router 800 Series (877)

Hi Mohamed,

Thanks for posting your config. I believe you've forgot to enable dynamic NAT on the 877. Try to do as below and test again:

access-list 23 permit 96.25.31.80 0.0.0.7

ip nat inside source list 23 interface dialer1 overload

Sent from Cisco Technical Support iPhone App

435
Views
0
Helpful
3
Replies
CreatePlease to create content