Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Dual P2P Route Question

Hello Guys,

Ihave attached a diagram for reference. At one of our sites we have a 10 Mb P2P connection, and we are upgrading that line to a 200 Mb with a different carrier. The thing is we would like to use the 200 Mb line for dedicated file transfers temporarily while the 10 Mb is still online, but still have the client connect using the 10 Mb line. To provide more info, we have two servers in our DC that we would like that to utilize the 10 Mb connection over to their site. All their computers will need to use the 10 Mb line to connect to only these two servers, but all the other servers in our DC we would like to use the 200 Mb to their site.

Is this something that can be handled with prefix-lists using like EIGRP or OSPF, or would static routes using just individual hosts to force them over the preferred line be ideal. Or maybe there is an easier way that I'm just not thinking of .

Thanks in advance for all the help!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Dual P2P Route Question

Hi John.

My idea was to match traffic from server subnet to the other side of P2P and redirecting to 10Mb link via a route-map

and the back path using a static route to the server subnet pointing to 10Mblink

Let's say P2P 10Mb link has 10.10.10.1 6500 side and 10.10.10.2 2900 side.

In 6500 configure a route-map as follows

ip access-list extended Sever10Mb

permit ip 192.168.1.100 0.0.0.1 192.168.2.0 0.0.0.255

route-map 10MbLink

match ip address Sever10Mb

set ip next-hop 10.10.10.1

interface vlan10 <------this should match your server vlan on 6500

ip policy route-map 10MbLink

------on 2921-----

ip route 192.168.1.100 255.255.255.254 10.10.10.2

ip route 192.168.1.100 255.255.255.254 x.x.x.x 200 (x.x.x.x) is the next hop of 200Mb P2P link

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
3 REPLIES

Re: Dual P2P Route Question

Hi John.
I can suggest you PBR (policy based routing) on 6K matching traffic from server to any destination , and symmetric static routes with different metric for HA
HTH

Regards

Carlo
Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Community Member

Re: Dual P2P Route Question

Hello Carlo,

Thanks for this info! I'm not too sure I fully understand though. Can you be a bit more specifc if possible? Thanks!

Re: Dual P2P Route Question

Hi John.

My idea was to match traffic from server subnet to the other side of P2P and redirecting to 10Mb link via a route-map

and the back path using a static route to the server subnet pointing to 10Mblink

Let's say P2P 10Mb link has 10.10.10.1 6500 side and 10.10.10.2 2900 side.

In 6500 configure a route-map as follows

ip access-list extended Sever10Mb

permit ip 192.168.1.100 0.0.0.1 192.168.2.0 0.0.0.255

route-map 10MbLink

match ip address Sever10Mb

set ip next-hop 10.10.10.1

interface vlan10 <------this should match your server vlan on 6500

ip policy route-map 10MbLink

------on 2921-----

ip route 192.168.1.100 255.255.255.254 10.10.10.2

ip route 192.168.1.100 255.255.255.254 x.x.x.x 200 (x.x.x.x) is the next hop of 200Mb P2P link

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
123
Views
5
Helpful
3
Replies
CreatePlease to create content