Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Duplex Mismatch between 2950 and 4503 (strange problem)

Hi folks,

I'm having a ... strange issue. I've tried searching all over, and haven't run into an answer that covers this scenario.

I have a 4503 switch (in L2 mode) running 12.1 hooked into a C2950 running 12.1, using regular 4 pair Cat5e cables to connect between them. The 4503 has Gigabit port 2/1 trunking to the 2950's Fa port 0/13.

When I set the duplex mode to DUPLEX FULL and SPEED to SPEED 100 on both switches (for their trunk ports) the link fails, and my 4503 loses connectivity (since it gets it from the 2950).

Here is my config from the switches (per description):

The 4503:

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

speed 100

duplex full

The 2950:

interface FastEthernet0/13

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

speed 100

duplex full

When I set DUPLEX AUTO (on both), SPEED 100 (on both)  I lose the link again.

Here is my port config for that setup:

The 4503:

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

speed 100

The 2950:

interface FastEthernet0/13

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

speed 100

When I set both switches to DUPLEX AUTO and SPEED AUTO, the link comes back, /but/ I get a duplex mismatch, which makes the 4503 link run at half duplex.

Here is my port config for that setup:

The 4503:

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

The 2950:

interface FastEthernet0/13

switchport trunk allowed vlan 1,2,100-140

switchport mode trunk

Note, this is the only mode that works (which seems to work fine, but I get TERRIBLE throughput for anything that goes over the 2950.

Can anyone shed some light on this? I'm hoping I just missed something elementary.

Everyone's tags (2)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Gold

Duplex Mismatch between 2950 and 4503 (strange problem)

You didn't mention what kind of cable are you using?  Straight-through or Cross-over?

Cisco Employee

Duplex Mismatch between 2950 and 4503 (strange problem)

Hello Mahir,

I believe that Leo is probably most close to the explanation. On many (if not all) Cisco Catalyst platforms, when you set both speed and duplex to a fixed setting then the auto-MDIX (autocross) function is deactivated. That means that you have to use proper cross-over cables to interconnect your 4500 and 2950, otherwise loss of connectivity will occur.

Please note that except in rare conditions, it is not recommended to statically configure the speed and duplex setting. Nowadays, the autonegotiation is considered a mechanism with a satisfactory performance, and using static settings usually leads to trouble, ranging from duplex mismatches to devices not even being able to bring the link up. Is there any particular need for you to configure the speed/duplex setting manually?

Best regards,

Peter

5 REPLIES
Hall of Fame Super Gold

Duplex Mismatch between 2950 and 4503 (strange problem)

You didn't mention what kind of cable are you using?  Straight-through or Cross-over?

Duplex Mismatch between 2950 and 4503 (strange problem)

Hi mahir,

can i have the sh ver of both the devices..... else i need the IOS complete code, sup model and 2950 model for verifying a known issue..... also i need the module chassis model for 4503 as well.....

Cisco Employee

Duplex Mismatch between 2950 and 4503 (strange problem)

Hello Mahir,

I believe that Leo is probably most close to the explanation. On many (if not all) Cisco Catalyst platforms, when you set both speed and duplex to a fixed setting then the auto-MDIX (autocross) function is deactivated. That means that you have to use proper cross-over cables to interconnect your 4500 and 2950, otherwise loss of connectivity will occur.

Please note that except in rare conditions, it is not recommended to statically configure the speed and duplex setting. Nowadays, the autonegotiation is considered a mechanism with a satisfactory performance, and using static settings usually leads to trouble, ranging from duplex mismatches to devices not even being able to bring the link up. Is there any particular need for you to configure the speed/duplex setting manually?

Best regards,

Peter

New Member

Duplex Mismatch between 2950 and 4503 (strange problem)

Hey guys,

Thanks for all the replies. Leo was spot on; I moved to a crossover cable and that fixed my problem. The only outstanding thing (as Peter mentioned) is that Auto configuration does not seem to work -- using a regular straight through cable, with both switches in AUTO SPEED and AUTO DUPLEX, I get a duplex mismatch. The 4500 runs at half duplex, while the 2950 wants to run at full duplex.

I am up and running , but it would be nice to have it auto config. Not a huge deal, just an ideal scenario.

Does anyone else have any further thoughts?

Also, here's the sho ver of both:

The 2950:

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA2, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Sun 07-Nov-04 23:14 by antonino

Image text-base: 0x80010000, data-base: 0x8055E000

ROM: Bootstrap program is C2950 boot loader

WFCoreSwitch1 uptime is 1 year, 16 weeks, 2 days, 11 hours, 40 minutes

System returned to ROM by power-on

System image file is "flash:c2950-i6q4l2-mz.121-22.EA2.bin"

cisco WS-C2950G-48-EI (RC32300) processor (revision A0) with 21055K bytes of memory.

Processor board ID FHK0615X26P

Last reset from system-reset

Running Enhanced Image

48 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:09:7C:4A:CF:00

Motherboard assembly number: 73-7409-08

Power supply part number: 34-0965-01

Motherboard serial number:  REDACTED

Power supply serial number:  REDACTED

Model revision number: A0

Motherboard revision number: A0

Model number: WS-C2950G-48-EI

System serial number: REDACTED

Configuration register is 0xF

The 4500:

Cisco Internetwork Operating System Software

IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-I9K2S-M), Version 12.1(20)EW1, EARLY

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Mon 01-Dec-03 19:45 by eaarmas

Image text-base: 0x00000000, data-base: 0x0106BC90

ROM: 12.1(20r)EW

Dagobah Revision 86, Swamp Revision 3

GBSwitch1 uptime is 20 hours, 50 minutes

System returned to ROM by reload

System image file is "bootflash:"

[REMOVED EXPORT WARNING]

cisco WS-C4503 (XPC8245) processor (revision 4) with 262144K bytes of memory.

Processor board ID FOX073902RB

Last reset from Reload

1 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

98 Gigabit Ethernet/IEEE 802.3 interface(s)

511K bytes of non-volatile configuration memory.

Configuration register is 0x2101

Hall of Fame Super Gold

Duplex Mismatch between 2950 and 4503 (strange problem)

Wow.  Both switches are running very, very old IOS.

Thanks for the ratings.

1655
Views
0
Helpful
5
Replies
CreatePlease to create content