Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dynamic routing with OSPF

Hi experts,

I have four routers: one is 1811 and three 871. I want to configure dynamic routing between them and I choosed OSPF to do that. Because of that routers doesn't have layer 3 FE interfaces but only 8 or 4 port switch interfaces, i am not sure how to do the dynamic routing. I configured Vlan 99 on all of the routers and connected the three 871's to 1811.

To understand me better i attach a picture of the topology!

So with this topology shoul i disable split horizon on int vlan99 at 1811 router??? I think i have to disable it because routing updates from any of the 871 routers will not be redistributed.

Thank you!

Tihomir Yosifov

2 REPLIES

Re: Dynamic routing with OSPF

Hi Zenon

Could be wrong but is the 1811 not a fixed chassis, ie, no modules, I did not know you could use them as L2 interfaces but could be wrong, if so then, split horizon will not help you here as that is a Distance Vector protocol feature and you are using OSPF which is a Link State protocol. This sounds more like a configuration issue.

As all the interfaces are in the same VLAN, then I assume you have put them all in the same subnet right?

I also assume you are using the ethernet module in the

Can you ping any of the routers

Have you put the interfaces in to the same area, ie

871 Router 1

interface

192.168.1.x 255.255.255.0

router ospf 1

network 192.168.1.0 0.0.0.0 area 0

871 Router 2

interface

192.168.1.x 255.255.255.0

router ospf 1

network 192.168.1.0 0.0.0.0 area 0

871 Router 3

interface

192.168.1.x 255.255.255.0

router ospf 1

network 192.168.1.0 0.0.0.0 area 0

are the neighbour relationships up

show ip ospf neighbour

New Member

Re: Dynamic routing with OSPF

Hi Adam,

1811 is a fixed model and there is no module support.

Just to be clear, I have not implemented the ospf routing yet and i am just asking if there will be any problems with this topology. I didn't know that split horizon is a distance vector feature?!

I configured the interfaces that way:

871 Router 1

interface vlan99

ip add 192.168.99.1

interface fa 2

switchport mode access

switchport access vlan 99

#################################

871 Router 2

interface vlan99

ip add 192.168.99.2

interface fa 2

switchport mode access

switchport access vlan 99

#################################

871 Router 3

interface vlan99

ip add 192.168.99.3

interface fa 2

switchport mode access

switchport access vlan 99

#################################

1811

interface vlan99

ip add 192.168.99.4

!

interface fa 2

descr ### to 871 Router1 ###

switchport mode access

switchport access vlan99

interface fa 3

descr ### to 871 Router2 ###

switchport mode access

switchport access vlan99

interface fa 4

descr ### to 871 Router3 ###

switchport mode access

switchport access vlan99

Everything is up and working.

OK so if I use OSPF it suppose to work. What if i use RIP or EIGRP ? Will be problem split horizon then ?

I am asking this because i am still not 100% sure witch routing protocol to use.

Thank you again!

165
Views
0
Helpful
2
Replies