Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Edit settings to have the LAN/WiFi internet connection through Cisco 871w router.

Hello,

 

I've been trying to solve an issue with internet connectivity. Can't ping any website from my Laptop that is connected to Cisco 871w router and this router is connected to Motorolla modem. 

I can ping any website or my laptop directly from a Cisco router.
From my laptop via LAN or Wireless I can ping: FastEthernet4 73.41.90.3
                                                                                  BVI1 10.10.11.1
                                                                                  Ethernet IP Address 192.168.100.1 on my modem.
Though, I can't ping any website from my laptop via LAN or Wireless.

 

I really need help to configure my router to have WiFi and LAN connectivity. When I had LAN only, I was able to surf the web but when I started to configure WiFi, I lost it when I had to add BVI1 and remove IP address from VLAN1. Don't know what to do and how to solve this problem. I know for sure that my access-list IP address is wrong. The must be something else. Main goal is to have a WiFi internet connectivity. Will appreciate any help very much!

 

Here is some info:

 

SHOW RUN:

Point38#sh running-config
Building configuration...

Current configuration : 3471 bytes
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Point38
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2115742889
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2115742889
 revocation-check none
 rsakeypair TP-self-signed-2115742889
!
!
crypto pki certificate chain TP-self-signed-2115742889
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313135 37343238 3839301E 170D3131 30393038 31363439
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313537
  34323838 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100951C BF907747 4B8E05F7 519CCF6B 9980D4BE 20E47422 E1BAA99E 7486F57A
  372803E3 8DDF1041 9AE62553 99F3B534 597A85D4 1F6AE1FA FB088662 E44B26F6
  E56646B0 D7CBAA6A EAE75DAB 9D2240F6 6B63E30B 80A1D618 B70D492B F4894A06
  B858FC61 DE5E6C03 8F91C57C 66C7EFA9 B69CA130 822E7A27 86397D01 B48A8C2A
  92010203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 146C2830 9C48CC87 AF9E2AE0 809CE79B B9634915 15301D06
  03551D0E 04160414 6C28309C 48CC87AF 9E2AE080 9CE79BB9 63491515 300D0609
  2A864886 F70D0101 05050003 81810066 34C4F576 70B52AB0 860568BA EF776057
  6733D526 3B03AB1E 7FF25528 8ECED3C2 84A9AC1E 8F366AF6 7FB446DA 3465243E
  2A3DF333 6A77F4B0 CE04ECBE 4C9EE716 91CDB426 6D235950 87A8FD73 F77A93D4
  A9547774 9D29C129 30D6F6A0 8FE6C71F 0EA4341A C4E2C349 6293253D E9FD2641
  291B8E30 E85B65E8 C13797AA 22D85B
        quit
dot11 syslog
!
dot11 ssid Area51
 vlan 1
 authentication open
 authentication key-management wpa
 mbssid guest-mode
 wpa-psk ascii 0 Cisco0607
!
ip source-route
!
ip dhcp pool DHCP_POOL
 import all
 network 10.10.11.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 75.75.75.75 75.75.76.76
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
bridge irb
!
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip dhcp client client-id hex 001FCA6BD8C8
 ip dhcp client hostname Point38
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm tkip
 !
 ssid Area51
 !
 mbssid
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly in
 bridge-group 1
!
interface BVI1
 ip address 10.10.11.1 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http secure-server
!
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
control-plane
!
bridge 1 route ip
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input all
!
end

________________________________________________________________________________

LAN Details: don't know why I have this default gateway but I believe it's wrong. ;)


   

 

BVI 1 and LAN 1:

 

 

MODEM:

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi , You need to modify your

Hi , 

You need to modify your gateway IP address on your DHCP pool & access-list for PAT

 

 no default-router 192.168.1.1

default-router 10.10.11.1 

no access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 10.10.11.0 0.0.0.255

 

HTH

Sandy

Hi , update ip nat inside on

Hi ,

 update ip nat inside on your BVI interface . it should work now .

interface BVI1
ip nat inside

 

HTH

Sandy

4 REPLIES

Hi , You need to modify your

Hi , 

You need to modify your gateway IP address on your DHCP pool & access-list for PAT

 

 no default-router 192.168.1.1

default-router 10.10.11.1 

no access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 10.10.11.0 0.0.0.255

 

HTH

Sandy

New Member

Hi Santhoshkumar,I've updated

Hi Santhoshkumar,

I've updated my configurations with yours, unfortunately it didn't work unless I didn't do it right. Here is my latest config:
 

Point38#sh run
Building configuration...

Current configuration : 3528 bytes
!
! Last configuration change at 16:46:14 UTC Thu Sep 8 2011
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Point38
!
boot-start-marker
boot-end-marker
!
no aaa new-model
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2115742889
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2115742889
 revocation-check none
 rsakeypair TP-self-signed-2115742889
!
!
crypto pki certificate chain TP-self-signed-2115742889
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313135 37343238 3839301E 170D3131 30393038 31363439
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313537
  34323838 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100951C BF907747 4B8E05F7 519CCF6B 9980D4BE 20E47422 E1BAA99E 7486F57A
  372803E3 8DDF1041 9AE62553 99F3B534 597A85D4 1F6AE1FA FB088662 E44B26F6
  E56646B0 D7CBAA6A EAE75DAB 9D2240F6 6B63E30B 80A1D618 B70D492B F4894A06
  B858FC61 DE5E6C03 8F91C57C 66C7EFA9 B69CA130 822E7A27 86397D01 B48A8C2A
  92010203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 146C2830 9C48CC87 AF9E2AE0 809CE79B B9634915 15301D06
  03551D0E 04160414 6C28309C 48CC87AF 9E2AE080 9CE79BB9 63491515 300D0609
  2A864886 F70D0101 05050003 81810066 34C4F576 70B52AB0 860568BA EF776057
  6733D526 3B03AB1E 7FF25528 8ECED3C2 84A9AC1E 8F366AF6 7FB446DA 3465243E
  2A3DF333 6A77F4B0 CE04ECBE 4C9EE716 91CDB426 6D235950 87A8FD73 F77A93D4
  A9547774 9D29C129 30D6F6A0 8FE6C71F 0EA4341A C4E2C349 6293253D E9FD2641
  291B8E30 E85B65E8 C13797AA 22D85B
        quit
dot11 syslog
!
dot11 ssid Area51
 vlan 1
 authentication open
 authentication key-management wpa
 mbssid guest-mode
 wpa-psk ascii 0 Cisco0607
!
ip source-route
!
ip dhcp pool DHCP_POOL
 import all
 network 10.10.11.0 255.255.255.0
 dns-server 75.75.75.75 75.75.76.76
 default-router 10.10.11.1
!
ip cef
!
bridge irb
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip dhcp client client-id hex 001FCA6BD8C8
 ip dhcp client hostname Point38
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm tkip
 !
 ssid Area51
 !
 mbssid
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly in
 bridge-group 1
!
interface BVI1
 ip address 10.10.11.1 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http secure-server
!
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 permit 10.10.11.0 0.0.0.255
!
control-plane
!
bridge 1 route ip
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input all
!
end

 

 

Hi , update ip nat inside on

Hi ,

 update ip nat inside on your BVI interface . it should work now .

interface BVI1
ip nat inside

 

HTH

Sandy

New Member

Wow, Santhoshkumar, it worked

Wow, Santhoshkumar, it worked indeed!! You know your stuff, thank you very much! yes

439
Views
0
Helpful
4
Replies
CreatePlease to create content