Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EIGPR IP default-network

Hello,

I have the following problem.

Topology.jpg

I'm trying to advertise the default route from R2 using the "ip default-network".

This is the configuration:

R1:

interface Loopback0
ip address 9.9.9.9 255.255.255.255
!
interface Loopback10
ip address 192.168.9.1 255.255.255.255
!

interface Ethernet0/0
ip address 40.0.0.2 255.255.255.252
duplex auto
!

ip route 0.0.0.0 0.0.0.0 40.0.0.1


************************************************


R2:

interface Ethernet0/0.10
encapsulation dot1Q 10
ip address 20.0.0.3 255.255.255.0
!
router eigrp 10
network 20.0.0.3 0.0.0.0
redistribute static metric 10000 1 255 1 1500
no auto-summary
!
ip default-network 192.168.9.0
ip route 192.168.9.0 255.255.255.0 40.0.0.2


************************************************

R3:

interface Ethernet0/0.10
encapsulation dot1Q 10
ip address 20.0.0.1 255.255.255.0
!
router eigrp 10
network 20.0.0.1 0.0.0.0

In R2's routing table:

S*    0.0.0.0/0 [1/0] via 40.0.0.2

      1.0.0.0/32 is subnetted, 1 subnets

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        20.0.0.0/24 is directly connected, Ethernet0/0.10
L        20.0.0.3/32 is directly connected, Ethernet0/0.10

      40.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        40.0.0.0/30 is directly connected, Ethernet0/1

L        40.0.0.1/32 is directly connected, Ethernet0/1

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        20.0.0.0/24 is directly connected, Ethernet0/0.10

L        20.0.0.1/32 is directly connected, Ethernet0/0.10     

S*    192.168.9.0/24 [1/0] via 40.0.0.2

In R3's routing table:

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/24 is directly connected, Ethernet0/0.10
L        20.0.0.1/32 is directly connected, Ethernet0/0.10

D*EX  192.168.9.0/24 [170/281856] via 20.0.0.3, 00:10:27, Ethernet0/0.10

Then, when I try to ping on R3 the 9.9.9.9 it's not possible.

If I dabuging "debug ip packet detail"

*Nov 21 01:32:47.727: FIBipv4-packet-proc: route packet from (local) src 0.0.0.0 dst 9.9.9.9
*Nov 21 01:32:47.727: FIBfwd-proc: Default:0.0.0.0/0 proces level forwarding
*Nov 21 01:32:47.727: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)
*Nov 21 01:32:47.727: FIBfwd-proc: try path 0 (of 1) v4-sp first short ext 0(-1)
*Nov 21 01:32:47.727: FIBfwd-proc: v4-sp valid
*Nov 21 01:32:47.727: FIBfwd-proc:  no nh type 8  - deag
*Nov 21 01:32:47.727: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if none nh none deag 1 via fib 0 path type special prefix
*Nov 21 01:32:47.727: FIBfwd-proc: Default:0.0.0.0/0 not enough info to forward via fib (none none)
*Nov 21 01:32:47.727: FIBipv4-packet-proc: packet routing failed
*Nov 21 01:32:47.727: IP: s=0.0.0.0 (local), d=9.9.9.9, len 100, unroutable
*Nov 21 01:32:47.727:     ICMP type=8, code=0

It saids the packet routing failed.

Maybe somebody can help me with this.

  • LAN Switching and Routing
5 REPLIES
VIP Super Bronze

EIGPR IP default-network

On r2, you do not have a static route to 9,9,9,9

ip default-network 192.168.9.0

ip route 192.168.9.0 255.255.255.0 40.0.0.2

you need to add it and then try again

ip route .9.9.9.9 255.255.255.255 40.0.0.2

HTH

New Member

EIGPR IP default-network

The problem is not on R2. I can ping 9.9.9.9 on that router.

On R3 this route should work as a last resort

D*EX 192.168.9.0/24 [170/281856] via 20.0.0.3, 00:10:27, Ethernet0/0.10

But it dosn't work.

On R2 I have a default route that was created when I set the command "ip default-network 192.168.9.0". This is another question, I haven't seen in the theory that a default route should be created in the routing table when you set that command.

I mean this route should be in the routing table as a last resort

S* 192.168.9.0/24 [1/0] via 40.0.0.2

But I haven't seen that the default route should appear in the routing table

S* 0.0.0.0/0 [1/0] via 40.0.0.2

EIGPR IP default-network

Hi,

If you look at R3 routing table, it doesn't have any route to 9.9.9.9 or even 0.0.0.0

So either you need to redistribute default route on R2 in eigrp or else, you need to configure default static route on R3 to make it work.

HTH,

Smitesh

New Member

EIGPR IP default-network

There are different methods to configure a gateway for last resort. Here you can find some examples: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

The idea is to redistribute the default route using the "ip deafult-network" command.

New Member

EIGPR IP default-network

I tried with another simulator (GNS3) and it works. The problem was the simulator.

Answer to my questions:

R3:

D*EX 192.168.9.0/24 [170/281856] via 20.0.0.3, 00:10:27, Ethernet0/0.10

This route is used as the last resort so the ping to 9.9.9.9 works.

R2 shouldn't install a default route (0.0.0.0/0) in the routing table.

I did the simulation in the GNS3 with an IOS 12.2(46a).

578
Views
0
Helpful
5
Replies
This widget could not be displayed.