Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP and BGP routing help

Hello Everyone, i am looking for some help to get eigrp routes to take precedense of eigrp routes.

I have an adtran distributing bgp routes from my mpls to a cisco c1700 which is also recieving eigrp routes from my cisco 2600 over my point to point connection point to point connection

my issue is when there is a slight hickup in the PTP line my bgp routes are taking precedence from my adtran to my c1700 over writing my eigrp from c2600 to c1700.  i need to make my c2600 eigrp routes take precedence over bgp and the only why i can get this to reset is to reload my c1700.

any help on this would be appreciated

my cisco 2600 is config like this for eigrp:

router eigrp 100

network 10.0.0.0

network 192.168.4.0

no auto-summary

my cisco 1700 is bgp and eigrp:

router eigrp 100

redistribute bgp 65005 metric 1500 20 255 1 1500

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

router bgp 65005

no synchronization

bgp log-neighbor-changes

redistribute eigrp 100

neighbor 10.43.144.2 remote-as 65001

neighbor 10.43.144.2 soft-reconfiguration inbound

neighbor 10.43.144.2 distribute-list trc-in in

neighbor 10.43.144.2 distribute-list trc-out out

no auto-summary

my adtran is

router bgp 65001

  no auto-summary

  no synchronization

  network 10.43.144.0 mask 255.255.240.0

  network 192.168.1.0 mask 255.255.255.0

  redistribute static

  redistribute connected

  neighbor 10.43.144.1

    no default-originate

    soft-reconfiguration inbound

    update-source loop 11

    remote-as 65000

  neighbor 10.43.144.4

    no default-originate

    soft-reconfiguration inbound

    remote-as 65005

4 REPLIES

EIGRP and BGP routing help

Your problem is that the cost of the routes received by the 2600 is higher then the routes redistributed from BGP.

So check the metric of the routes received in normal times by the 2600 , and use a number higher then this metric when you redistribute from BGP.

Regards

Dan

Silver

EIGRP and BGP routing help

Please decrease the "delay" metric on the interface to make EIGRP route preferred over the BGP route.

run show interface command and note down the delay value in both the interfaces which is like this : DLY 1000 usec.

then run a command like this :

NJ-R2#config t

Enter configuration commands, one per line. End with CNTL/Z.

NJ-R2(config)#int fa0/0

NJ-R2(config-if)#delay 100

NJ-R2(config-if)#

Hope it helps. Delay is preffered metric to play with in EIGRP versus Bandwidth.

---

Posted by WebUser Neeraj Jagga from Cisco Support Community App

New Member

EIGRP and BGP routing help

Thanks for getting back to me.

Do i perform the dely reconfig on the 1700 or 2600?

my dely for ser0/0 is 2000 usec and fa0/0 100 usec for both 1700 and 2600

Bronze

Re: EIGRP and BGP routing help

Is the prefix learned as an external route over the PTP link? Are you redistributing EIGRP Into BGP as well? There could be multiple factors at work here. Could you supply the output of "show ip eigrp topo " for the prefix in question both with it working and with it broken?

Sent from Cisco Technical Support iPad App

611
Views
0
Helpful
4
Replies
CreatePlease to create content