Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EIGRP and Internet Help..

     Home+Network.jpg

I am having two small issues....

First on my

3745 i get the following message:

*Mar  2 12:13:13.615: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.3.1 not on common subnet for FastEthernet0/1

*Mar  2 12:13:25.811: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.2.1 not on common subnet for FastEthernet0/1

Second problem is that I have my internet connection going to the 3640 on FE0/0 and it works just fine....I want to change over and have the 3745 be the internet router, but when I configure it, I get no connection.

3745 -

Current configuration : 1624 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.150

!

ip dhcp pool 192.168.1.0/24

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

username woodjl1650 privilege 15 password 0 henry999

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.6 255.255.255.252

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

!

!

ip http server

ip http authentication local

no ip http secure-server

ip nat inside source list 15 interface FastEthernet0/0 overload

!

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

webvpn cef

!

end

3640 -

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.9 255.255.255.252

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

ip address 10.0.1.5 255.255.255.252

!

interface Ethernet1/0

ip address 192.168.4.10 255.255.255.252

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

network 192.168.2.0

no auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

2610 -

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash

boot-end-marker

!

no logging on

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.150

!

ip dhcp pool 192.168.3.0/24

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 10.0.1.10 255.255.255.252

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 1

network 10.0.0.0

network 192.168.3.0

no auto-summary

!

no ip http server

ip classless

!

!

snmp-server community public RO

snmp-server community private RW

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

Thanks in advance for the help....

Everyone's tags (2)
6 REPLIES
Cisco Employee

EIGRP and Internet Help..

Hi Jon,

The first issue with EIGRP complaining about its neighbors not being on the same subnet is obvious: the problem is here indicated very clearly. You have connected three routers on a common network but their IP addresses are not from a single common subnet. Correctly, the 3745 should be 192.168.1.1/24, the 3640 should be 192.168.1.2/24 and the 2610 should be192.168.1.3/24 - or any other addressing where all three routers use IP addresses from a single common subnet.

Regarding the issues with internet connectivity - it is not clear where the PCs are connected, where is the internet access located, and what address space the clients use. Can you update the picture with this information?

Best regards,

Peter

New Member

EIGRP and Internet Help..

Ok, I think I changed the IP scheme correctly.  My question is no what router will be the devices get there IP address from?  I had each router on a different subnet to act like seperate router for each network. Each router was/is connected to each other by serial connection and I was able to ping and access them that way.  I still can, but now I have different IP address.  I guess I am a little confused on what router will issue IP address. Since they have the same subnet are they still seperate routers and have their own pool to release IP address?

Running configs:

3640-Internet#show run

Building configuration...

Current configuration : 1851 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.9 255.255.255.252

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

ip address 10.0.1.5 255.255.255.252

!

interface Ethernet1/0

ip address 192.168.4.10 255.255.255.252

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.0.0.0

network 192.168.2.0

no auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

3745-Internet#show run

Building configuration...

Current configuration : 1614 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3745-Internet

!

boot-start-marker

boot-end-marker

!

no logging on

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool 192.168.2.3/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.3

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

ip domain name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

username woodjl1650 privilege 15 password 0 henry999

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.6 255.255.255.252

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.2.3 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 10.0.0.0

network 192.168.2.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 192.168.2.1

!

!

ip http server

ip http authentication local

no ip http secure-server

ip nat inside source list 15 interface FastEthernet0/0 overload

!

access-list 15 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

webvpn cef

!

end

Router#show run

Building configuration...

Current configuration : 1019 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash

boot-end-marker

!

no logging on

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip dhcp pool 192.168.2.4/24

   network 192.168.2.0 255.255.255.0

!

ip dhcp pool 192.168.3.1

   default-router 192.168.3.1

!

ip dhcp pool 192.168.2.4

   default-router 192.168.2.4

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface Ethernet0/0

ip address 192.168.2.4 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 10.0.1.10 255.255.255.252

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 1

network 10.0.0.0

network 192.168.2.0

no auto-summary

!

no ip http server

ip classless

!

!

snmp-server community public RO

snmp-server community private RW

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

New Member

EIGRP and Internet Help..

Jon ,

As per Peter's suggestion we need to correct the network ip addressing. To become Eigrp neighbor we need to have a single common subnet. Once that being corrected , look into the Eigrp process for 2610 ...once you decide the common subnet , that needs to be advertised here as well...

Looking forward...

Regards,

Hriday

Hall of Fame Super Silver

EIGRP and Internet Help..

I have a couple of things that I notice and hope tht Jonathan may clarify for us.

- I do not see any of the routers with a configured default route. So how are the routers learning a default route?

- what are you doing to switch the internet connection from the 3640 to the 3745?

- both the 3640 and the 3745 have configured address translation. But each of them uses an access list to control the translation that permits only a single locally connected network. How is internet working if the addresses are not translated?

HTH

Rick

New Member

EIGRP and Internet Help..

From what was said above, I changed the IP Scheme so that all routers are on the same subnet.  To answer the question how I am moving the internet from the 3640 to the 3745, I configured the FE0/0 on the 3745 the same way it is configured on the 3640 and moved the ethernet cable the the 3745...but no connection.

Hall of Fame Super Silver

EIGRP and Internet Help..

Jonathan

What is the router connecting to on its Fe0/0? I have seen some situations, particularly with things like cable modems, where they do not like to change connected devices and sometimes we need to power cycle the cable modem to get it to work with a new connection. Perhaps your problem is something like that?

HTH

Rick

1474
Views
0
Helpful
6
Replies