Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP continually flapping

This is the message that I am getting from my 1941w router. I have a isakmp tunnel built with a GRE tunnel going through it. I keep getting the following message, continously.

Nov 16 08:58:09.352 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 08:59:47.361 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 08:59:51.217 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:01:27.230 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:01:27.782 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:03:03.792 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:03:04.372 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:04:40.381 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:04:40.909 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:06:13.774 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:06:18.282 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:07:54.296 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:07:58.436 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

Nov 16 09:09:29.521 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is down: Interface PEER-TERMINATION received

Nov 16 09:09:30.233 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.20.255.97 (Tunnel31) is up: new adjacency

The other end of the device is a 2801 router and it doesnt show anything in the logs. Anyone have any ideas? Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Sorry - I was referring to

Sorry - I was referring to the tunnel transport MTU. Are all your physical links in between the two tunnels based on 1500MTU? If so....

You can first try using this on both sides under your tunnel interfaces (make sure that your physical interface is 1500, if it's Ethernet, the default should be 1500 unless it was globally changed).

Under tunnel interfaces:

 ip tcp adjust-mss 1376
 tunnel path-mtu-discovery

ip mtu 1400

 

You only need 1 of the last 2 commands but Cisco recommends putting them both...

Here's a good document although it's a bit 'lengthy' : http://www.cisco.com/c/en/us/support/docs/ip/generic-routing-encapsulation-gre/25885-pmtud-ipfrag.html

25 REPLIES
Purple

EIGRP continually flapping

Hi,

can you post output of following command:

debug eigrp packet

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: EIGRP continually flapping

Here is the result.

Hall of Fame Super Silver

EIGRP continually flapping

What can you tell us about the router on the other end of the tunnel?

It looks to me like the problem is not on your router but is on the router at the other end of the tunnel.

To me the most significant part of the output that you posted is this

(Tunnel31) is down: Interface PEER-TERMINATION received

What I think is happening is this:

- your router sends a hello over the tunnel.

- your router receives a hello over the tunnel from the other router.

- your router adds the new neighbor.

- your router receives a PEER-TERMINATION from the other router and tears down the neighbor relationship.

So why is the other router sending the PEER-TERMINATION? When we find the answer to that we will know what the problem is.

HTH

Rick

New Member

Re: EIGRP continually flapping

It is a 2801 running 12.4(5a).

It currently has 10 other vpn tunnels connected to it, and they are not having the same problem.

Here is what I think is the relative config.

FLOH-2801-001#show run | section eigrp

router eigrp 1

network 172.20.0.0

network 172.21.0.0

maximum-paths 1

default-metric 128 344 200 200 200

no auto-summary

no eigrp log-neighbor-changes

neighbor 172.20.255.98 Tunnel21018

snmp-server enable traps eigrp

FLOH-2801-001#show run int tunnel 21018

Building configuration...

Current configuration : 214 bytes

!

interface Tunnel21018

description T-SATX-108

ip address 172.20.255.97 255.255.255.252

ip mtu 1500

ip route-cache flow

keepalive 10 3

tunnel source 172.20.240.31

tunnel destination 172.21.100.18

end

Re: EIGRP continually flapping

Hi,

I would probably have started with some eigrp debugging on your 2801 router to see whats actually happening.

Sent from Cisco Technical Support iPad App

New Member

Hello, My issue was due to

Hello,

 

My issue was due to MTU sizing not matching. EIGRP will try to use the highest MTU size supported on the link for sending it's routing table when neighbor adjacency is first brought up. If the MTU size is too large for the ANY link in between the two peers, the packet/frame will be dropped causing the peer to not receive any routes...this causes a peer-termination since it isn't getting an acknowledgement of the routing updates it sent...hope this helps.

 

I would also check to make sure your tcp segment sizing is correct - ip tcp adjust-mss xx (usually you want to set it to the same size as your MTU or a little smaller if I'm not mistaken but I would recommend researching this and seeing what your tunnel needs/is using from MTU and MSS since GRE/IPsec all have their own overheads and increase size since they're encapsulating.

New Member

Dear Joshua, Thanks for

Dear Joshua,

 

Thanks for getting back with your views. In our case the tunnel has got an MTU size of 17984, so do we reduce this same as to the physical interface level,or do we reduce it to a value around 14k.

 

Thanks in advance

New Member

Sorry - I was referring to

Sorry - I was referring to the tunnel transport MTU. Are all your physical links in between the two tunnels based on 1500MTU? If so....

You can first try using this on both sides under your tunnel interfaces (make sure that your physical interface is 1500, if it's Ethernet, the default should be 1500 unless it was globally changed).

Under tunnel interfaces:

 ip tcp adjust-mss 1376
 tunnel path-mtu-discovery

ip mtu 1400

 

You only need 1 of the last 2 commands but Cisco recommends putting them both...

Here's a good document although it's a bit 'lengthy' : http://www.cisco.com/c/en/us/support/docs/ip/generic-routing-encapsulation-gre/25885-pmtud-ipfrag.html

New Member

Hi ALL  I found the Correct

Hi ALL 

 

I found the Correct  solution 

 

The Solution  is  remove ip nhrp map multicast dynamic and add static multicast mapping to the real interface IP not the tunnel IP . IT worked Bingo 

Hall of Fame Super Silver

EIGRP continually flapping

Thanks for the additional information. I find it interesting that it looks like the remote router has specified an EIGRP neighbor for this router. Would I be correct in assuming that this is the only neighbor for which it has done this?

If so then I believe that we shoud investigate why the remote neighbor did this for one neighbor and not for others.

I would also be interesting to know what would be the result if you configured your router with an EIGRP neighbor statement for this remote neighbor.

HTH

Rick

I have the similar problem ,

I have the similar problem , changed mtu to 1400 , increased EIGRP hello and hold timers still flapping. Question is : are these mtu and EIGRP hello/hold parameters must be changed on both sides hub-and-spoke  ? must they be equal on both sides ?

Hall of Fame Super Silver

While I believe that it would

While I believe that it would be advisable to have the hold time and hello time parameters match at both ends it is not required. EIGRP should run just fine with different settings for the hold time and hello time.

 

It would be more important that the MTU setting match at both ends.

 

HTH

 

Rick

New Member

Doesn't have to be the same

Doesn't have to be the same on both sides

On your HUB change MTU to 1300, adjust-mss to 1260 on the tunnel interface, not the physical interface

EIGRP is pushing lots of route updates

give it 15 minutes and then up the MTU and adjust mss again

 

I prefer to leave it at :

ip mtu 1390

ip tcp adjust-mss 1350

 

Had a case where the EIGRP neighbor relationship was unstable between 2 Spokes and a Hub (Point-2-Point IPSEC over GRE with EIGRP)

set mtu to 1300

adjust-mss to 1260

problem went away immediately

changed it back to preferred after a few minutes and it was still stable

EIGRP continually flapping

Hi,

My thoughts here. You are using GRE tunnels and by default GRE allocates 9kbps BW for the routing protocol traffic and EIGRP uses 50% of that to send its hellos,updates etc. I believe in this case the BW is not enough on the tunnel for this traffic and hence you are seeing the flapping. Please use the physical interface bandwidth using the "bandwidth < bandwidth> on the tunnel interface and see if helps.

for example if you are using gigethernet then just put the command bandwidth 1000000 on the tunnel interface at both ends and see if that helps.

you can also see the load on the tunnel interfaces as well. do a sh int tunnel 21018 and you should be able to see the load on the interface. it should look something like X/255  where X is the load.

Also you might want to change the ip mtu to 1476 so that the packets dont get fragmented.

Regards,

Kishore

Cisco Employee

EIGRP continually flapping

You are advertising the tunnel source in the eigrp statement.   If this is the preferred route on the remote end you end up with recursive routing.  Recommended to remove "network 172.20.0.0" and put in 172.20.255.96 0.0.0.3 so you are not advertising the tunnel source through the tunnel routing protocol.

Dan

New Member

EIGRP continually flapping

I had a similar problem and got it resolved..

On the dmvpn spoke, (GRE over ipsec) the tunnel was continually flapping.

the public ip address on the dmvpn spoke is 99.X.X.X

Upon debug I realized that there is a static route on the peer (hub router) poining to 99.x.x.x which is again redistributed into eigrp..so spoke router is now having this as a local route as well as a route redistributed via eigrp ..so it was falpping..

i fixed this by implementing a block route-map..

hope this helps...

Regards Vinayak
New Member

EIGRP continually flapping

What I did to fix my issue that I was having above was to lower my MTU on the tunnel interface. After I changed that to 1400 everything else has worked smoothly.

Cisco Employee

EIGRP continually flapping

Hello,

Oh yes - that's yet another issue to have in mind - large routing tables compounded with MTU issues on tunnel interfaces. Thanks for sharing and reminding us of that!

Best regards,

Peter

New Member

EIGRP continually flapping

Hi Guys !

I got DUAL-5-NBRCHANGE error after I turn up a site to MPLS network, could you help me with that please ?

Feb  1 11:35:12.008 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.74 (Tunnel18) is down: holding time expired

Feb  1 11:50:01.486 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.74 (Tunnel18) is up: new adjacency

Feb  1 19:25:50.005 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 10.1.150.6 (GigabitEthernet8/33) is down: interface down

Feb  1 19:26:03.742 Central: %SYS-5-CONFIG_I: Configured from console by mgriffin on vty0 (10.1.211.93)

Feb  1 19:29:12.434 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 10.1.150.6 (GigabitEthernet8/33) is up: new adjacency

Feb  1 19:33:40.546 Central: %SYS-5-CONFIG_I: Configured from console by mgriffin on vty0 (10.1.211.93)

Feb  1 21:31:38.013 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.66 (Tunnel16) is down: Interface PEER-TERMINATION received

Feb  1 21:31:41.509 Central: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(512) 1: Neighbor 192.168.201.66 (Tunnel16) is up: new adjacency

Cisco Employee

EIGRP continually flapping

Majid,

The reason may very well be similar to the issues already described in this thread. Have you carefully went each suggestion posted here so far and made sure that none of them applies to you? In particular, are you sure you do not advertise the network in which the tunnel endpoint resides through the EIGRP running over that tunnel?

Best regards,

Peter

New Member

EIGRP continually flapping

Here is my MTU size!

Core site, MTU Size on tunnel interface =17868 and customer tunnel MTU size = 1514, so what do you think ?

New Member

EIGRP continually flapping

I set mine at 1400, but how I got there was through trial and error. I was at 1514, adjusted it to 1300 and it worked better. Then i slowly workd my way up the chain to find out where the stable point is and left it ther.

New Member

I have the same error, what I

I have the same error, what I can do?

 

1y13w: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.20.250 (Vlan2) is up: new adjacency
1y13w: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.20.250 (Vlan2) is down: holding time expired

Hall of Fame Super Silver

Perhaps you can give us some

Perhaps you can give us some more information about your environment? How often does this happen?

 

The error message indicates that holding time expired. This means that you have established a neighbor relationship, that you have sent EIGRP packets to the neighbor and the neighbor has not responded.  The holding time is the amount of time that you wait for a response. So there is a possibility that the real issue may be on the neighbor and not on your router.

 

HTH

 

Rick

New Member

Dear Members, Do we have a

Dear Members,

 

Do we have a solution for the same as we faced the same issue wherein the tunnel keeps flapping with the same error message, however there is no downtime reported. Please advise what to do

47566
Views
14
Helpful
25
Replies
CreatePlease to create content