cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
898
Views
0
Helpful
9
Replies

EIGRP default network or route

maninthemirrow
Level 1
Level 1

hello friends, l have an issue here with EIGRP default route.

this is my home lap which am working on but something is not working.

from window XP7 on the far left if l ping the loopback addresses on the ISP it works fine but if l tracert e.g 2.2.2.2 which is not a valid loopback it will go to the ISP then back to RII and back to ISP untill it reaches the 30 hops.

is this the normal behaviour or it has to stop when it realize there is no such IP addresss.

if you look at the design everything works fine, or l have misconfigure the default-network on the router R11 and ISP.

router ISP

interface Loopback1

ip address 199.68.10.1 255.255.255.0

!

interface Loopback2

ip address 177.35.6.8 255.255.255.0

!

interface Loopback3

ip address 68.10.25.1 255.255.255.0

!

interface Loopback4

ip address 1.1.1.1 255.0.0.0

interface Serial0/0

ip address 192.10.25.2 255.255.255.0

clock rate 2000000

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.10.25.1

!

R11

interface FastEthernet0/0

ip address 10.9.1.34 255.255.255.252

speed 100

full-duplex

!

interface Serial0/0

ip address 192.10.25.1 255.255.255.0

clock rate 2000000

!

router eigrp 100

network 10.0.0.0

network 192.10.25.0

auto-summary

!

ip default-network 192.10.25.0

ip route 0.0.0.0 0.0.0.0 192.10.25.2

!

Core2 {this connect to the whole network}

interface FastEthernet1/11

no switchport

ip address 10.9.1.22 255.255.255.252

duplex full

speed 100

!

interface FastEthernet1/12

no switchport

ip address 10.9.1.29 255.255.255.252

duplex full

speed 100

!

interface FastEthernet1/13

no switchport

ip address 10.9.1.10 255.255.255.252

duplex full

speed 100

!

interface FastEthernet1/15

no switchport

ip address 10.9.1.33 255.255.255.252

duplex full

speed 100

!

router eigrp 100

network 0.0.0.0

no auto-summary

!

sho commands

ISP#SHO IP ROUTe

Gateway of last resort is 192.10.25.1 to network 0.0.0.0

     68.0.0.0/24 is subnetted, 1 subnets

C       68.10.25.0 is directly connected, Loopback3

C    1.0.0.0/8 is directly connected, Loopback4

C    199.68.10.0/24 is directly connected, Loopback1

C    192.10.25.0/24 is directly connected, Serial0/0

     177.35.0.0/24 is subnetted, 1 subnets

C       177.35.6.0 is directly connected, Loopback2

S*   0.0.0.0/0 [1/0] via 192.10.25.1

ISP#

R11#sho ip route

Gateway of last resort is 192.10.25.2 to network 0.0.0.0

design.PNG

C*   192.10.25.0/24 is directly connected, Serial0/0

     10.0.0.0/8 is variably subnetted, 20 subnets, 5 masks

D       10.11.1.0/24 [90/3852800] via 10.9.1.33, 02:12:36, FastEthernet0/0

D       10.9.1.4/30 [90/33280] via 10.9.1.33, 02:12:32, FastEthernet0/0

D       10.12.1.0/24 [90/3875840] via 10.9.1.33, 02:12:38, FastEthernet0/0

D       10.9.1.8/30 [90/30720] via 10.9.1.33, 02:12:39, FastEthernet0/0

D       10.0.0.0/24 [90/33280] via 10.9.1.33, 02:12:34, FastEthernet0/0

D       10.0.0.0/8 is a summary, 00:26:31, Null0

D       10.9.1.12/30 [90/33280] via 10.9.1.33, 02:12:33, FastEthernet0/0

D       10.9.1.16/30 [90/30720] via 10.9.1.33, 02:12:40, FastEthernet0/0

D       10.9.1.20/30 [90/30720] via 10.9.1.33, 02:12:40, FastEthernet0/0

D       10.16.2.0/24 [90/158720] via 10.9.1.33, 02:12:35, FastEthernet0/0

D       10.16.3.0/24 [90/158720] via 10.9.1.33, 02:12:35, FastEthernet0/0

D       10.9.1.24/30 [90/33280] via 10.9.1.33, 02:12:35, FastEthernet0/0

D       10.16.1.0/24 [90/158720] via 10.9.1.33, 02:12:35, FastEthernet0/0

D       10.16.4.0/24 [90/158720] via 10.9.1.33, 02:12:35, FastEthernet0/0

D       10.9.1.28/30 [90/30720] via 10.9.1.33, 02:12:40, FastEthernet0/0

C       10.9.1.32/30 is directly connected, FastEthernet0/0

D       10.17.35.0/25 [90/158720] via 10.9.1.33, 02:12:33, FastEthernet0/0

D       10.17.34.0/24 [90/158720] via 10.9.1.33, 02:12:33, FastEthernet0/0

D       10.17.32.0/23 [90/158720] via 10.9.1.33, 02:12:33, FastEthernet0/0

D       10.17.35.128/25 [90/158720] via 10.9.1.33, 02:12:34, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 192.10.25.2

R11#

2 Accepted Solutions

Accepted Solutions

devils_advocate
Level 7
Level 7

2.2.2.2 is not a valid route in the routing table of R11 so it sends the packet to its default route which is 192.10.25.2.

192.10.25.2 is the Serial interface on the ISP router.

The ISP router looks at its routing table and finds no route so forwards the packet to its default route which is 192.10.25.1.

192.10.25.1 is the Serial interface on R11.

Then R11 does the same thing again so you have a routing loop so to spreak. The ISP router is looping any packets which match the default route back the way they came, i.e back to R11.

View solution in original post

It is expected behaviour for your network setup but in the real world this would not happen because the ISP would not have a default route pointing back to your router.

So there is nothing wrong with your config other than the fact it does not represent what would happen if you were actually connnected to an ISP.

Jon

View solution in original post

9 Replies 9

devils_advocate
Level 7
Level 7

2.2.2.2 is not a valid route in the routing table of R11 so it sends the packet to its default route which is 192.10.25.2.

192.10.25.2 is the Serial interface on the ISP router.

The ISP router looks at its routing table and finds no route so forwards the packet to its default route which is 192.10.25.1.

192.10.25.1 is the Serial interface on R11.

Then R11 does the same thing again so you have a routing loop so to spreak. The ISP router is looping any packets which match the default route back the way they came, i.e back to R11.

hello

this is what l was thinking when l traceroute the 2.2.2.2. is this the normal behaviour?

what if ISP is real then it will drop the packet.

what l want to know again if my configuration is correct.

thank you in advance

It is expected behaviour for your network setup but in the real world this would not happen because the ISP would not have a default route pointing back to your router.

So there is nothing wrong with your config other than the fact it does not represent what would happen if you were actually connnected to an ISP.

Jon

thank you very much

hello friends

other question on the same topology. l use prefix-list on WAN2 and WAN1 to block all IP addresses with /30 from displaying on the BRANCH routers. then l enable debug on the WAN2 and it keep getting the message which l dont know what it means

can some explain to me what that NET-RED means and why am getting the message

Hi,

This is when the router adds or deletes route entries in the routing table.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

so what does the NET-RED means in plan english and why does it keep printing on the console?. it has been deleted  or added already.the prefix list has done it job by blocking the /30. but this message keep printing on the console means the can consume some bandwidth in real network.

thanks

Hi,

The message you get is about a /24 not a /30.

How often do you see this message ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hello l created a prefix list blocking all /30 and the message every minute.

this the prefix list code

the message is every mins

do you think it is normal please if it comes down to every mins.

thanks in advance

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: