Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

eigrp does not advertise external routes

 

I have got 2 switches facing to each other through an L3 etherchannel:

SW4(config-if)#do sh ip eigrp nei
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   155.1.108.8             Po1               10 02:57:52    1   200  0  66

 

SW2(config-if)#do sh ip eig nei
EIGRP-IPv4:(10) neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   155.1.58.5              Vl58              11 02:36:13    9   200  0  72
0   155.1.108.10            Po1               12 02:58:52    1   200  0  36

 

The port channel is woking fine:

on SW2:

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)          -        Fa0/19(P)   Fa0/20(P)   

 

and on SW4:

 

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)          -        Fa0/16(P)   Fa0/17(P)   

 

SW2 receives eigrp external routes from Vlan 58:

 

SW2(config-if)#do sh ip route | i EX
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
D EX 204.12.1.0/24 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    4.4.1.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    4.4.2.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    4.4.3.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    31.3.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    31.2.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    31.1.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    31.0.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    30.2.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    30.3.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    30.0.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58
D EX    30.1.0.0 [170/2560512512] via 155.1.58.5, 01:20:02, Vlan58

This routing table matches what's in the eigrp topology: 

SW2(config-if)#do sh ip eig top
EIGRP-IPv4 Topology Table for AS(10)/ID(150.1.8.8)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 155.1.5.0/24, 1 successors, FD is 28416
        via 155.1.58.5 (28416/28160), Vlan58
P 155.1.13.3/32, 1 successors, FD is 2682112
        via 155.1.58.5 (2682112/2681856), Vlan58
P 155.1.45.0/24, 1 successors, FD is 2170112
        via 155.1.58.5 (2170112/2169856), Vlan58
P 150.1.8.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 30.3.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 150.1.10.0/24, 1 successors, FD is 143360
        via 155.1.108.10 (143360/128256), Port-channel1
P 155.1.23.0/24, 1 successors, FD is 2682112
        via 155.1.58.5 (2682112/2681856), Vlan58
P 30.1.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 155.1.108.0/24, 1 successors, FD is 15360
        via Connected, Port-channel1
P 4.4.2.0/24, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 31.0.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 31.3.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 150.1.2.0/24, 1 successors, FD is 2298112
        via 155.1.58.5 (2298112/2297856), Vlan58
P 30.0.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 204.12.1.0/24, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 150.1.5.0/24, 1 successors, FD is 130816
        via 155.1.58.5 (130816/128256), Vlan58
P 155.1.13.1/32, 1 successors, FD is 21024256
        via 155.1.58.5 (21024256/21024000), Vlan58
P 155.1.8.0/24, 1 successors, FD is 2816
        via Connected, Vlan8
P 155.1.23.2/32, 1 successors, FD is 21024256
        via 155.1.58.5 (21024256/21024000), Vlan58
P 31.2.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 192.10.1.0/24, 1 successors, FD is 2172672
        via 155.1.58.5 (2172672/2172416), Vlan58
P 155.1.10.0/24, 1 successors, FD is 15616
        via 155.1.108.10 (15616/2816), Port-channel1
P 31.1.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 155.1.58.0/24, 1 successors, FD is 2816
        via Connected, Vlan58
P 155.1.23.3/32, 1 successors, FD is 2682112
        via 155.1.58.5 (2682112/2681856), Vlan58
P 155.1.45.4/32, 1 successors, FD is 2170112
        via 155.1.58.5 (2170112/2169856), Vlan58
P 4.4.1.0/24, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 155.1.0.0/24, 1 successors, FD is 2170112
        via 155.1.58.5 (2170112/2169856), Vlan58
P 155.1.13.0/24, 1 successors, FD is 2682112
        via 155.1.58.5 (2682112/2681856), Vlan58
P 4.4.3.0/24, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58
P 30.2.0.0/16, 1 successors, FD is 2560512512
        via 155.1.58.5 (2560512512/2560512256), Vlan58

but external routes are not advertised to SW4:

 

SW4(config-if)#do sh ip route | i EX
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

 

Neither they are in the topology:

SW4(config-if)#do sh ip eigr topolo
EIGRP-IPv4 Topology Table for AS(10)/ID(150.1.4.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 155.1.5.0/24, 1 successors, FD is 30976
        via 155.1.108.8 (30976/28416), Port-channel1
P 155.1.13.3/32, 1 successors, FD is 2684672
        via 155.1.108.8 (2684672/2682112), Port-channel1
P 155.1.45.0/24, 1 successors, FD is 2172672
        via 155.1.108.8 (2172672/2170112), Port-channel1
P 150.1.8.0/24, 1 successors, FD is 143360
        via 155.1.108.8 (143360/128256), Port-channel1
P 150.1.10.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 155.1.23.0/24, 1 successors, FD is 2684672
        via 155.1.108.8 (2684672/2682112), Port-channel1
P 155.1.108.0/24, 1 successors, FD is 15360
        via Connected, Port-channel1
P 150.1.2.0/24, 1 successors, FD is 2300672
        via 155.1.108.8 (2300672/2298112), Port-channel1
P 150.1.5.0/24, 1 successors, FD is 143616
        via 155.1.108.8 (143616/130816), Port-channel1
P 155.1.13.1/32, 1 successors, FD is 21026816
        via 155.1.108.8 (21026816/21024256), Port-channel1
P 155.1.8.0/24, 1 successors, FD is 15616
        via 155.1.108.8 (15616/2816), Port-channel1
P 155.1.23.2/32, 1 successors, FD is 21026816
        via 155.1.108.8 (21026816/21024256), Port-channel1
P 192.10.1.0/24, 1 successors, FD is 2175232
        via 155.1.108.8 (2175232/2172672), Port-channel1
P 155.1.10.0/24, 1 successors, FD is 2816
        via Connected, Vlan10
P 155.1.58.0/24, 1 successors, FD is 15616
        via 155.1.108.8 (15616/2816), Port-channel1
P 155.1.23.3/32, 1 successors, FD is 2684672
        via 155.1.108.8 (2684672/2682112), Port-channel1
P 155.1.45.4/32, 1 successors, FD is 2172672
        via 155.1.108.8 (2172672/2170112), Port-channel1
P 155.1.0.0/24, 1 successors, FD is 2172672
        via 155.1.108.8 (2172672/2170112), Port-channel1
P 155.1.13.0/24, 1 successors, FD is 2684672
        via 155.1.108.8 (2684672/2682112), Port-channel1

 

I removed Po1 and used a simple routed switchport instead (sw2-fa0/21 facing sw4-fa0/18), but the problem remains. I do not understand why. Furthermore, I have already used the same architecture and it was fine, all the external were advertised on SW4, but after quite a long time.
          

 

 

2 REPLIES
New Member

I have been told it was it's

I have been told it was it's a duplicate router-id issue:

Purple

Hi,SW2(config-if)#do sh ip

Hi,

SW2(config-if)#do sh ip eig top
EIGRP-IPv4 Topology Table for AS(10)/ID(150.1.8.8)

 

SW4(config-if)#do sh ip eigr topolo
EIGRP-IPv4 Topology Table for AS(10)/ID(150.1.4.4)

 

As you can see the EIGRP RIDs are different.

Can you issue following command on SW4: sh ip eigrp neigh detail  to see if SW2 is not a stub device

What is the model and image version for the switches ?

 

Regards

 

Alain

Don't forget to rate helpful posts.
67
Views
0
Helpful
2
Replies
CreatePlease login to create content