Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP dont'n redistribute routes into OSPF

R1 FE0/3/0 and R2 FE0/1/0 directly connected. Route to 192.168.255.4/32 dont't present in routing table (RT) on R2 with next-hop R1-interface (FE0/3/0, 172.16.255.254). Why?

----------------------------------------------------------

R1:

----------------------------------------------------------

!

interface FastEthernet0/3/0

ip address 172.16.255.254 255.255.255.252

ip nat enable

duplex auto

speed auto

!

interface Tunnel1011

...

ip summary-address eigrp 1 10.0.0.0 255.0.0.0

ip summary-address eigrp 1 192.168.255.0 255.255.255.0

...

!

router eigrp 1

network 172.17.0.0

redistribute bgp 65000

redistribute ospf 1 match external 1

passive-interface default

no passive-interface Tunnel1001

no passive-interface Tunnel1010

no passive-interface Tunnel1003

no passive-interface Tunnel1008

no passive-interface Tunnel1007

no passive-interface Tunnel1011

no passive-interface Tunnel1004

eigrp router-id 192.168.255.254

!

router ospf 1

router-id 192.168.255.254

area 0 range 172.18.254.0 255.255.255.0 cost 10

area 0 range 192.168.254.0 255.255.255.0 cost 10

area 16 stub

area 16 range 10.0.0.0 255.0.0.0 cost 20

area 16 range 172.16.0.0 255.255.0.0 cost 10

area 16 range 172.20.0.0 255.255.0.0 cost 20

area 16 range 192.168.255.0 255.255.255.0

summary-address 192.168.255.0 255.255.255.0

summary-address 10.0.0.0 255.0.0.0

redistribute static subnets

redistribute eigrp 1 subnets

redistribute bgp 65000 subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

no passive-interface FastEthernet0/3/0

no passive-interface Tunnel1

network 172.16.0.0 0.0.255.255 area 16

network 172.18.254.0 0.0.0.255 area 0

network 192.168.255.0 0.0.0.255 area 16

maximum-paths 2

default-information originate

!

---------------------------------------------------------

R2:

---------------------------------------------------------

!

interface Tunnel1011

...

ip summary-address eigrp 1 10.0.0.0 255.0.0.0

ip summary-address eigrp 1 192.168.255.0 255.255.255.0

...

!

router eigrp 1

network 172.17.0.0

redistribute bgp 65000

redistribute ospf 1 match external 1

passive-interface default

no passive-interface Tunnel1008

no passive-interface Tunnel1001

no passive-interface Tunnel1010

no passive-interface Tunnel1003

no passive-interface Tunnel1007

no passive-interface Tunnel1011

no passive-interface Tunnel1004

eigrp router-id 192.168.255.253

!

router ospf 1

router-id 192.168.255.253

area 0 range 172.18.254.0 255.255.255.0 cost 10

area 0 range 192.168.254.0 255.255.255.0 cost 10

area 16 stub

area 16 range 10.0.0.0 255.0.0.0 cost 20

area 16 range 172.16.0.0 255.255.0.0 cost 10

area 16 range 172.20.0.0 255.255.0.0 cost 20

area 16 range 192.168.255.0 255.255.255.0

summary-address 10.0.0.0 255.0.0.0

summary-address 192.168.255.0 255.255.255.0

redistribute static subnets

redistribute eigrp 1 subnets

redistribute bgp 65000 subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

no passive-interface FastEthernet0/3/0

no passive-interface Tunnel1

network 172.16.0.0 0.0.255.255 area 16

network 172.18.254.0 0.0.0.255 area 0

network 192.168.255.0 0.0.0.255 area 16

maximum-paths 2

default-information originate

!

---------------------------------------------

OSPF neighbors

---------------------------------------------

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

...

192.168.255.253   1   FULL/DR         00:00:31    172.16.255.253  FastEthernet0/3/0

...

----------------------------------------------

RT for 192.168.255.... on R1:

----------------------------------------------

R1#sh ip route 192.168.255.0

Routing entry for 192.168.255.0/24, 15 known subnets

  Attached (2 connections)

  Variably subnetted with 2 masks

  Redistributing via nhrp

D        192.168.255.0/24 is a summary, 19:12:30, Null0

O        192.168.255.1/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

O        192.168.255.2/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

O        192.168.255.3/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

D        192.168.255.4/32 [90/1920000] via 172.17.254.229, 20:17:44, Tunnel1004

O        192.168.255.6/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

O        192.168.255.7/32 [110/6] via 172.16.254.7, 03:47:43, Tunnel1

O        192.168.255.8/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

O        192.168.255.9/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

O        192.168.255.10/32 [110/7] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

B        192.168.255.11/32 [20/0] via 172.18.254.2, 5w0d

B        192.168.255.12/32 [20/0] via 172.18.254.2, 3d01h

O        192.168.255.253/32 [110/2] via 172.16.255.253, 03:47:43, FastEthernet0/3/0

C        192.168.255.254/32 is directly connected, Loopback0

C        192.168.255.255/32 is directly connected, Loopback255

R1#

------------------------------------------

RT for 192.168.255... on R2:

-------------------------------------------

R2#sh ip route 192.168.255.0

Routing entry for 192.168.255.0/24, 14 known subnets

  Attached (2 connections)

  Variably subnetted with 2 masks

  Redistributing via nhrp

D        192.168.255.0/24 is a summary, 19:19:48, Null0

O        192.168.255.1/32 [110/6] via 172.16.253.1, 19:20:16, Tunnel1

O        192.168.255.2/32 [110/6] via 172.16.253.2, 19:20:16, Tunnel1

O        192.168.255.3/32 [110/6] via 172.16.253.3, 19:20:16, Tunnel1

O        192.168.255.6/32 [110/6] via 172.16.253.6, 19:20:16, Tunnel1

O        192.168.255.7/32 [110/6] via 172.16.253.7, 19:20:16, Tunnel1

O        192.168.255.8/32 [110/6] via 172.16.253.8, 19:20:16, Tunnel1

O        192.168.255.9/32 [110/6] via 172.16.253.9, 19:20:16, Tunnel1

O        192.168.255.10/32 [110/6] via 172.16.253.10, 19:20:16, Tunnel1

B        192.168.255.11/32 [20/0] via 172.18.254.6, 5w0d

B        192.168.255.12/32 [20/0] via 172.18.254.6, 3d01h

C        192.168.255.253/32 is directly connected, Loopback0

O        192.168.255.254/32

           [110/2] via 172.16.255.254, 03:48:09, FastEthernet0/3/0

C        192.168.255.255/32 is directly connected, Loopback255

R2#

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: EIGRP dont'n redistribute routes into OSPF

Hello Anton,

you have answered by yourself.

Area 16 is a stub area so no external routes are injected into area 16 and Fas0/3/0 IP subnet is within 172.16.0.0/16 that is associated to area 16.

As a result of this routes imported from EIGRP that would be external routes are not seen in area 16 they are all blocked at area border as no LSA type 4 or LSA type 5 can exist within an OSPF stub area

Hope to help

Giuseppe

7 REPLIES
New Member

Re: EIGRP dont'n redistribute routes into OSPF

I seem understood in what a problem...

...is that routes of EIGRP will be presents as external for OSPF, and OSPF area 16 (where R1 and R2) is stub area, where all external routes installed in RT as 0.0.0.0/0.

Didn't check still... but can be there are other thoughts?

Hall of Fame Super Silver

Re: EIGRP dont'n redistribute routes into OSPF

Hello Anton,

you have answered by yourself.

Area 16 is a stub area so no external routes are injected into area 16 and Fas0/3/0 IP subnet is within 172.16.0.0/16 that is associated to area 16.

As a result of this routes imported from EIGRP that would be external routes are not seen in area 16 they are all blocked at area border as no LSA type 4 or LSA type 5 can exist within an OSPF stub area

Hope to help

Giuseppe

New Member

Re: EIGRP dont'n redistribute routes into OSPF

There is a problem isn't decided: in addition to a Stub-zone, it was necessary to delete ip summary-address eigrp 1 on interface Tun1011 (because router won't send out specific route if manual or auto summ is enabled), but all the same redistributions in OSPF isn't present, :

--------------------------------------------------------

R1:

--------------------------------------------------------

...

router ospf 1

...

redistribute eigrp 1 subnets

...

router bgp 65000

...

redistribute eigrp 1 route-map RMAP-EIGRP-TO-BGP

...

--------------------------------------------------------

Show detailed info for specific route:

--------------------------------------------------------

R1#sh ip route 192.168.255.4

Routing entry for 192.168.255.4/32

  Known via "eigrp 1", distance 90, metric 1920000, type internal

  Redistributing via eigrp 1, ospf 1, bgp 65000

  Advertised by bgp 65000 route-map RMAP-EIGRP-TO-BGP           <--- only to BGP and not to OSPF! Why?

  Last update from 172.17.254.229 on Tunnel1004, 3d20h ago

  Routing Descriptor Blocks:

  * 172.17.254.229, from 172.17.254.229, 3d20h ago, via Tunnel1004

      Route metric is 1920000, traffic share count is 1

      Total delay is 55000 microseconds, minimum bandwidth is 5000 Kbit

      Reliability 255/255, minimum MTU 1400 bytes

      Loading 1/255, Hops 1

Hall of Fame Super Silver

Re: EIGRP dont'n redistribute routes into OSPF

Hello Anton,

Has R1 got OSPF neighbors in area 0? if all OSPF neighbors are in area 16 the answer is the same.

I guess R1 has some OSPF neighbors in area 0.

Edit:

in any case on R1 router ospf configuration there is the following line:

> summary-address 192.168.255.0 255.255.255.0

with this line all routes within 192.168.255.0/24 of type external are summarized in a single external route. Component  routes like 192.168.255.4/32 are not advertised. Check if 192.168.255.0/24 is advertised in OSPF.

Hope to help

Giuseppe

New Member

Re: EIGRP dont'n redistribute routes into OSPF

Thanks Giuseppe! Yes, summary-address 192.168.255.0 255.255.255.0 in OSPF blocks all specific routes. After delete this config the route advirtised. Though in it is told that:

"...router won't send out specific route if manual or auto summ is enabled."

,but subnet/route '192.168.255.4/32' advertised even if in interface Tun1011 present ip summary-address eigrp 1 192.168.255.0 255.255.255.0 !

Hall of Fame Super Silver

EIGRP dont'n redistribute routes into OSPF

Hello Anton,

in EIGRP the manual summarization is performed outbound an interface, a component route can be advertised out of other EIGRP enabled interfaces. It shouldn't be advertised out of the interface in which summary eigrp is configured unless a leak-map is used see

http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_eigrp/command/ire-i1.html#GUID-F65B16C1-6E09-4C15-80DC-22B0537B1C9A

In OSPF manual summarization of OSPF external routes is performed at OSPF process level and it is global.

Hope to help

Giuseppe

New Member

Re: EIGRP dont'n redistribute routes into OSPF

Ok! Thanks to you and Cisco! EIGRP the most flexible protocol in any network infrastructure . Theme is closed.

1338
Views
5
Helpful
7
Replies
CreatePlease to create content